Results 1 to 29 of 29

Thread: Mesh Flickering

  1. #1
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default Mesh Flickering

    Hi guys,

    I've got a skeletal mesh, that looks fine in the viewer in the editor, looks fine when placed as a skeletalmeshactor in the game, but flickers between being visible and invisible and does not display correctly when used as a pawn mesh.

    Any ideas?

  2. #2
    Marrow Fiend
    Join Date
    Jul 2006
    Location
    UT40k
    Posts
    4,634

    Default

    the only thing i can think of is the MIC not being parented properly
    UT40K:The Chosen - Warhammer 40,000 for UDK
    ut40kgeodav - UE4 Tutorials
    UT3 Tutorials - Characters - Weapons - Vehicles - FaceFX
    UDK Tutorials - Basics - Vehicles - Characters - Weapons

  3. #3
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    It's not the material - it's the actual mesh.

    Thanks anyway!

  4. #4
    Prisoner 849
    Join Date
    Oct 2006
    Location
    Hurstville, NSW.
    Posts
    864
    Gamer IDs

    Gamertag: KazeoHin

    Default

    The only time I've seen that is when the Origin is not centered on the asset and the asset does not use exact occlusion information. But, I don't have as much experience with Skelmeshes and code as others.

  5. #5
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Hmm, I'll pass that on to the artist. The mesh seems to be centered properly, but it could be related.

    thanks!

  6. #6
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Posts
    79

    Default

    Most of the vehicle's geometry is not 100% enclosed. Would that contribute to the issue at all? I really hope not, because that would be a major pain to fix.

  7. #7
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Had a chat with the artist. Could this be the result of not using fully enclosed geometry?

    Edit: lol, instaposted.

  8. #8
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Update: Fully enclosed geometry also flickers. I'd really like to have this solved by this weekend.

  9. #9
    Prisoner 849
    Join Date
    Oct 2006
    Location
    Hurstville, NSW.
    Posts
    864
    Gamer IDs

    Gamertag: KazeoHin

    Default

    Is the mesh using a translucent material, and if so, is the sort priority the same as other translucent materials in the scene?

  10. #10
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    The mesh uses a simple test material that just include diffuse and normal texture maps. Applying any other material yields the same results; like I said before, it's not the material.

  11. #11
    Palace Guard

    Join Date
    Jun 2007
    Location
    Christchurch
    Posts
    3,781

    Default

    The only time I've noticed this behaviour is if I happen to have VLC or some other video media player playing. I'm not 100% sure why, but if I open VLC to watch something (The Simpsons) while I code and test UDK games ... it seems to occur.

  12. #12
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    I doubt it's that - it's only one skeletal mesh, and it's consistent across various machines.

  13. #13
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Jacksonville, Fl.
    Posts
    456

    Default

    Sometimes 3d files just go whacky.
    Try beating it into submission. When all else fails export it to some older format like 3DS or OBJ and reimport it into your 3d App.

  14. #14
    Palace Guard

    Join Date
    Jun 2007
    Location
    Christchurch
    Posts
    3,781

    Default

    Could be video card drivers? I'll do some testing on my machine and see if I get the same problems.

  15. #15
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Like I said, it's consistent across multiple machines, and it's just this one mesh. I'll try and get a video shortly.

  16. #16
    Palace Guard

    Join Date
    Jun 2007
    Location
    Christchurch
    Posts
    3,781

    Default

    Haven't been noticing it myself as of late. Perhaps your confuddling the occlusion system?

  17. #17
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    We created a simple cube mesh and still get the same results.

    Ok, the results of some testing with various mesh, material and physics asset:

    Mesh does not flicker when:
    • We use the default UDK pawn mesh, material and assign no physics asset.
    • We use the Cicada mesh, Cicada material and Cicada physics asset.


    Mesh does flicker when:
    • We use our mesh, but default pawn material.
    • We use default mesh, but our material.
    • We use default pawn mesh and material, but assign our physics asset.

  18. #18
    Palace Guard

    Join Date
    Jun 2007
    Location
    Christchurch
    Posts
    3,781

    Default

    I'll see if I can duplicate these issues ambershee.

  19. #19
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Cheers. I'm about to go through every combination of settings and take note of the results.

    I'll be checking against every combination of:

    Default mesh versus Cicada mesh versus custom mesh
    Material versus MaterialInstance versus MaterialInterface
    Default material versus Cicada material versus custom material

  20. #20
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Ignoring my previous post, here's the results of the tests I just ran. Without a doubt, it's the mesh itself that is the issue:

    Code:
    			Default Mesh	Cicada Mesh	Custom Mesh
    mat Default		Works		Works		Flickers
    mInst Default		Works		Works		Flickers
    mInt Default		Works		Works		Flickers
    mat Cicada		Works		Works		Flickers
    mInst Cicada		Works		Works		Flickers
    mInt Cicada		Works		Works		Flickers
    mat Custom		Works		Works		Flickers
    mInst Custom		Works		Works		Flickers
    mInt Custom		Works		Works		Flickers
    I've attached the package in question containing the mesh.
    Attached Files Attached Files

  21. #21
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Moving to the March build appears to have solved the problem.

    Now to sort out three-weeks worth of undone code done by the difference in the codebase xD

  22. #22

    Default

    I'm having this problem with the latest edition of the UDK. My skeletalmesh flickers, any advice would be great. It's not a playable character just a skeletalMesh used with matinee for a cutscene.

    Thanks

    Dann

  23. #23
    Veteran
    Join Date
    Sep 2006
    Location
    Unreal Nomad
    Posts
    7,682
    Gamer IDs

    Gamertag: ambershee

    Default

    Yeah, I've also heard of one other person also having this problem, albeit with a playable character. There does seem to be a genuine issue creeping in somewhere.

  24. #24

    Default

    Ooh I think I've solved it. Don't know if it's a combination of things but settings the physics asset seemed to fix it. I also made quite a large non-colliding & no mass collision sphere on the asset. Hope this helps someone

  25. #25
    Iron Guard
    Join Date
    Dec 2007
    Posts
    775
    Gamer IDs

    Gamertag: m3maestro

    Default

    This happens to me all the time when the root bone of the mesh goes out of the view of the camera. The physics asset should help a lot but won't solve it 100% (at least it didn't in my case)

    Dan Reese, I put a fix for this on my site somewhere. You can parent the root to the mesh. so it never leaves site of the cam.

  26. #26
    MSgt. Shooter Person
    Join Date
    Feb 2010
    Posts
    64

    Default

    i had the same problem but i used a false phys asset for a mesh...
    changed it and it works...

  27. #27

    Default

    I still have the problem even after making a physucs asset. If this is indeed a no solution problem, does anyone have any guideline in order to prevent it? Like how to model or export a character efficiently.
    Thanks anyway!

  28. #28

    Default

    Fix:
    Quote Originally Posted by DannRees View Post
    Ooh I think I've solved it. Don't know if it's a combination of things but settings the physics asset seemed to fix it. I also made quite a large non-colliding & no mass collision sphere on the asset. Hope this helps someone
    Issue:
    Quote Originally Posted by m3fs View Post
    This happens to me all the time when the root bone of the mesh goes out of the view of the camera. The physics asset should help a lot but won't solve it 100% (at least it didn't in my case)
    This issue is resolved by applying a physic's asset to the Skeleton Mesh. Then edit the Physic's asset in UnrealPhat and make a new body in the middle of your mesh. Select the new body and check 'No Collision' and scale the body till it is two times the size of your mesh or the end result of the animation.

    My mesh happened to be a stream of water which ran down a spiraling canal using morphs, so the body i ended up with was approximately 10x the size of the original mesh and 2x the size of the end morph.

    It would seem this bug happens when the bodies of a Skeletal Mesh are out of sight of the controlling camera.

    I am using the 01-2012 build of UDK
    Last edited by deadly161; 05-03-2012 at 04:36 AM.

  29. #29
    The Sacrifice
    Join Date
    Jan 2014
    Posts
    247

    Default

    Thank you!!!


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.