Results 1 to 11 of 11
  1. #1

    Exclamation UTPawn skeletalmesh floating

    Hello to all,

    I've been trying to get my own custom skeletalmesh to show up ingame as a bot. So far I've tackled many small things and succeeded, but ofcourse, just because I've won a battle or two doesn't mean I won the war just yet

    My new problem is the fact that my pawn isn't exactly leveled with the ground but floating quite a bit above it:



    Also, when I try to shoot it the PhysicsAssets I've assigned to it seems to be lower than the mesh itself. I can shoot through his head for instance, without the bullet colliding with something.

    I've been trying to fix this all day with no luck. So far I've setup an offset in the SkeletalMesh itself so it seems to be on the floor, but the PhysicsAssets still seems to be lower than the Mesh.

    Though I have a few options left to try I would rather take my chances and post this here in case someone recognizes the problem and can point me into the right direction, for my time is running out on my deadline (school project)

    A few thoughts:
    - Could this have something to do with the PhysicsAssets I've assigned to it according to the UDN tutorial video?
    - Should I change my pivot's position in 3ds Max or something?
    - Should I continue setting up my custom AnimTree? (look at this post for my previous workflow)

  2. #2

    Default

    Just a quick addition: When I click Play From Here I can see the pawn falling on the ground for a mere second, before returning to his floating position..

  3. #3
    Marrow Fiend
    Join Date
    Jul 2006
    Location
    UT40k
    Posts
    4,634

    Default

    in the mesh options change the origin z=-51
    this is required when using the UTPawn
    UT40K:The Chosen - Warhammer 40,000 for UDK
    ut40kgeodav - UE4 Tutorials
    UT3 Tutorials - Characters - Weapons - Vehicles - FaceFX
    UDK Tutorials - Basics - Vehicles - Characters - Weapons

  4. #4

    Default

    Thanks again Geodav for pointing out such small but valuable information. You are a project's lifesaver

    As for the PhysicsAsset appearing to be lower than the Mesh:that wasn't the case at all. My CollisionCylinder was able to take hits from bullets, which clearly shouldnt. I fixed this by adding a line "BlockZeroExtent=FALSE" to the CollisionCylinder code in my Pawn class AND adding "BlockZeroExtent=TRUE" and "CollideActors=TRUE" to my SkeletalMeshComponent code.

    I stumbled upon this here:
    http://udn.epicgames.com/Three/Colli...0Weapon%20Fire

    Now my custom PhysicsAsset takes the damage as it should be

  5. #5
    Marrow Fiend
    Join Date
    Jul 2006
    Location
    UT40k
    Posts
    4,634

    Default

    glad to hear it works

    looking forward to see-ing a video or beta
    UT40K:The Chosen - Warhammer 40,000 for UDK
    ut40kgeodav - UE4 Tutorials
    UT3 Tutorials - Characters - Weapons - Vehicles - FaceFX
    UDK Tutorials - Basics - Vehicles - Characters - Weapons

  6. #6
    MSgt. Shooter Person
    Join Date
    Nov 2007
    Location
    The Netherlands
    Posts
    386
    Gamer IDs

    Gamertag: LennardF1989

    Default

    Instead of using "show bounds", try "show collision" as well. As bounds have pretty much nothing to do with the actual BSP collision.

  7. #7

    Default

    Hey there Lennard. Thanks! I already found the "show collision" command and it helped me figure out some other problems I had with the PhysicsAsset and CollisionCyllinder. Thanks for the reply though

  8. #8
    MSgt. Shooter Person
    Join Date
    Jan 2012
    Posts
    179

    Default

    i assigned my custom mesh to the player so i now i spawn as my custom character but when i got to third person view my player is floating and the camera is like zoomed on its ass so i want to lower it.....and about the z=-51 where do i put that in 3dsmax or in the animset editor i tried in animset editor on the properties where it says bounds but it doesnt work
    zen_shen

  9. #9

    Default

    Quote Originally Posted by geodav View Post
    in the mesh options change the origin z=-51
    this is required when using the UTPawn
    See above for the z options and where to put it (double click your skeletal mesh in the asset window and look for it there).

    As for the 3rd person camera view I'm not sure. How are you implementing that? I'm sure you can set the distance/angle somewhere. Or are you just toggling it with the console command? If the latter -> search these forums for any 3rd person camera examples. There are tons of them out there!

    - Cheers
    Last edited by Mojokin; 05-19-2012 at 11:03 AM.

  10. #10
    MSgt. Shooter Person
    Join Date
    May 2012
    Posts
    30

    Default

    hi
    see here
    Last edited by UDK-Team; 05-19-2012 at 10:52 AM.

  11. #11

    Default

    Thanks for clearing that up! Edited my previous post to avoid confusion..
    Imagination is more powerful than knowledge..


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.