Page 1 of 2 12 LastLast
Results 1 to 40 of 41
  1. #1

    Post Use Visual Studio 2008 with nFringe and UDK

    Quote Originally Posted by 280Z28 View Post
    The tutorial at the beginning of this thread is currently completely wrong for nFringe 1.1.10+. I've posted a much simpler set of instructions on our wiki:

    http://wiki.pixelminegames.com/index...pt:UdkProjects
    I removed the old tutorial since it was for earlier versions of the UDK and nFringe and seemed to be causing confusion. Hopefully that link will stay current for new versions of nFringe and UDK since I haven't been keeping up to date with it lately.
    Last edited by SneakyToB; 05-10-2010 at 04:50 PM. Reason: Removing outdated tutorial

  2. #2
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Texas
    Posts
    77

    Default

    Thanks for this i was having some issues using nfringe.
    Programming is a way of life.

  3. #3
    Redeemer
    Join Date
    May 2000
    Location
    between the monitor and chair
    Posts
    1,523

    Default

    Interesting, that's pretty much the same as I was writing for an UDN document, except that I got stuck with nFringe at "create project".

    Here's last night's version of the document I was working on: http://udn.epicgames.com/Three/Devel...ptProject.html
    Michiel 'El Muerte' Hendriks
    Magicball Network - Little Big Adventure community
    the Unreal Admin page - Unreal server administration
    UnrealWiki - UnrealScript and UnrealEd wiki.
    UnCodeX - powerful UnrealScript tool for programmers

  4. #4

    Default

    Cool, that UDN document was exactly the type of information I was looking for a few days ago. I couldn't find very much so I just tried to figure it out using what I could find and lots of trial and error. Please, feel free to add anything I wrote here to that UDN doc to make it more complete.

    Also, if visual studio won't create a project make sure the folder you are trying to create the project in does NOT already exist.
    Last edited by SneakyToB; 11-11-2009 at 04:33 PM.

  5. #5

    Default

    Quote Originally Posted by SneakyToB View Post
    Why Visual Studio?
    Using Visual Studio with nFringe makes coding unrealscript much easier, mostly because of getting a "Go to definition" link by right clicking in the code, syntax highlighting, and intellisense which shows what functions can be called from various objects.

    Background
    This will explain how I got it working because it wasn't very straight forward, at least not to me.

    To begin, this tutorial will assume you have already installed Visual Studio 2008 (this should work in the free Express edition but I have not tried it). You also need to have installed nFringe by following the instructions. Obviously, you need to have installed UDK as well and make sure you run the UDK game demo at least once before following this tutorial so the config files get generated.

    Next, this tutorial expands on the UDK Programming Tutorial but sets it up to work with Visual Studio. So be sure to download the SuperFunGame.uc sample source code.

    Setup
    1. Create the project in Visual Studio
    • Create a new project of type "UnrealScript" and select "UnrealEngine 3 Licensee Project"
    • Name: enter "SuperFunProject" or whatever you would like the package to be called.
    • Location: pick C:\UDK\UDK-2009-11\Development\Src
    • Uncheck "Create Directory for solution"
    • On the solution drop down leave it on "Create new Solution"
    • Finally, click OK to create the project

    2. Configure the project
    • Right click on the project in the Solution Explorer and click Properties
    • Under General -> Game -> Target Game pick “UnrealEngine 3 Mod” from the drop down menu (this is needed because you can’t set the “Reference Source Path” when using the “UnrealEngine 3 Licensee Project” type.
    • Under General -> Script Compiler -> UCC Path pick: C:\UDK\UDK-2009-11\Binaries\Win32\UDK.exe
    • Under General -> Script Compiler -> Reference Source Path pick: C:\UDK\UDK-2009-11\Development\Src
    • Under Build -> Script Outputs check “Manual set UCC output directory” and set the path to C:\UDK\UDK-2009-11\UTGame\Script
    • Under Debug -> Start Action -> Start Game Executable set the path to C:\UDK\UDK-2009-11\Binaries\Win32\UDK.exe
    • Check “Enable unpublished mods”
    • With the project selected in Solution Explorer, right click, and select Add -> New Folder. Type “Classes” and hit enter. Now any new classes you make should be added under the Classes folder. To follow this tutorial, add "SuperFunGame.uc" which you downloaded above. Right click on "Classes" and select "Add existing item" (make sure you copied it to your Classes folder first in Explorer) then select "SuperFunGame.uc"
    • Finally, close the solution (MUST exit Visual Studio) and then reopen it. This adds all the Reference Source files which is the UDK source code. It also allows Intellisense to work correctly.

    3. Build the project
    • Add an existing file (as a link) to your project from C:\UDK\UDK-2009-11\UTGame\Config\UTEngine.ini. Click the arrow to the right of Add and select "Add as a link". This way it won't copy the file to your project directory.
    • Edit the file and search for “ModEditPackages=” and make sure your mod name package is included there. Add a line: "ModEditPackages=SuperFunGame" if you are following this tutorial (now save and close UTEngine.ini).
    • Make sure the Output window is open in Visual Studio. Now you should be able to build using Visual Studio (press F6) or pick Build -> Build Solution from the menu. You will probably get an error about not being able to find the .NET Framework SDK but you can just ignore it.
    • Check your C:\UDK\UDK-2009-11\UTGame\Script folder for the output of the .u file for the package you just compiled. In this case, there should be a SuperFunGame.u file at that location.
    • Finally, if you see the .u file in there for the package you just build, then you are ready to test it out.

    4. Run the project
    • Under the project properties -> Debug -> Start Action, check “Load map at startup” and type "dm-deck" or whatever map is available
    • Check “Start with specified game type” and type the "ModPackage.Class" such as "SuperFunGame.SuperFunGame"
    • Check “Enable unpublished mods”
    • Check “Open log window at position” and position it wherever
    • Run your project by pressing F5 inside Visual Studio
    • Visual Studio will pop up an information bubble saying that pixel mine doesn’t allow the free non-commercial nFringe to attach to UE3. But it can still be used to run the code and/or look at the log console or output.
    There are corrections on this.

    The quickest way to get this right is instead of naming your project as SuperFunProject as indicated in step 1, name it SuperFunGame. Otherwise, you have to do these corrections:
    Step 3.2: ModEditPackages=SuperFunGame should be ModEditPackages=SuperFunProject
    Step 4.2: SuperFunGame.SuperFunGame should be SuperFunProject.SuperFunGame

    I hope this helps.

  6. #6

    Thumbs up

    Thank you, Death4Hire. I just edited my post above in step 1 to say create a project named "SuperFunGame" instead of "SuperFunProject".

  7. #7
    Redeemer
    Join Date
    May 2000
    Location
    between the monitor and chair
    Posts
    1,523

    Default

    Quote Originally Posted by SneakyToB View Post
    Also, if visual studio won't create a project make sure the folder you are trying to create the project in does NOT already exist.
    I was doing that, but I keep getting an error message that it can not copy the project file from a temp directory. Anyway, I have yet to bother Pixel Mine about this.
    Michiel 'El Muerte' Hendriks
    Magicball Network - Little Big Adventure community
    the Unreal Admin page - Unreal server administration
    UnrealWiki - UnrealScript and UnrealEd wiki.
    UnCodeX - powerful UnrealScript tool for programmers

  8. #8
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Posts
    33

    Default

    Can you debug/Step through unrealscript code with nFringe?
    I'm using WOTgreal now, it works great but a bit slow when edit large script file, and lack of any debugger integration with UDK.

  9. #9
    MSgt. Shooter Person
    Join Date
    Dec 2001
    Posts
    477

    Default

    Then it's not far behind nFringe Debugging doesn't work in UDK, it was purposely locked to UT3.
    Visit us at BeyondUnreal!
    And for a cultured and mature Unreal Engine community, try our forums!

  10. #10

    Default

    Well I have VS2008 and nFringe setup and my project is compiling fine, so many thanks for this thread!

    My question is... Is there anyway of working on scripts within VS2008 at the same time as working in UDK?

    I mean, when I compile the solution within VS2008 I get a build error when the core compiles as the UDK is open. When coding I do tend to build and test constantly which means closing and opening UDK every few minutes.

    Maybe I've missed something obvious or am a total noon!

    Regards,
    Matt.

  11. #11

    Default

    I'm glad this thread was useful for you, fallingbrickwork.

    To answer your question it doesn't look like what you are trying to do is possible even if you compile using the UDK make system and bypass Visual Studio. To recompile the scripts it has to overwrite the existing ones (.u files), which it can't do because they are currently in-use and opened by the UDK editor (if you are running it). So, it looks like the only way around this is to close the UDK editor every time you compile the scripts.
    Last edited by SneakyToB; 11-13-2009 at 04:15 PM.

  12. #12
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Wellington , New Zealand
    Posts
    105

    Default

    Hi

    So got every thing going with nFring up to the pointto do the build solution.
    Im using the new beta2 BTw.

    For some reason it is not generating the .u file.

    Ive down all the above as the tutorial (following this TUT:
    http://www.dl.deathtouchstudios.com/...ldEnvironment/

    THe build says its successful and displays this:
    MyGame -> D:\UDK\UDK-2009-11-2\Development\Src\MyGame\MyGame\Unpublished\Cooked PC\Script\MyGame.u

    (Note the double MyGame\Mygame ...strange?)

    However the MyGame.u never gets made or copied to the UTgame\scripts folder I had specified:
    D:\UDK\UDK-2009-11-2\UTGame\Script

    Any ideas? Any one tried with beta2?

    Its not because IM using a "non-commercial" version of nFringe is it? I'd imagine most people use that?

    Thanks heaps

    -LW

  13. #13
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Montreal
    Posts
    186

    Default

    Anybody knows how to step in into unrealscript and debug with VS ? I know it was advertised somewhere for UDK.
    Engineers like to solve problems. If there are no problems handily available, they will create their own problems.
    Dilbert

    http://x9productions.com/blog
    UDK Isometric Camera tutorial with pathfinding

  14. #14
    MSgt. Shooter Person
    Join Date
    Nov 2007
    Location
    Cambridge, UK
    Posts
    262
    Gamer IDs

    Gamertag: TheSchizoslayer

    Default

    Quote Originally Posted by roychr View Post
    Anybody knows how to step in into unrealscript and debug with VS ? I know it was advertised somewhere for UDK.
    At the moment you can't without a commercial nFringe licence.

  15. #15

    Default

    Quote Originally Posted by LordsWarrior View Post
    For some reason it is not generating the .u file.
    ...
    Same, I did a search in my whole UDK folder No superfunproject.u file anywhere.

    The build output anounce that :
    SuperFunProject -> L:\UDK\Development\Src\SuperFunProject\Unpublished \CookedPC\Script\SuperFunProject.u
    I specified that in the build setup :
    L:\UDK\UTGame\Script
    (note : I installed udk without the "\udk-2009-11-2\")
    Last edited by hide; 11-17-2009 at 01:05 PM.

  16. #16
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Montreal
    Posts
    186

    Default

    Quote Originally Posted by schizoslayer View Post
    At the moment you can't without a commercial nFringe licence.
    Is it me or the nFringe minimum 3500$ for the software is maximum overkill for UDK ? considering that Visual Studio pro is about 600$, they could at least give a version that support debugging and if you release something you have to pay them. I understand they must get paid for this tool, but even T3D + Unity + UDK together does'nt amount to that...

    shame, considering UDK advertised debugging as stock in the engine...
    Engineers like to solve problems. If there are no problems handily available, they will create their own problems.
    Dilbert

    http://x9productions.com/blog
    UDK Isometric Camera tutorial with pathfinding

  17. #17
    MSgt. Shooter Person
    Join Date
    Nov 2007
    Location
    Cambridge, UK
    Posts
    262
    Gamer IDs

    Gamertag: TheSchizoslayer

    Default

    Quote Originally Posted by roychr View Post
    Is it me or the nFringe minimum 3500$ for the software is maximum overkill for UDK ? considering that Visual Studio pro is about 600$, they could at least give a version that support debugging and if you release something you have to pay them. I understand they must get paid for this tool, but even T3D + Unity + UDK together does'nt amount to that...

    shame, considering UDK advertised debugging as stock in the engine...
    Unfortunately nFringe is developed by a company unrelated to Epic so they are allowed to charge whatever they want and Licensees are quite willing to pay the large pricetag of a commercial licence.

    It should be possible to get WoTgreal to work with UDK as UDK is intended to work the same way as the older UT games and not use the odd UT3 mod structure.

  18. #18

    Default

    It compiles fine but I cannot find my *.u file in the script-folder. I cannot find it anywhere. What's wrong? And on starting it claims, that my scripts where outdated and asks me to rebuild...

    Edit: Okay I fixed it. You have to create your solution to the development/src folder.
    Last edited by youkai; 11-17-2009 at 04:18 PM.

  19. #19
    Veteran
    Join Date
    May 2007
    Location
    Above KillZ, Below StallZ
    Posts
    9,986

    Default

    schizo: actually WOT works fine, but it doesn't understand the INI or log files. I haven't heard from Harmon in at least a year and a half now, since the last development update, so I don't think he has any interest in going there. Maybe he hasn't heard about UDK, though.

  20. #20

    Default

    It compiles fine but I cannot find my *.u file in the script-folder!!!

    Help!!!!!!!!!!!SOS

  21. #21
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Ripon, WI
    Posts
    59
    Gamer IDs

    Gamertag: SpartanDonut007

    Default

    I am having the same issue as many of the other people here. It claims to create the file at ..\Development\Src\SuperFunProject\Unpublished \CookedPC\Script\SuperFunProject.u

    However, SuperFunProject.u file is MIA - not to be found in the above location or the UTGame/Script folder I specified.

    Running Windows 7 Pro - 64bit with UAC Disabled (Read this somewhere saying it may help but no go)

    Any thoughts?? =(

  22. #22

    Default

    When i'm in the properties of visual studio i don't have the build tab, it gives me weird error, anyone know how i can manually change the build path

  23. #23
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Ripon, WI
    Posts
    59
    Gamer IDs

    Gamertag: SpartanDonut007

    Default

    Fixed my issue. Turns out I was just being stupid. My UTEngine.ini file had "Packages=MyMod" instead of "ModEditPackages=MyMod"

    Changed it and problem solved.

  24. #24

    Default

    Hey for me it says 'Warning - paths may not be valid' in the log. I've triple checked everything, tried with UDK, the second version of it, reinstalled each about 3 times, but it still says that. Anyway I can fix this??

  25. #25
    Skaarj
    Join Date
    Nov 2009
    Location
    Wichita, KS
    Posts
    8

    Default

    Just in case it helps anyone, at one point I had added the file extention ".uc" to VS2008 to get C++ color coding when viewing scripts. This was then interfering with trying to get things working with nFringe, so if you have problems check for that...

  26. #26

    Default

    I have solved the not generating the .u file in the UTGame\Script folder issue. To fix this issue I took the following steps:

    ..\Development\Src\SuperFunProject\Unpublished \CookedPC\Script\SuperFunProject.u

    Make sure the path it is saving looks like that, chances are it probably doesn't. More than likely it looks like this:

    ..\Development\Src\SuperFunProject\SuperFunProject\Unpublished \CookedPC\Script\SuperFunProject.u

    You need to remove that duplicate path. Just move all the files so there is only one instance of the \SuperFunProject path. After you've done this, head back into UDK and it should tell you your scripts are not up to date. Let them rebuild, and in should generate your SuperFunProject.u file. Now technically, you can go back to Visual Studio and begin editing, but you may have a dead link to your UTEngine.ini file in your project. Just remove and readd the Existing Item link to the UTEngine.ini file, just like you did it in OPs tutorial.

    I know thats not very thorough, go ahead and ask if you are having any problems with this solution.
    Last edited by SpoinkX12; 12-21-2009 at 04:55 PM.

  27. #27

    Default

    ^^ that wasn't my problem I checked the paths and they were set correctly. Still cannot see the .u file after building (even though it says the build succeeded). After I put your .uc file in my classes directory and add it to my project should I see anything change on my solution explorer?? That was one thing I thought was odd was that I didn't see the .uc file after I added it.

    I've tried to search through the UDK folder and I don't see SuperFunGame.u anywhere. I ran the unreal frontend make-->full recomplie and that made the .u file correctly.... but I don't get why it wouldn't make it in VS.

    SuperFunGame's root folder is in the dev/src folder like you asked it to be, I edited the .ini file to 'ModEditPackages=SuperFunGame' also. I read though other people's problems not generating the .u but they dont seem to apply to me... suggestions?

    UPDATE:
    So I was really wondering why my classes folder wasn't showing anything... I tried to add a new class (called SuperFunGame and copy/paste your code into it... which made it appear under classes... however now when I build it'll say the "Ucc" task failed unexpectedly).


    Also I noticed even when there were no classes it tried to make a .u file (which is prolly why I never saw the .u file). But I dont get what I did wrong now =/
    Last edited by BZB; 01-13-2010 at 01:35 AM. Reason: update

  28. #28
    Iron Guard
    Join Date
    Apr 2008
    Posts
    542

    Default

    As should be clear by this point in the thread, I haven't had the chance yet to experiment with UDK and thus clean up the cooperation between it and nFringe. The code editing features should work with it currently, but building and debugging scripts won't.

    nFringe, like UnrealEngine itself, is free for non-commercial use and paid ("expensive" to some) for commercial use. However, we were careful to keep the cost completely practical for commercial development teams and as low as possible yet still have a reasonable expectation of covering the costs of our 2-year development effort in a niche market.

    Before UDK came around, it was easy to rely on Epic's strict mod licensing policy to separate non-commercial use (UT3 mods) from commercial use (anything else). The new policies (pricing and licensing) makes it harder to distinguish between uses with UDK, so before we can offer debugging support under UDK we'll have to resolve the new licensing concerns it brings. While I'd like to say this will be solved by the end of the coming Summer, I think we'll have to just see how it goes.

    If the lack of script debugging under UDK is hindering your development efforts, it can't hurt to let Epic know.
    Last edited by 280Z28; 01-13-2010 at 11:01 AM.

  29. #29

    Default

    ne1 have any ideas why I get that UCC error?

    UPDATE:
    Sigh** I figured it out, I set my UCC path to the UDK.exe.config instead of just UDK.exe ... didn't notice

    I mean when I set the path I clicked on the UDK.exe (which is really the .exe.config).

    Also if you just see that it made the .u file but not giving you an error... make sure you actually have some code in there it can look at... because it'll say that it made a .u file even if there is no code (and thus no .u file will be made).
    Last edited by BZB; 01-13-2010 at 07:01 PM.

  30. #30
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Montreal
    Posts
    186

    Default

    280Z28

    Any contact information for contacting Epic ? Nice job for nFringe, and nice to know Epic and you are trying to get the debugger available, I must say that the ability to debug is one of the thing I hate about Unity3d. Torque3d is complicated for a C++ engine, compared to Ogre3d and that leaves you to make a difference, the only thing that is still a turn off for UDK is the browser gaming being non available.
    Engineers like to solve problems. If there are no problems handily available, they will create their own problems.
    Dilbert

    http://x9productions.com/blog
    UDK Isometric Camera tutorial with pathfinding

  31. #31
    MSgt. Shooter Person
    Join Date
    Mar 2009
    Location
    Victoria, Australia
    Posts
    419

    Default

    Man, I can't even get my files to add to my solution if I use add existing item, it just doesnt appear at all. This is really frustating

  32. #32

    Default

    I installed nfringe and I can create unreal script projects, but I dont see an option for debugging unreal script. I saw it at my university under debug menu, but i dont know how to configure my installation of VS 2008 to have the same functionality. Can someone give me a hint how to enable different debugging modes in VS? Thanks in advance

  33. #33

    Default

    i can't Debug it cause my debug choices are greyed out ^^
    what should i do ?

  34. #34
    MSgt. Shooter Person
    Join Date
    Nov 2009
    Location
    Montreal
    Posts
    186

    Default

    Debugging is not supported yet by nfringe
    Engineers like to solve problems. If there are no problems handily available, they will create their own problems.
    Dilbert

    http://x9productions.com/blog
    UDK Isometric Camera tutorial with pathfinding

  35. #35

    Question

    Maybe I am being stupid or blind, but there is no UTGame folder in my UDK directory!

    This Image Was Automatically Resized by using the Screenshot Tag.  Click to view the full version

    I am using the 04.2010 version. I would be very grateful if anyone of you guys helped me to solve this problem.

    UPD: Haha, problem solved. It turned out that Epic renamed "UTGame" into "UDKGame"!
    # Renamed to UDKGame

    * All the tools now refer to this game as 'UDKGame'
    * UDK content directory is now named UDKGame, not UTGame.
    The tutorial must be updated soon, so no one else is confused. =)
    Last edited by Mr.CG; 04-25-2010 at 02:36 PM. Reason: Problem solved.

  36. #36
    MSgt. Shooter Person
    Join Date
    May 2010
    Posts
    100

    Default

    Ok, so everything builds fine, however I'm not getting my .u file anywhere. This is the error message that I get in the output window.

    ------ Build started: Project: MageWarTD, Configuration: Debug Win32 ------
    Could not locate the .NET Framework SDK. The task is looking for the path to the .NET Framework SDK at the location specified in the SDKInstallRootv2.0 value of the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewor k. You may be able to solve the problem by doing one of the following: 1.) Install the .NET Framework SDK. 2.) Manually set the above registry key to the correct location.
    MageWarTD -> C:\UDK\UDK-2010-04\Development\Src\MageWarTD\Unpublished\CookedPC\ Script\MageWarTD.u
    ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========




    EDIT: On a side note I do have .NET Framework 4.0 installed.

  37. #37
    Iron Guard
    Join Date
    Apr 2008
    Posts
    542

    Default

    Quote Originally Posted by Mastershadow View Post
    Ok, so everything builds fine, however I'm not getting my .u file anywhere. This is the error message that I get in the output window.
    Try again with the latest preview release:
    http://wiki.pixelminegames.com/index...review_Release

    Follow the steps under Building Scripts here:
    http://wiki.pixelminegames.com/index...pt:UdkProjects
    Last edited by 280Z28; 05-08-2010 at 05:35 PM.

  38. #38
    MSgt. Shooter Person
    Join Date
    May 2010
    Posts
    33

    Default

    Quote Originally Posted by Mastershadow View Post
    Ok, so everything builds fine, however I'm not getting my .u file anywhere. This is the error message that I get in the output window.

    ------ Build started: Project: MageWarTD, Configuration: Debug Win32 ------
    Could not locate the .NET Framework SDK. The task is looking for the path to the .NET Framework SDK at the location specified in the SDKInstallRootv2.0 value of the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewor k. You may be able to solve the problem by doing one of the following: 1.) Install the .NET Framework SDK. 2.) Manually set the above registry key to the correct location.
    MageWarTD -> C:\UDK\UDK-2010-04\Development\Src\MageWarTD\Unpublished\CookedPC\ Script\MageWarTD.u
    ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========




    EDIT: On a side note I do have .NET Framework 4.0 installed.
    Don't mind the SDK warning. I get the same thing and I have 3.5 installed. As for the .u file not showing up. If you followed the tutorial correctly, it should be in the C:\UDK\UDKGame\Script folder if you are using April Beta UDK or C:\UDK\UTGame\Script folder if you are using March Beta.

  39. #39
    Iron Guard
    Join Date
    Apr 2008
    Posts
    542

    Default

    Quote Originally Posted by waterxyro View Post
    If you followed the tutorial correctly
    The tutorial at the beginning of this thread is currently completely wrong for nFringe 1.1.10+. I've posted a much simpler set of instructions on our wiki:

    http://wiki.pixelminegames.com/index...pt:UdkProjects

  40. #40
    Redeemer
    Join Date
    Nov 2009
    Location
    Help-me!
    Posts
    1,267

    Default

    I can't change the folder for my solution, I changed all the configurations but the solution is still being build on the march build, instead of april.

    D:

    Edit: Actually, it's not being build anywhere!
    o.o?

    Does it need to be at the development/src folder?

    Edit2:

    Ok, bunch of errors:

    I installed a new fresh UDK, the april build.
    I did a new solution at development/src named UdkProject
    The Classes folder was being created at development/src instead of development/src/UdkProject
    Every time I tried testing, it game me the warning "there is no *.u files at development/src/UdkProject/Classes" but the folder is not even there
    Now I removed the line #+EditPackages=UdkProject from DefaultEngine.ini, but when I try to debug I get the hovering game controller, instead of the default UI and player.

    Edit3: Forget that, moved the visual studio files to inside UdkProject folder, changed to unreal 3 mod and defined Reference Source and everything is working now
    Last edited by Saishy; 05-08-2010 at 11:52 PM.
    Lead Programmer
    It's the Only NEET Thing to Do

    Programming for non-fiction.
    I'm the function of my code. Conditions are my body and calls are my blood. I have input over a thousand lines. Unknown of bugs, nor known to work. Have withstand coffee to create many programs. Yet, those hands will never code anything again. So, as I pray, Unlimited Code Works.


 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.