I have the german version. I installed an english patch. Is it possible for that to cause errors ?

Also, from where can I download the lastest german patch ?

Thanks in advance.