Results 1 to 6 of 6
  1. #1

    Default Low performance (FPS drops)

    Since i bought the game recently i found some framerate drops, which might be insignificant on small servers like CTF or DM, but on the big Warfare servers, my framerate drops several times to 30 or less.

    A fast paced game like this one should be played with a constant FPS (60).

    I found out that low or high settings get the exact same results.

    What kind of framerate should i be getting with these specs?

    Specs: Q6600@2.4GHz , 8800GT, 4GB RAM, Asus P5K SE/EPU, Win XP64 (if it matters anyway)

  2. #2

    Default

    You should be getting 60fps - 90fps depending on if you have Vsync or Frame Smoothing enabled.

    Also ran into this problem once and saw others also having it. Mine is fixed now but I'm not sure of what the exact cause was. Wanna figure this one out so I know what to do if it happens again. Could be steam, UT3, or the Graphics drivers. What graphics ddrivers you using btw?

    Lets try something:
    1. Upload your UTEngine.ini file and pm me the link
    (located here: My Games\Unreal Tournament 3\UTGame\Config)
    You can use www.sendspace.com (no registering etc required)

    2. After that delete your entire config folder (My Games\Unreal Tournament 3\UTGame\Config). Just keep your serial handy, because your gonna have to re-enter it.

    3. Run the game as you normally would. Change the resolution to 1280x1080. Take off Vsync and framerate smoothing.

    4. Try hosting a normal LAN game on dm-Rising Sun. Put in about 5 bots.

    5. Type in stat fps in the console (F10) and see if your framerates drop below 90 during the match.

    6. Tell me if your game is still giving performance issues. If it works please also upload that UTEngine.ini file so that I can compare them.

    If not I'm going to compare some settings of your UTEngine.ini to mine.
    I also have a 8800GT so I should be able to spot the problem quite easily.

    I'm exspecially interested in these:

    [Engine.ISVHacks]
    HTML Code:
    bInitializeShadersOnDemand=False
    DisableATITextureFilterOptimizationChecks=True
    UseMinimalNVIDIADriverShaderOptimization=True
    PumpWindowMessagesWhenRenderThreadStalled=False
    [AppCompat]
    HTML Code:
    MeasuredCPUScore=429.832001
    CompatLevelComposite=3
    CompatLevelCPU=5
    CompatLevelGPU=3

  3. #3

    Default

    Thank you for helping out.

    Well, i started a lan dm match on Rising Sun with that resolution and all eye candy on as usual, and the framerate started out high around 110, but after a while it dropped to a range of 60-90, only going up to 130 when i died for a couple of seconds (yeah i know i get owned by bots).

    That framerate is obviously acceptable, but the framerate drops persist with populated servers, going as low as 18 FPS once on that underground warfare map on some caves, and as low as 35 in a iCTF server.

    Btw i turned on a setting before on UTEngine called forcestaticterrain, and that setting does a "Precaching" before the start of the map, and even after deleting the config folder that setting is still active, even if the value is at "false". Strange.

    I sent you the link to the ini file.

    Thanks again.

  4. #4

    Default

    Ok gonna take a while to find the real cause since there's a few possibilites. Warfare seems to eat the fps or it's the map. But there's a definate problem in fps drops when I used your ini. Went to 20-30 for a few seconds and fps was averaging 40-50.

    Try my ini for now.
    Just rename file to UTEngine.ini and replace yours.
    http://www.sendspace.com/file/cz0udp

    WAR-FreeDuskMine 20bots fightng in the middle
    Absolute minimum fps 40 explosions + chaos for a few split seconds. Average about 60-70 in action. 90+fps when not in the middle and semi out of action.

    I'm using the 182.06 drivers atm btw.

    The two number one performance hitters seem to be:
    1. Quality bloom
    2. Dynamic shadows

    Both of which were enabled in your ini, but not the cause of the 20-30fps ultra drops.

    The possible causes so far is the folowing:
    Something else that was different was my onethreadlag was set to true. Yours to false.

    Your forcestaticterrain was set to True, mine was false.

    PS. Is fps limited to 90 in LAN. Know it's limited to 90 online?

  5. #5

    Default

    Checking the box for "disable one thread lag" drops the fps by 20-30...
    That + Quality bloom alone kills performance expecially in WAR.

    Looks like that was the biggest cause of your problem.
    One thread Lag should be true is you got a 8800Gt class card

    One thread lag : Enabled by default for higher fps and smoother gameplay.
    Disable one thread lag : Makes your mouse and input lot more responsive. Warning, has sever impact on performance.

  6. #6

    Default

    Ok, your ini definitely gets better results.

    DM -> average 110, always over 60
    WAR -> average 70, lowest ever 40 but just for less than a second

    I'll be sure to tweak it some more if it gets lower, but i doubt it.

    Thanks man, i knew i had to get better FPS lol


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.