Results 1 to 7 of 7
  1. #1

    Default Why is Gears of War PC Laggy!?

    I just want to know why don't they fix this? The game gets so freakin laggy, I sometimes am getting shot and I don't even know it. I'm just getting tired of it, they need to fix this. Or does someone already know how to fix this?
    I have a Intel Q6600 clocked at 3.2Ghz, 2GB DDR2 854Mhz, and a 512MB Geforce 8800 GTS. I play the game Max setting at 1280 x 720. Is it my computer or is it the game?

  2. #2
    MSgt. Shooter Person
    Join Date
    Dec 2007
    Posts
    198

    Default

    It's not so much lag as it is stutters, choppiness, hitching, etc, which is different. It has to do with boat loads of textures being loaded at once. It's common that it doesn't run smoothly even on high end rigs.

    The best thing for smoothing out the stutters is using a texture lod config tweak whereby you lower the texture lod settings in the config files. Just do a search for it, it's been posted numerouns times.

    If you can't find it let me know and I'll dig it up. I use the first settings I saw on Gamespot before I saw them posted here. Others have gone with even lower settings recently in a thread I saw. Last time I posted the settings I use I got a response saying it worked very well for others.

  3. #3
    MSgt. Shooter Person
    Join Date
    Apr 2008
    Posts
    35

    Default

    Stutter is the word.

    And it stutters like absolute hell.

    One thing you can do is find the file WarEngineUserSettings. Search for it. It is in your games folder.

    Open it and change the "OnlyStreamInTextures=FALSE" to "OnlyStreamInTextures=TRUE".

  4. #4

    Default

    yea, some get the stutters, some don't

    after all the patches, i personally only get the stuttering at loading points in levels where the 360 version also stutters
    "Mmmm... giblets." - Akasha

  5. #5
    MSgt. Shooter Person
    Join Date
    Jan 2008
    Posts
    219

    Default

    Don't use AA, run in Dx10 (much smoother--XP users are SoL), disable triple-buffering and multi-sampling, set "max prerendered frames" to "1," use the newest drivers available, update DirectX, defrag, and if you've got enough RAM (x64 users), disable your paging file. Smooth as butter. . ..

  6. #6

    Default

    automatic V-Sync is the main problem. game is capped at 62 fps. when your fps drops beneath that numbre your fps will be capped in half to empty the V-sync buffer.
    this means you'll be switching stuttering between 62 en 31 fps and that is an big gap!

    why have an option in the menu when it is already enabled.

  7. #7
    MSgt. Shooter Person
    Join Date
    Oct 2007
    Posts
    153

    Default

    There are différent types of stutterings, The one you are speaking of yoshimatsu is certainly the streaming problem (big pauses generaly at the same points or during certain battles of the game). The problem is there for a lot of people I guess as I tested on three totally différent PCs and experienced it on each.

    So sad they did not succeed with the streaming routine.. or just took the decision to impose some loading pauses at some keypoints of the game, i would have prefered, really.

    Anyway the streamingonlytextures switch and the lod tricks seems to work for some, not really for others. Patches have reduced the problem to a level I would call "playable". anyway it is only a bad moment to pass as multi doesn't suffer that problem, so once you finished the game, just enjoy the multiplayer experience .
    Last edited by [ST2]Unborn; 04-23-2008 at 04:16 AM.


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •