Results 1 to 14 of 14
  1. #1
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default UCC Make problems

    I'm having problems getting ucc make to work. I can't describe the problem any better, because I don't really know what the problem is. Anyway, in the ucc.log file, everything runs along fine until this point:

    Warning: Failed to load '..\GUIRes\ScatterRocket.u': Can't find file '..\GUIRes\ScatterRocket.u'
    Warning: Error deleting file 'System\Save.tmp' (0x3)
    Critical: Error opening file
    Exit: Executing UObject::StaticShutdownAfterError
    Critical: UObject::SavePackage
    Critical: UMakeCommandlet::Main
    Exit: Exiting.
    Log: FileManager: Reading 0 GByte 104 MByte 476 KByte 680 Bytes from HD took 0.751997 seconds (0.528997 reading, 0.223000 seeking).
    Log: FileManager: 0.470998 seconds spent with misc. duties
    Uninitialized: Name subsystem shut down
    Uninitialized: Log file closed, 03/23/04 00:22:46

    I think it has to do something with this "Save.tmp" file, but I don't know why it's deleting or what other problems it has...

    I'd really appreciate any help anyone can give me.

    Thanks

  2. #2
    Iron Guard
    Join Date
    Feb 2004
    Posts
    699

    Default

    DO you get that same error in the dos window as well? That is a seriously f-ed up error right there. When and why would a temp file even exist to be deleted?

    Make sure the temp file isnt read only.

  3. #3
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default

    The only error that is output by the program is

    "Error opening file

    History: UObject::SavePackage <- UMakeCommandlet::Main

    Exiting due to error"

    The "Save.tmp" file is created by ucc. In other cases (on a friend's computer), I've seen that it gets moved to "PackageName.u", once the compilation is completed.

    It seems to me like something's going wrong somewhere and ucc suddenly decides it's time to delete the temp file.

  4. #4
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default

    And, just for reference, here's what a friend's log file outputs (after the fail to load the GUIRes .u file):

    "Log: Save=38.686596
    Log: Moving 'Save.tmp' to 'MantaMutators.u'
    Log: Success - 0 error(s), 0 warning(s)
    Exit: Preparing to exit.
    Log: Purging garbage
    Log: Unbound to Core.dll
    Log: Unbound to Editor.dll
    Log: Unbound to Engine.dll
    Exit: Editor shut down
    Log: Unbound to Fire.dll
    Log: Unbound to Onslaught.dll
    Log: Unbound to IpDrv.dll
    Log: Unbound to XGame.dll
    Log: Unbound to XInterface.dll
    Log: Unbound to UWeb.dll
    Log: Garbage: objects: 31910->0; refs: 0
    Exit: Object subsystem successfully closed.
    Exit: Exiting.
    Log: FileManager: Reading 0 GByte 42 MByte 596 KByte 542 Bytes from HD took 0.272000 seconds (0.184000 reading, 0.088000 seeking).
    Log: FileManager: 0.046000 seconds spent with misc. duties
    Uninitialized: Name subsystem shut down
    Uninitialized: Allocation checking disabled
    Uninitialized: Log file closed, 03/23/04 00:22:30 "

    It's a different package, but the same error occurs. Also, it may be important to note that this happens with every package. I've tried recompiling the .uc files exported from UnrealEd (specifically, IpDrv), and I get the same error.

  5. #5
    Boomshot
    Join Date
    Mar 2002
    Posts
    2,475

    Default

    Originally posted by WeevahMatic
    ...I've tried recompiling the .uc files exported from UnrealEd (specifically, IpDrv), and I get the same error.
    Don't try to recompile the UT200x source! (runs around screaming).

  6. #6
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default

    I only tried it to see if I got the same error, which I did. I wouldn't have done it otherwise. And I didn't delete the .u file, I just moved it to check if I was right, then moved it back, so calm down.

    Also, that doesn't help me any.
    Last edited by legacy-WeevahMatic; 03-23-2004 at 11:16 AM.

  7. #7
    Iron Guard
    Join Date
    Feb 2004
    Posts
    699

    Default

    Does the file 'System\Save.tmp' exist right now?

  8. #8
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default

    No. I've tried creating an empty Save.tmp file, but then I get an error that it's reading past the end of the file...
    But I can't seem to recreate that error now... Now it's just giving me the same thing it did before, "Error deleting file..."

    I've tried to catch the Save.tmp file created in my System directory, but UCC does all it's stuff so fast I can't catch it. It does cause Windows Explorer to refresh the folder, though, so I'm pretty sure the file is being created... Although that doesn't explain why it's not doing anything to the empty Save.tmp I created...

    I know this is a wierd error. Thanks for all the help you've already given me.
    (Or at least, tried to give me. )

  9. #9
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default

    Decided I'd post an entire log file, just in case it clues anyone in to anything important.

    "Log: Log file open, 03/23/04 16:52:38
    Init: Name subsystem initialized
    Init: Detected: Microsoft Windows XP 5.1 (Build: 2600)
    Init: Version: 3186 (127.29)
    Init: Compiled: Mar 3 2004 02:43:29
    Init: Command line: -ini=UT2004_newmanta.ini
    Init: Character set: Unicode
    Init: Base directory: D:\Games\UT2004\System\
    Init: Ini:UT2004_newmanta.ini UserIni:User.ini
    Init: Build label: Build UT2004_Build_[2004-03-03_02.42]
    Init: Object subsystem initialized
    Log: Executing Class Editor.MakeCommandlet
    Heading: -------------------------Onslaught - Release--------------------------
    Heading: -----------------------MantaMutators - Release------------------------
    Warning: Failed to load 'MantaMutators.u': Can't find file 'MantaMutators.u'
    Warning: Failed loading package: Can't find file 'MantaMutators.u'
    Log: Analyzing...
    Log: FactoryCreateText: Class with ClassFactoryUC (0 1 MantaMutators\Classes\MutSuperManta.uc)
    Log: Class: MutSuperManta extends Mutator
    Log: Imported: Class MantaMutators.MutSuperManta
    Log: FactoryCreateText: Class with ClassFactoryUC (0 1 MantaMutators\Classes\SuperManta.uc)
    Log: Class: SuperManta extends ONSHoverBike
    Log: Imported: Class MantaMutators.SuperManta
    Log: Parsing MutSuperManta
    Log: Parsing SuperManta
    Log: Compiling MutSuperManta
    Log: Compiling SuperManta
    Log: Importing Defaults for MutSuperManta
    Log: Importing Defaults for SuperManta
    Log: Success: Compiled 31 line(s), 5 statement(s).

    Warning: Failed to load '..\GUIRes\MantaMutators.u': Can't find file '..\GUIRes\MantaMutators.u'
    Warning: Error deleting file 'System\Save.tmp' (0x3)
    Critical: Error opening file
    Exit: Executing UObject::StaticShutdownAfterError
    Critical: UObject::SavePackage
    Critical: UMakeCommandlet::Main
    Exit: Exiting.
    Log: FileManager: Reading 0 GByte 42 MByte 597 KByte 639 Bytes from HD took 0.363000 seconds (0.237000 reading, 0.126000 seeking).
    Log: FileManager: 0.368999 seconds spent with misc. duties
    Uninitialized: Name subsystem shut down
    Uninitialized: Log file closed, 03/23/04 16:52:43"

    Like I said, everythink looks good until the Save.tmp line...

  10. #10
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default Fixed!?

    I think I've fixed it! Yay!

    For anyone interested:

    The problem is something I should've noticed before, but should have never been a problem to start with. It says it couldn't delete "System\Save.tmp". As it turns out, it wanted a subdirectory of System, named System, with Save.tmp in it. So, now, ucc creates a file with the path: D:\Games\UT2004\System\System\Save.tmp

    Now, I never remember reading anything about making a subdir of System called System, so I don't know why it wanted a subdir. Maybe I'm missing something. Regardless, it works now and I'm happy.

    However, if anyone knows why it'd be wanting a subdir, I'd appreciate knowing how to fix it.

  11. #11
    MSgt. Shooter Person
    Join Date
    Jul 2002
    Posts
    303

    Default

    It's probably a bug. I remember I have had that error aswell.

  12. #12
    Skaarj
    Join Date
    Mar 2004
    Posts
    21

    Default

    Many thanks this avoided me major headache...

  13. #13
    MSgt. Shooter Person
    Join Date
    Mar 2004
    Posts
    32

    Default

    Good. I was hoping this would help someone else... And it's nice to know I'm not the only one.

  14. #14
    MSgt. Shooter Person
    Join Date
    Feb 2004
    Posts
    87

    O My God THANKS YOU

    Thanks a lot I had about given up hope.

    now I can finaly write my script


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright ©2009-2011 Epic Games, Inc. All Rights Reserved.
Digital Point modules: Sphinx-based search vBulletin skin by CompletevB.com.