Results 1 to 6 of 6

Thread: Problems saving UnrealScript.chl to ConTEXT highighter. Access denied, contact admin

  1. #1

    Problems saving UnrealScript.chl to ConTEXT highighter. Access denied, contact admin

    Hello everyone, this is my first post. Hopefully this is in the right area. I have searched for hours online and in the forums here and I am finally going to post a thread because I am completely stuck.

    Windows 7 professional is my system.

    I recently purchased the book Unreal Development Kit Programming with UnrealScript by Rachel Cordone on Kindle (probably a mistake not buying the actual book with cd). I am at the part where since I don't have a CD I am directed to the wiki page with the unreal script and have to save it as UnrealScript.chl and save in the "highlighters" folder in ConTEXT. So first I battled with it and got the file in the folder, but turns out it was saved as UnrealScript.chl.oog (open office org), then I deleted it and tried again, it looked like I got it but when hitting F9 in context I kept getting error can't find chl file associated with blah blah blah. So I was thinking today at work I must have saved it wrong. So then I tried to save it as "UnrealScript.chl" with the " " included in the save because I read if you save like that it will force it to be saved as UnrealScript.chl and not as UnrealScript.chl.oog or .txt or whatever I am using to save. So I think I have it and I try and save directly in ConText highlighter folder and now it's saying Access Denied, please contact administrator for access. Great, so then I look online again searching for answers and attempt to change the properties to allow access. That never worked, and the only place I can save it is in my "downloads" folder. So I try and drag it to highlighters folder and get another access denied, but no mention of administrator privileges.

    Part 2: Thinking maybe the file must be somewhere else already saved in chl because maybe i'm doing this all wrong even though I checked view all known file extensions in the folder and it was indeed saved as UnrealScript.chl and not UnrealScript.chl.txt (because I decided to try with notepad). So I found the highlighters section on the Context webpage and noticed unreal script was there and saved in CHL!!! So I right click and save, but I am denied saving again competely. So my final options are hope I can get some help here, and try and ask the IT guys at my work tomorrow and see if they have any ideas. I would love to get this thing working, press F9 and get moving along in this book.

  2. #2
    I'm going to bump this once before looking for help elsewhere. I talked to the IT guy at the hospital I work at and he said I should save to the desktop, or boot up windows in safe mode to access the administrator account. I wen't through the whole process of doing that in windows 7 by running a command prompt and unlocking the admin account on the windows startup login screen. I finally got the file in there, but F9 still doesn't compile ConTEXT's script for me. So maybe I should look at other issues that may be causing this. I posted 2 links here to the highlighter files for UnrealScript that I found so I guess I should ake sure these are the files I really need. The wiki link I saved in notepad in contexts highlighter folder, and the context highlighter link I simply right clicked and saved as default in contexts highlighter folder. However I noticed that it does not save as UnrealScript.chl, so after trying the F9 I re-named it to UnrealScript.chl and it still didn't work. I really don't know what to do anymore excpet try and start over from the beginning. I'm hoping maybe this is something simple. I have the next 5 days off and I would love to push through this book.

  3. #3
    There are alternatives to ConTEXT. If you're having this much trouble it may be worth considering one of them.

    This one may be the most accessible:

  4. #4
    I don't know if my email reply got through, but the attachment you sent of the error message was in some weird format I couldn't open. Can you post a pic of the error message here?

  5. #5
    Have you found a solution to the problem yet? I got the same book for christmas, but it was perchased on Amazon so it did not come with the CD. I'm having the exact same problem, but I don't want to use a different program becasue i would perfer to follow the book the same way. I downloaded the extras on but it did not come with the .chl . I am going to lodge a complaint on the website to see what i can come up with, but I would still apreciate a responce.

  6. #6

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts