Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Interior Lighting with Lightmass

  1. #11
    There are two things you can play with:

    1- Set the Indirect Illumination Occlusion Factor parameter to something like 0.5.

    2- Brighten up the Environment Color parameter.

    Both are found under the Lightmass category in World Properties.

  2. #12
    Quote Originally Posted by darthviper107 View Post
    In addition to that, UDK has HDR rendering, basically it adjusts exposure based on where you are, so when you look into an interior while you're outside it's going to look dark because the sun is so bright, likewise if you're inside and you look out then outside will look too bright.
    HDR rendering doesnt mean it includes eye adaptation wich is not included by default in the UDK, if you go in a dark place it will stay dark.
    Anyway you can try adding a skylight in the scene and see if it helps, it should brighten the too dark areas of the scene, playing with the indirect diffuse boost parameter could help to increase the bounced light too.
    if you need further assistence you could share the map and i can arrange a setup for it.
    Check it out and let me know

  3. #13
    box-0: In fact, I've tried the other day with skylight as you suggest, and that seemed to help. The problem is that as those areas were almost dark, I don't think I'll have soft shadows for the furniture this way. But I haven't got there yet (I have to study for an exam next week, so no UDK for me for a few days) so I'll check that out next week. And of course, if you could arrange a setup if needed I'd deeply appreciate it!

    seenooh: I played with those parameters too (and others on World Properties and directional light too) and the problem remains. That's why I think I may be missing something obvious.

  4. #14
    Tom Shannon
    From your screenshots, I can see you're using the default material. It doesn't really seem to bounce light too much as it's actually a fairly dark texture. Try making everyting pure white. Also, if you're trying to get light into a space, you should have your camera inside that space rather than outside looking in. To light an interior accurately, you need to overexpose the image either though brighter lights or through post processing (Or a combo). That makes the exterior blow out big-time, so trying to 'balance' the exterior and interior lighting is difficult.
    To allow more light to get into your structure, 1) Turn off ambient occlusion inthe Lightmass properties in World Properties, 2)Increase the Diffuse Boost in the Lightmass settings. Increasing the number of bounces can helpa little but not muc after 3 or 4 bounces.
    Also, you can use the Scene Tonemapper Scale in your world properties/Post Processing chain to overexpose your image, acting more like a camera.

  5. #15
    Tom has the best answer yet... dark textures!

    Keep in mind that when you resized that scene, you drastically altered the texturing as seen by lightmass.

    In the 1st image you posted, direct light is only affecting a small piece of the hallway on the ground. But that entire chunk is a dark purple square (part of the default texture) with only a tiny bit of the wall being white.
    Because of the way gamma and lightmass works, a dark part of a texture like that will reflect VERY little light. To compensate for this, you can jack up the diffuseBoost in the lightmass settings of those assets. Note that this setting just makes the texture approach 1, it cannot make it brighter than 1 as far as lightmass is concerned.

    In the 2nd set of images, you altered the texturing such that instead of just a purple square, you had light hitting 2 white square a little. That more than the scale change increased the apparent bounce lighting.

    To rule out these issues, I suggest using the LightmassReplace node on your materials (yes even make your own default material), where you put in a lighter color like constant 0.75 or 0.5 into the Lightmass input.

    This will mean lightmass always sees flat gray. Those of us who did lighting on most of gears3 ended up using the lightmass replace node for most of the game to get around issues like this. Oftentimes it is useful to use a vector parameter there so you can control the lightmass impact per material instance.

    Also many materials require lightmass replace for technical reasons. For example RavensNest used worldcoordinates to generate the stripes on the walls (they werent in the texture). Lightmass has no concept of world coordinates or anything, so those materials would generate totally incorrect indirect lighting if we didn't just use lightmassreplace.

    Texture brightness is by far the biggest issue in getting good bounce.

  6. #16
    If you rule out the brightness issues (by either actually brightening them, using diffuse boost, or lightmassreplace), then you can still get more bounce by increasing the IndirectLightingScale of your directional light. We've done that on a few gears maps, especially the sunny ones that have lots of orange bounce on the interiors.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts