Hey, I recently tried downloading the newest update of udk, and it says I need shader model 3.0 or newer, but my graphics card has support for shader model 5.0, anyone know whats going on?

PS: Here's the link to my graphics cards info.

Edit: ok.... after restarting and trying 3 times it suddenly worked... O.o ok whatever im not complaining, thanks anyways guys.