Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: How to make custom content download faster?

  1. #1
    Red Squirrel
    Guest

    How to make custom content download faster?

    When I let the game download custom content, it takes bloody ages. If I manually download it via HTTP, it downloads literally 100 times faster.

    Is there a way to speed it up in game? I looked into redirection but there is a huge lack of documentation on how it should be done. The only thing I found is adding this to utengine.ini:

    Code:
    [IpDrv.HTTPDownload]
     RedirectToURL=http://ut3.uovalor.com
     UseCompression=True

    But what is the http folder structure suppose to be like? This is what I have, is this correct? http://ut3.uovalor.com Or do the files all have to be in the same folder?

  2. #2
    TKBS
    Guest
    be thankful for the technology you have available to you.

    - show some patience; - is it really so bad to spend a few minutes downloading?

    - the fact that people cant be bothered to wait this time is ridiculous

    - if you are a player- tough.

    - if you are a server provider you can compress your files alittle bit more.
    - using stuff like this

    http://www.gamefront.com/files/97510...and_Decompress
    http://www.fileplanet.com/187733/180...mpression-tool

  3. #3
    Red Squirrel
    Guest
    So there's no way to make it faster through the game? Just seems odd that it's so slow. It takes about a minute just to get 0.1%. I have 100mbps of bandwidth up/down to the server. If I download it manually through http then it's fine, but through the game it's very slow.

  4. #4
    RattleSN4K3
    Guest
    The path to your redirect needs to point directly to any files. Meaning, you have to put all files into the root folder of your selected path => no subfolders.
    Every file should be located at http://ut3.uovalor.com/

    http://ut3.uovalor.com/CTF-GRD-Arsenal[UGM].ut3
    http://ut3.uovalor.com/CTF-GRD-Biohazard[UGM].ut3
    etc.

    In this case, you're sharing the raw files - u, upk and ut3 files. So the variable "UseCompression" needs to be false. By compressing them with the methods TKBS mentioned, you have to set this to true. All the maps, package and script will have a new extension UZ3. Remember: In any case, no subfolder.

    It looks like your sharing the files from the server. This can cause any lags on the client machines which are playing on that server. Files should be located on a different machine.

    PS: Try to search "ut3 setup redirect" on search engines to get more information.

  5. #5
    Red Squirrel
    Guest
    I have 100mbps to the server so it should be fine as far as bandwidth goes, cpu should be able to handle it too once I shut down my Ultima Online server (currently running in a VM on that box). Guess I will create a separate folder and just make sure to copy the files to it as well as to the server's proper path, or create symlinks. I'll play around with that and see how things go.

  6. #6
    Red Squirrel
    Guest
    I made a separate redirect folder under a different DNS hostname and put the files in the folder (testing with only one map right now) and it's still not working, anything else I need to do?

    This is the setting:

    Code:
    [IpDrv.HTTPDownload]
    RedirectToURL=http://redirect.ut3.uovalor.com/data/
    UseCompression=False
    I turned Allowdownloads off so I can rule out that it's downloading through redirection. If I turn it on it downloads but at the super slow rate.

    Also I noticed lot of other settings that may help speed things up:

    Code:
    [IpDrv.TcpNetDriver]
    AllowDownloads=False
    ConnectionTimeout=30.0
    InitialConnectTimeout=200.0
    AckTimeout=1.0
    KeepAliveTime=0.2
    MaxClientRate=15000
    MaxInternetClientRate=10000
    RelevantTimeout=5.0
    SpawnPrioritySeconds=1.0
    ServerTravelPause=4.0
    NetServerMaxTickRate=30
    LanServerMaxTickRate=35
    IdleServerTickRate=30
    DownloadManagers=IpDrv.HTTPDownload
    DownloadManagers=Engine.ChannelDownload
    NetConnectionClassName=IpDrv.TcpipConnection

    Is there any of those settings I can change?

    Oh another thing I noticed is the server log says this when a map loads:


    Code:
    Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
    Log: FHttpDownload resolved gamecontent.unrealtournament3.com (199.255.40.77)
    Could it be that it's trying to redirect to that hostname? Or is that for something else?

    Also, I don't see anything in my web server logs, so it does not look like it's even trying. The problem is elsewhere. (perhaps what I just mentioned above)

  7. #7
    RattleSN4K3
    Guest
    Hmm. I created a basic redirect on my PC and connected with another PC (LAN) to this server.
    I used the retail version of UT3 running as a dedicated server and the only thing i had to do is, adding the "[IpDrv.HTTPDownload]" block and set the AllowDownloads property to false. I used an Apache server for the redirect (basic XAMPP installation with allowing local IPs).
    I tried 3 different things and all of these were working as expected.

    1. No redirect. Allowdownloads to true. Client could donwnload the file.
    2. No redirect. Allowdownloads to false. Client aborted loading the map due to download failure.
    3. Set redirect. Allowdownloads to false. Client downloaded the file. The access log of apache has a new entry of that client.

    There is no additional server log in UT3 for having a redirect configured - on my side.

    Try to delete all config files and create the basic setup in order to test if it is running well with a minimal configured system.

  8. #8
    Red Squirrel
    Guest
    All config files? Wont that break everything? Everything IS stock, other than a few added maps, which are only addition of new files.

    Now what confuses me is that some of the files are in the server's folder, while some are in the home directory under a hidden file. Is this normal? The file I have to edit is in that home folder, and is not in the server's folder. The server is running under that user though, and editing the file does seem to have some kind of impact (the downloads=false/true option).

  9. #9
    Red Squirrel
    Guest
    Oh and this is my startup string, could a flag in there have anything to do with why it's not working?

    Code:
    #!/bin/sh
    
    {
    date
    echo
    ./ut3 Server VCTF-Necropolis?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=2?Numplay=4?MaxPlayers=64?NumPublicConnections=24?NumPrivateConnections=2?MinNetPlayers=1?bIsDedicated=true?bUsesStats=true?ForceRespawn=0?bShouldAdvertise=false?PureServer=1?bIsLanMatch=false?bAllowJoinInProgress=true?AdminName=********?AdminPassword=******** -Login=******** -Password=******** -Log=myserver.log -multihome=96.45.178.186 -unattended
    } > server.log 2>&1

  10. #10
    Red Squirrel
    Guest
    Ok I give up on redirection, everything I try is not working. I reverted all the stuff I did from file backup.

    Is there not any settings I can change to just make the normal way faster? I see a bunch of settings under [IpDrv.TcpNetDriver] that seem to have to do with download rate. I just don't know what the units are (bytes, KB? MB?) and what each one does. There's tick rate etc...

    Would increasing any of these help?

    Is there a way to find out what version server I'm running? Maybe I need to apply a patch or something?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •