Results 1 to 9 of 9

Thread: Web interface, can't get VCTF map list

  1. #1
    Red Squirrel
    Guest

    Web interface, can't get VCTF map list

    When adding new maps and I go to "map lists" then select VCTFmaplist from the drop down at the top to edit that list, when I click on the secondary drop down to get a list of available maps, it always returns nothing. I always have to add them in manually. Why is this? It works for all the other types. Basically going to the option should change the list to the maps available for that list but for VCTF nothing happens, so I just continue to see whatever was in the list already. It's like if it's not calling the proper javascript method to trigger it to load the list or something.

    Anyone else have this issue? Keep in mind it works for all the other ones, so it's not my javascript or something local not working.

  2. #2
    zunnie
    Guest
    Are you talking about custom maps or not?

    To have custom maps showup on your maplist you must have it like in this image:
    [shot]http://www.zunnie.net/tutorials/ut3/img/06-createfolders.jpg[/shot]

    The tutorial can be found here:
    http://www.zunnie.net/ut3dedicatedse...ontutorial.php

  3. #3
    Red Squirrel
    Guest
    I meant the web interface itself, this pic explains it better:



    I do upload all the maps to CookedPC first of course. This works fine with all the other map lists, like even under VCTF mode I can pick another list from the drop down and the maps do appear in the blank area but wont do it for CVTF maps for some reason.

  4. #4
    zunnie
    Guest
    You know, i have the same problem right now but then with DM maps :/
    It happened when i accidentally selected a gametype other than the one that is currently used for the maplist to select new maps from :s
    Now no matter what, the list stays empty lol :/

  5. #5
    unrealloco
    Guest
    have u tried selecting your maps save it then restart current map then check if their still there???

  6. #6
    Red Squirrel
    Guest
    They do save if I type them manually, but they still don't show up in the list on the side. When uploading multiple maps at once, especially if it's not me that uploaded them, I find it's easier to just go to "Add missing" instead of typing them in one by one. But they have to show up in the list for that.

  7. #7
    RattleSN4K3
    Guest
    I helped another guy with a solution who came accross this bug.
    The maps are requested by an ajax post. The maps will get returned in a XML format. This format is only accepting ANSI.
    There is a common map (which is also in your image) RocketForest which has the name "RöcketForest". The character ö is not ANSI so the XML cannot be parsed (at least for Firefox).

    You can goto to the following page. This is requesting the maps for the gametype VehicleCTF.
    Code:
    /ServerAdmin/data?ajax=1&gametype=UTGameContent.UTVehicleCTFGame_Content&type=maps
    You might see an XML error containing some information what file could be corrupt.
    For this specific error, you have to change RöcketForest to RocketForest in its ini file "VCTF-RocketForst.ini" resulting like this:
    Code:
    [VCTF-RocketForst UTUIDataProvider_MapInfo]
    MapName=VCTF-RocketForst
    FriendlyName=RocketForst
    PreviewImageMarkup=<Images:VCTF-RocketForst.screenshot_MAT>
    Description=None
    NumPlayers=8 to 20 Players Author: scarface

  8. #8
    WishfulThinking
    Guest
    One of the problem I have is that everytime I add the maps into the voteable map list, it don't save, therefore the only way to goto thos maps is either the UTComp vote system or admin manually change themselves.

  9. #9
    Taffy
    Guest
    Put the map ini file in the server's config folder and it will show up in webadmin in the vote list and in utcomp list.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •