Results 1 to 9 of 9

Thread: FBX Import Corruption

  1. #1
    sirjimbob
    Guest

    FBX Import Corruption

    Hello,

    I'm trying to import a mesh out of 3dsMax into UDK and running into corruption issues. I have a highly detailed mesh to begin with so I'm scaling it way down in 3dsMax using ProOptimizer to under the UDK vertices ceiling. What's weird and where I'm running into a problem is that UDK corrupts any mesh I import into it that has been ProOptimized more any less than 90%. Optimizing and reducing the polys on the original mesh in 3ds by 90% or more imports fine into UDK but any less than that and I get crazy looking corrupted meshes in UDK. While 90% or more works it's a bit too low poly for my tastes so I'd like to get this figured out.

    Image of the meshes in UDK after being ProOptimized and exported out of 3dsMax as FBX. From left to right: 90% optimization looks fine, 89% has some corruption, 75% has a ton of corruption.


    Thoughts on WTF is happening here? Everything looks great in 3ds.

  2. #2
    haldolium
    Guest
    How many polys do the corrupted meshes have?

  3. #3
    sirjimbob
    Guest
    Quote Originally Posted by haldolium View Post
    How many polys do the corrupted meshes have?
    From left to right in my image: 20,000 22,000 50,000

  4. #4
    MrRipGames
    Guest
    At first glance the mesh is too dense ..
    This is a 3D sculpture? Zbrush / Blender / Sculptris / Mudbox? If this is the case you need to do a retopology to optimize the mesh and have a clean base and slight if you have not done

  5. #5
    skwisdemon666
    Guest
    Looks like you didn't set up smoothing groups, which means every vert of every tri is duplicated for each tri it is part of. To check this, give the entire mesh the same smoothing group and try to import.

  6. #6
    taz1004
    Guest
    Quote Originally Posted by sirjimbob View Post
    From left to right in my image: 20,000 22,000 50,000
    I get those results for mesh over 20K polys too. I think there's difference between technical poly limit and practical one.

  7. #7
    ikifenix
    Guest
    That is weird, I imported a 120k tris = 60k polys mesh just for test and it is ok.
    [shot]http://img26.imageshack.us/img26/9397/60kq.jpg[/shot]

  8. #8
    haldolium
    Guest
    In my experience it *is* a polycount problem, though it seems not to follow particular rules. I once had the very same problems, and the errors even variated for one and the same model when I imported it several times. That was a while ago though with an older UDK version. Static Mesh only btw. Apparently Skeletal Meshes can have more polys/vertices since some 2012 UDK release.


    In any case - what do you want to achieve with the head? Because despite this particular error, 20k for just a head is rather intense and not really necessary for a character.

    /edit

    Quote Originally Posted by ikifenix View Post
    That is weird, I imported a 120k tris = 60k polys mesh just for test and it is ok.
    [shot]http://img26.imageshack.us/img26/9397/60kq.jpg[/shot]

    I just tested it too (with the same model that once gave me these errors) and despite the warning for collision it worked well too. I used the UDK februrary release this time. So by now I think it can be either a problem with the model (make sure to collapse the stack. It just worked for me not doing so, but safe is safe) or with the UDK version.

  9. #9
    sirjimbob
    Guest
    It was a polycount problem. Thanks for the help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •