Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: problems with custom game mode + multiplayer

  1. #11
    axelzellalex
    Guest
    oh ive done all those in regards to creating my own exe for my game build etc... been using udk for a few years now
    my first time trying as a multiplayer

    but i was sure to use a gametype in multiplayer you could just create the game mode (like a mutator) in the menu of unreal - im sure thats how it used to be done
    i will try what you have said here - not done it like this

  2. #12
    axelzellalex
    Guest
    i followed what you said but has not worked
    i begin my "...UDK.exe HG-Test.udk?Game=Hunter.HunterGameInfo -log" which loads up my level etc... and not the UDK menu stuff
    then i ran my "...UDK.exe 127.0.0.1 -log" but that just began another version of the game

    "Cant start an online game that hasnt been created" - is the error i get with both runs

  3. #13
    saiboat
    Guest
    Wanna read this line again?

    C:\UDK\UDK-2012-02\Binaries\Win64\UDK.exe server DM-Deck.udk?Game=Hunter.HunterGameInfo -log

  4. #14
    axelzellalex
    Guest
    LOL i assume the KEY word that i missed ... is... "server" ....
    i shall try right now!

  5. #15
    axelzellalex
    Guest
    ok, so when i run the server .exe the log window gives me an error:
    Code:
    Error: Can't create a new online session when one is in progress: Transient.UTGameSettingsDM_1
    ScriptWarning: Failed to reister game with online service.Game wont be advertisied.
    but i assume the "Online" part is fine, as its creating a local instance
    when i start my ".exe 127.0.0.1" my log says "Accessed None Map Info" and again with the "TeamIndex 255" :S
    and the game crashes on the loading screen which says "DeathMatch" and "Test" - Test being my map name, but I dont know why its loading DeathMatch ? id have thought it would reference HunterGameInfo

    when tyring to join the game, my server console window does say "HG-Test.udk (1 players)" - interesting

  6. #16
    saiboat
    Guest
    The error that you server log is giving you has to do with steam and online subsystem stuff, I don't know really but it's normal that it doesn't work at this point. I have it aswell.

    Did you do this stuff from the guides?

    Code:
    [Engine.GameInfo]
    DefaultGame=UDNGame.UDNGame
    DefaultServerGame=UDNGame.UDNGame
    PlayerControllerClassName=UDNGame.UDNPlayerController
    GameDifficulty=+1.0
    MaxPlayers=32
    DefaultGameType="UDNGame.UDNGame"

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •