Results 1 to 9 of 9

Thread: Processing maps takes forever...

  1. #1

    Question Processing maps takes forever...

    Processing maps takes FOREVER to complete. In a scene with 6 bsps, 3 static meshes, and 2 lights.

    Everything else goes pretty quick, the stuff with the photons and so on, it's practically instantaneous. But processing maps takes forever just in the preview settings for this scene (and my other scenes).

    I'm not exactly sure what caused this problem to occur.

    I have been using Swarm to create lighting in my scenes without a problem in this build of the UDK before. The only thing I can think of that I have changed in my computer since then is my video card drivers - but I rolled back and I'm still having this problem.

    Last night, I decided to leave my PC on all night while it builds the lighting in preview settings for my scene with 6 brushes. It did complete, but it took all night.
    PC Specs:
    Intel i7 950 3.07 ghz
    12 gbs of RAM
    Nvidia GTX 570

  2. #2
    Solid Snake
    Did you add a LightMassImportanceVolume?

  3. #3
    Yes, I tried that. Doesn't work.

    Even so, it's such a small space it wouldn't normally make a difference.

  4. #4
    It shouldn't be doing that, ( but you already know that )

    Not sure if it would help, but I always load all packages once to build the shader cache.

  5. #5
    Nah didn't make a difference.

    Is no one else having the same problem? I've googled around, and it looks like there's one post on Polycount where someone is having the same problem:

    I've got the December 2010 build of the UDK and I'll try rebuilding my simple scene in there, although I know that build is missing one of the props I want to render in there. And it doesn't have any of my newer scenes in their current forms so I don't care if it even works in that version.

    If I'm unable to solve this with the help of anyone on the forums then I'm hoping that the May version of the UDK will resolve this issue.

    But I'd really like to fix this now.

  6. #6
    It seems that I was trying to lightmap an object that had an emissive map and that was causing the problem. It's strange because this hasn't caused a problem before. And it's unfortunate that the UDK doesn't notify me that this is causing any issue.

    After changing the lightmap assignment to a different UV so it wouldn't try and lightmap onto my emissive material, it seems to have solved the issue.

  7. #7
    Solid Snake
    Emissive materials actually emit light in LightMass. So if it covered a large area then it will take a long time to process the maps for the light emitted by the emissive material.

  8. #8
    I thought that you had to turn on "Light with emissive" in order to tell Lightmass to use it for lighting?

    Edit: I just checked and it looks like if you check a static mesh's properties, there's a check box under Lightmass > Lightmass Settings that says "Use Emissive For Static Lighting"

    Mine was checked off. Does Lightmass use emissive for lighting anyway?

  9. #9
    Solid Snake
    If it is turned off then it won't. Hmmm, well, I suppose there is something to investigate perhaps. I'll have to see if I can reproduce the issue.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts