Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Static meshes not showing MAY build

  1. #1

    Static meshes not showing MAY build

    Hi, long time lurker on the forum, always meant to sign up but never had the chance up until now. I've been using UDK since the moment it got released but recently switched to Killing Floor SDK (Unreal 2.5) to make some maps and came back to UDK when the may build was released, so not a total noob at UDK

    So now the introduction is over, here is my problem:

    I just downloaded the may beta build and found tons of new static meshes such as the new mayan ruins (they work fine btw) and new foliage such as big fan leafes and such. My problem is that when I try adding them to my game they don't show up - at all.

    They show up fine in wireframe but not in anything else! all the other meshes show up just fine, except these. when I double click the static mesh nothing shows up inside the properties as well, usually it shows the mesh inside of there so you can add collision etc. but it doesn't... unless I click wireframe.

    Also when I close the editor the static mesh suddenly appears black in the content browser, I've looked into the material they use and they also show up completely black, so thats the problem. I tried applying a new material to it and it works fine, so the problem lies with the materials...

    I've took a few pictures of my problem, I really need this fixing as I was planning on making a simple jungle setting with decent lighting and god rays to show off for my portfolio to get into a different game design course at a different college I'm currently at now so I really needed these. I've gone to college to test the may build there and it works fine! the materials show up fine, the static meshes work as they should but not on my computer. And without the materials working the static mesh looks crap and unusable.

    I've tried uninstalling every build I have and reinstalling the may build to no effect, everytime it installs and I run it the meshes don't show. I've had this problem for a few days now and its really starting to do my head in!

    If anyone can shed some light onto my problem I'd greatly appriciate it, I thought it was a god send with these new meshes being added just when I was thinking of making a jungle theme and since I don't have time to make my own (and not very good at max/maya moddling) I couldn't wait to use them. I just can't understand why they they don't work.

  2. #2
    apply a material to them.

  3. #3
    Quote Originally Posted by CreativeCoding View Post
    apply a material to them.
    I have, they work then but what I'm saying is the default textures don't work, and I loved the way they looked so wanted to keep the entire thing, but even the material shows up black and I don't know why, they show up fine on everyone elses.

  4. #4
    I HAD THE EXACT SAME PROBLEM!(Lol....) Something is strange with the May version I almost decided to stop using UDK because I built a complex map and in game "nothing was there" I was wanting to hit my computer. But I tried to find a solution and I found that all I had to do was save the package and it worked.....
    And since your just having problems with already made packages just re-save them see if it works then.

  5. #5
    A thing that I always found that worked when I started was to hit each of your letters on your keyboard twice until what you want happens

  6. #6
    So your static meshes don't show up in the viewport or content browser or both? You didn't press Q by accident, did you?

  7. #7
    None of the above, I haven't started any custom packages, All I did was load a few new meshes and found that ALL the plant related ones don't work with their default material.

    All the other static meshes work fine and show up fine, trust me, I know when I've pressed the W key by accident and all my meshes have dissapeared.

    The problem lies with the material, not me pressing a button by accident or unsaved packages. What I can't understand is that this seems to be only happening to me - and only on the may build.

  8. #8
    So its worked fine in earlier builds? You should add a picture of your material setup, I have a feeling that is where your problem lies.

  9. #9
    Quote Originally Posted by Zipstacrack View Post
    So its worked fine in earlier builds? You should add a picture of your material setup, I have a feeling that is where your problem lies.

    I'm not sure about other builds having the plant meshes but the only time I've ever had this problem my self was materials not working right. I don't know if the meshes are in the april build.

    I believe they is a picture with one or two static meshes material instance constant settings, that too shows up totally black and I can't seem to find the Texture2D for them at all.

    If anyone needs more information let me know, thanks for the help up to now guys. I'd love to overcome this problem like I have with the many other errors I've had in the past with UDK and sorted it out. I still struggle to actually see why I'm the only one experiencing this error, its baffling.

    Edit: this is one material settings for the banana plant static mesh/material for it.

  10. #10
    Just to cheer you up, I'm having exactly the same problem.
    Every static mesh that is built from one-side polygons(leaves, etc) becomes invisible. Interesting example is StaticMesh'GenericFoliage01.Trees.Mesh.SM_GEN_Foli age01_LargeTree01_Opt'.
    Just after launching the UDK and navigating to this mesh i can see a thumbnail of a nice tree with lots of green leaves. When i double click the thumbnail and Static mesh viewer appears, I can see tree but without all the leaves, just bare branches.

    Any other foliage meshes like grass or smaller plants are completely invisible to me(i can see them in wire frame view).

    Oh, and I'm having this issue on both April and May release(i also have March release but those meshes are not available in this build).


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts