Results 1 to 6 of 6

Thread: UV Tangent seams & Normal Map

  1. #1
    Lokkee
    Guest

    UV Tangent seams & Normal Map

    Hello folks,

    I haven't seen this problem reported so far, so instead of keeping bashing my head against the wall, I was wondering if some of you would be so kind tell me what I am doing wrong, or if there is a work-around for this problem:

    I am trying to get a static mesh into Unreal Engine, nothing too complicated theoratically.

    I have detailed a tree in ZBrush and all my textures have been created and transfered on a low res mesh.
    So far so good, here is the result on Maya High QUality viewport:

    Here is what the UV layout looks like:


    Now...here come the pain:
    When I look at it in Unreal Engine I keep having those ugly seams from hell:

    Since the tree looks okay in Maya I was assuming thesource of the problem could be narrowed down to 2 possibilities. (I could be wrong)

    1-Either some UV tangent data have not been exported
    Which would explain why Maya displays the object correctly while Unreal doesn't.
    I have exported this mesh with ActorX and Collada and tried as many export option as I could think of... without any noticeable difference

    2-Something has gone horribly wrong with my object/texture/material options in Unreal Engine.
    My Textures and Meshes options seem all right to me, comparing them with similar static meshes from the editor
    here is what the material looks lik at present.


    Pretty please, if anybody has a suggestion or even better... Ze answer, I am running out of option my head hurts and my ears are bleeding.

  2. #2
    nightFlarer
    Guest
    Maybe this could help http://boards.polycount.net/showthread.php?t=51088 ,don't know if its the same problem, I'm kinda a noob when it comes to high polys & normals.

  3. #3
    Lokkee
    Guest
    Thanks nightFlarer,
    I've seen that thread but I think the problem here is different: I'm not using any mirror or overlapping UVs and in my case, the seams are not visible on other renders than Unreal Engine:
    displayed with Maya or Xnormal everything looks fine
    Unless I missed something I wouldn't blame the textures

  4. #4
    geodav
    Guest
    i haven't done a lot of static work like that, but it be an idea to check the LOD setting of the normal map "after" you have imported it, in a lot of cases it reverts to worldmap and not to normalmap

    ps. nice tree

  5. #5
    Lokkee
    Guest
    Thanks Geodav!
    You just gave me the solution, that was a schoolboy error indeed!

    There is 2 sorts of Normal maps

    -Most of the time we tend to use tangent space normal map, and it make mostly sense when your mesh is animated, the downside being that it is a more resource consuming process.

    -And there is objectspace normal map which is unfit for animated object but far more economic for the GPU

    As I was exporting a static mesh...the engine was therefore only considering Object space normal maps hence my problem:
    I just didn't use the right type of texture so it could not be sorted correctly in Unreal Engine.
    If I was going to animate this object later on... Exporting that tree as a skeletal mesh, I would need to switch back my normal map into tangent space.

    Thank you all!

  6. #6
    Psycho-Designs
    Guest
    I just posted the solution elsewhere:
    http://forums.epicgames.com/threads/...8#post30089858

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •