Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: UT3 2.0 Mod Setup

  1. #1
    WOLFhellfire
    Guest

    UT3 2.0 Mod Setup

    This is how my mod folders are setup with the new 2.0 patch and the Titan Pack; in case you starting a new mod or needing to update your current project.

    Updated 3/12/09

    Code:
    - Mod Main Folder
        - Artwork
        - Config
        - Logs
        - Screenshots
        - Shaders
        - Source
             - PackageName
                  + Classes 
        - Splash
             * Splash.BMP
             * EdSplash.BMP
        - Unpublished
             + CustomChars
             + CustomMaps
             + Localization
             + Script
             + Sounds
             + Textures
             + UI
        - Published
             + CustomChars
             + CustomMaps
             + Localization
             + Script
             + Sounds
             + Textures
             + UI
    
        * DirectPlay.exe
        * Editor.exe
        * NormalPlay.exe
        * Rebuild.exe
    DirectPlay.exe
    Code:
    "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" DM-CoolLevel?game=PackageName.GameType -useunpublished -mod=..\ModName
    Editor.exe
    Code:
    "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" editor -mod=..\ModName
    NormalPlay.exe
    Code:
    "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" -useunpublished -mod=..\ModName
    Rebuild.exe
    Code:
    "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" make -useunpublished -mod=..\ModName

  2. #2
    Jetfire
    Guest
    Nice try but a bit wrong imo. Try to emulate the folder structure of UTGame. The config folder is for .ini files.

  3. #3
    Drifa
    Guest
    Quote Originally Posted by WOLFhellfire View Post
    [...]
    Code:
    [...]
        * DirectPlay.exe
        * Editor.exe
        * NormalPlay.exe
        * Rebuild.exe
    Are these self made or a new feature? Still downloading..

    Edit: when do you think they will release the ScriptSource_2.0?

  4. #4
    WOLFhellfire
    Guest
    Quote Originally Posted by Jetfire View Post
    Nice try but a bit wrong imo. Try to emulate the folder structure of UTGame. The config folder is for .ini files.
    I thought the same thing until I looked at my folders after I played UT3. I tried to build my mod and it would not work so I checked the files and sure enough. UT3 decided to put all my .u files inside the config folder.

    Quote Originally Posted by Drifa View Post
    Are these self made or a new feature? Still downloading..
    I made the .exe files myself to make modding a bit easier. I decompiled the source already but we all know how that goes. The source probably wont be released for awhile if you take in account for how long the others took to come out.

  5. #5
    Jetfire
    Guest
    You probably have '-mod = ..\xgame\config' in your make etc. Remove the \config, it's not needed now.

  6. #6
    WOLFhellfire
    Guest
    That certainly would be a reason why I had to put the source in the config.
    I'll go ahead and change that.

  7. #7
    |*BILLY$CLINT*|
    Guest
    Did anyone have an issue where your player could no longer fire when your custom TC is loaded. I all of a sudden can not fire in game but I can in the editor its the weirdest thing.

  8. #8
    Angel_Mapper
    Guest
    Delete your UTInput.ini and let it make a new one.

  9. #9
    schenksmill
    Guest
    I had some remaining config file stuff from the 1.3 build of Unreal Demolition that interfered as well, so surf through your configs and get rid of excess crap.

  10. #10
    |*BILLY$CLINT*|
    Guest
    Quote Originally Posted by Angel_Mapper View Post
    Delete your UTInput.ini and let it make a new one.
    Add a +1 to your awesomeness...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •