Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: HowTo: Move Settings from a Commandline Into the .ini Files

  1. #1
    Dubious
    Guest

    HowTo: Move Settings from a Commandline Into the .ini Files

    In the original release it was necessary to manually specify a large number of settings in the command line. As part of the patch a significant amount of these settings are no longer required. In fact, they may actually be HURTING you. The software now automatically detects some settings that used to be required. Other settings have been optionally moved into the .ini files.


    If your server no longer appears in the browser, the problem may be caused by unnecessary settings in the command line.


    It used to be that this was a 'standard' command line:
    Code:
    ut3.exe server vCTF-Suspense?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=3?numplay=4?maxplayers=12?NumPublicConnections=12?NumPrivateConnections=0?NumOpenPublicConnections=12?NumOpenPrivateConnections=0?bShouldAdvertise=True?bIsDedicated=True?PureServer=1?timelimit=20?goalscore=5?botskill=3?AdminPassword=MyAdminPassword  -login=MyGamespyLogin -password=MyGamespyPassword -unattended
    Since applying the patch, this exact same command line can be shortened to this:
    Code:
    ut3.exe server vCTF-Suspense?Game=UTGameContent.UTVehicleCTFGame_Content?numplay=4?maxplayers=12?botskill=5?AdminPassword=MyAdminPassword  -login=MyGamespyLogin -password=MyGamespyPassword -unattended
    In fact, if I really wanted to push this to be as short as possible, this works too:
    Code:
    ut3.exe server vCTF-Suspense?numplay=4?Botskill=5  -login=MyGamespyLogin -password=MyGamespyPassword -unattended

    So, how did I get it so short? Its simple, yet complicated.

    The short answer is that almost all of these settings are now located in the .ini files. If you know what to change then you can change it, and remove it from the command line. When the server starts it will read the .ini files and load your desired settings.

    The long answer is that these settings are scattered throughout the .ini file(s) so there are a lot of places to edit them. Below are some examples. Obviously you will have to modify these to suit your desired gametype and settings.

    -----

    Old commandline setting:
    - ?Game=UTGameContent.UTVehicleCTFGame_Content

    New UTGame.ini file setting:
    - [Engine.GameInfo]
    - DefaultServerGame=UTGameContent.UTVehicleCTFGame_C ontent

    -----

    Old commandline setting:
    - ?GameMode=3

    New UTGame.ini file setting:
    - [not needed] - The server now knows to set the GameMode to 3 when its set to load a UTVehicleCTFGame. Same goes for any other gametype.

    -----

    Old commandline setting:
    - ?numplay=4

    New UTGame.ini file setting:
    - [not found] - I can't find an .ini setting that states the desired # of bots

    -----

    Old commandline setting:
    - ?maxplayers=12

    New UTGame.ini file setting:
    - [Engine.GameInfo]
    - MaxPlayers=12

    -----

    Old commandline settings:
    - ?NumPublicConnections=12
    - ?NumPrivateConnections=0
    - ?NumOpenPublicConnections=12
    - ?NumOpenPrivateConnections=0

    New UTGame.ini file setting:
    - [not needed] - The server automatically determines these settings.

    -----

    Old commandline setting:
    - ?bShouldAdvertise=True

    New UTGame.ini file setting:
    - [not needed / none found] - The server now advertises itself by default. I could find no setting in an .ini file to control this. I suspect that you can disable server advertisement by using this in the commandline as '?ShouldAdvertise=False' if you wanted.

    -----

    Old commandline setting:
    - ?bIsDedicated=True

    New UTGame.ini file setting:
    - [not needed] - The server now knows whether it is operating in dedicated mode or not.

    -----

    Old commandline setting:
    - ?PureServer=1

    New UTGame.ini file setting:
    - [not needed] - The server now knows whether it is "pure" or not.

    -----

    Old commandline setting:
    - ?timelimit=20

    New UTGame.ini file setting:
    - [UTGameContent.UTVehicleCTFGame_Content]
    - TimeLimit=20

    -----

    Old commandline setting:
    - ?goalscore=5

    New UTGame.ini file setting:
    - [UTGameContent.UTVehicleCTFGame_Content]
    - GoalScore=5

    -----

    Old commandline setting:
    - ?botskill=3

    New UTGame.ini file setting:
    - [not found] - I can't find an .ini setting that states the desired botskill. Leaving this out of the commandline sets the botskill to Average.

    -----

    Old commandline setting:
    - ?ServerDescription=This Is My Server Description

    New UTGame.ini file setting:
    - [Engine.GameReplicationInfo]
    - ServerName=This Is My Server Description

    -----

    Old commandline setting:
    - ?AdminPassword=MyAdminPassword

    New UTGame.ini file setting:
    - [Engine.AccessControl]
    - AdminPassword=MyAdminPassword

    -----

    Old commandline setting:
    - ?GamePassword=MyGamePassword

    New UTGame.ini file setting:
    - [Engine.AccessControl]
    - GamePassword=MyGamePassword

    -----

    So there you have it. Your commandline can be VERY short as long as you hard-code the settings in your .ini files.

  2. #2
    sCaryDeth
    Guest
    Wow holmes. Someone at Epic should be paying you for the tremendous amount of support you've been giving the UT community.

    Thanks for the tips. I'll get to work on cleaning up my command line asap!

  3. #3
    Bob!!!!!!
    Guest
    That's a big help, thanks for all your hard work. I have some other stuff in my command line, do you know if it is needed and what it does?

    ?OwningPlayerName=
    ?PingInMs=
    ?bIsListPlay=
    ?bUsesArbitration=
    ?bUsesPresence=

  4. #4
    Dubious
    Guest
    Quote Originally Posted by Bob!!!!!! View Post
    I have some other stuff in my command line, do you know if it is needed and what it does?

    ?OwningPlayerName=
    ?PingInMs=
    ?bIsListPlay=
    ?bUsesArbitration=
    ?bUsesPresence=
    None of that is needed for any reason AT ALL that I can think of. You can completely rip that out and have no ill effects.

  5. #5
    Haunting
    Guest
    Bump, Bump, Bump this to the top of the forum

  6. #6
    hanuta
    Guest
    hm, is there a way to bring the game and the adminpassword to the ini?
    i mean its a security problem in linux, when we get the linux server.
    everyone who has shell access to the linux box can see the admin/game pw.
    i dont want this!


    cheers
    hanu

  7. #7
    Mr_Beanie
    Guest
    Hi thanks for the hot tip, With your help i was able to narrow down the exact problem, the -nohomedir in the command line was the culprit. remove that and youre good to go. but shortening your command lines wont hurt either but just dont forget to remove -nohomedir if you use it

  8. #8
    Dubious
    Guest
    Quote Originally Posted by Mr_Beanie View Post
    Hi thanks for the hot tip, With your help i was able to narrow down the exact problem, the -nohomedir in the command line was the culprit. remove that and youre good to go. but shortening your command lines wont hurt either but just dont forget to remove -nohomedir if you use it
    Some people require the -nohomedir switch. Like me, for example. It causes no problems and is a legitimate command switch. If you do not want to use it, but still need your .ini files stored in a specific location then you can use the '-configsubdir=xxxxxx' command switch.

  9. #9
    Mr_Beanie
    Guest
    well the nohomedir command sets the server to go to the main ut config directory because the earlier versions would search for the my documents directory configs. since being patched it doesnt seem to do that anymore and defaults the way its meant to. If it doesnt cause problems for some good stuff but i found that when i removed it it worked like it should still using the configs in the default directory.

  10. #10
    Dubious
    Guest
    Quote Originally Posted by Mr_Beanie View Post
    well the nohomedir command sets the server to go to the main ut config directory because the earlier versions would search for the my documents directory configs. since being patched it doesnt seem to do that anymore and defaults the way its meant to. If it doesnt cause problems for some good stuff but i found that when i removed it it worked like it should still using the configs in the default directory.
    You are correct in its usage - it does change the config file location. And even with the first patch installed it still does that. You are the first person who has said that it stopped working for them. I suspect that there may be something else working here but if you fixed it to your liking then thats all that matters.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •