Page 3 of 12 FirstFirst 12345 ... LastLast
Results 21 to 30 of 117

Thread: Preparing your map for publishing and distribution

  1. #21
    DGUnreal
    Guest
    That is odd. My A_Music_Arrangements package only contains UTMapMusicInfo objects.

  2. #22
    Jagnot
    Guest
    Dangit. No matter how many times I've tried to get a preview picture to work, success still eludes me..

    Is there anyone here who has successfully implement a preview picture that can take a look at my map & ini and see what I'm doing wrong?

  3. #23
    SKYFURNACE
    Guest
    Quote Originally Posted by DGUnreal View Post
    That is odd. My A_Music_Arrangements package only contains UTMapMusicInfo objects.
    Yes, but when i load the editor, it autoloads "sounds" and even after i load the package, i must manually check the "UT Map Music" Filter to see them in the browser.... Maybe i am just using the browser wrong or in a different way.

  4. #24
    CreepyD
    Guest
    I don't see this stickied yet, it need to be stickied, it's just what any mapper wants to read all in 1 place.

  5. #25
    Felarion
    Guest

    Question

    Hmm, I have some trouble adding the map description. The preview pic works fine, but the description just doesn't show up. (You are supposed to see the description in the in-game menu under "Game", am I right there?)

    This is what I put into my ini file for testing purposes:
    [DM-Xaero UTUIDataProvider_MapInfo]
    MapName=DM-Xaero
    FriendlyName=Xaero
    NumPlayers=4 to 12 players
    PreviewImageMarkup=<Images:resources_xaero.Preview >
    Description=My 1337 description

  6. #26
    DGUnreal
    Guest
    *edit*

    It appears that the Description entry works for some but not for others.
    I am trying to determine why it does this.

  7. #27
    DGUnreal
    Guest
    Quote Originally Posted by Jagnot View Post
    Dangit. No matter how many times I've tried to get a preview picture to work, success still eludes me..

    Is there anyone here who has successfully implement a preview picture that can take a look at my map & ini and see what I'm doing wrong?
    What occurs when you try to add the screenshot?
    Can you successfully import the Texture, create the Material, apply it to a surface in your map, etc?
    Make sure that you use the Texture name in the .ini and not the Material name.
    You can also open the cooked map up in the editor and verify that the Texture has remained in the map file.


    Quote Originally Posted by SKYFURNACE View Post
    Yes, but when i load the editor, it autoloads "sounds" and even after i load the package, i must manually check the "UT Map Music" Filter to see them in the browser.... Maybe i am just using the browser wrong or in a different way.
    Do you have the A_Music_Arrangements package selected by itself in the Generic Browser?
    If you select multiple packages in the browser, it shows all of the content from all of them.

  8. #28
    Jagnot
    Guest
    Quote Originally Posted by DGUnreal View Post
    What occurs when you try to add the screenshot?
    Can you successfully import the Texture, create the Material, apply it to a surface in your map, etc?
    Make sure that you use the Texture name in the .ini and not the Material name.
    You can also open the cooked map up in the editor and verify that the Texture has remained in the map file.
    I have a feeling no-one will take me seriously after this, but, I accidently forgot the "P" in "Preview" in the INI.. Everything is working fine now..

  9. #29
    DGUnreal
    Guest
    Bump. Mods don't like me I guess...

  10. #30
    HTM~Necron99
    Guest
    Thanks for this! it really helped me figure that level preview out.

    One thing that I would add in distribution part(or maybe someone can explain to why people do this) is to NOT create a .rar/.zip with folders inside folders in it. It's really a hassle when you are uncompressing multiple files that all go to the same place and 2 or 3 are like that.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •