Page 1 of 13 12311 ... LastLast
Results 1 to 10 of 126

Thread: Getting Started Compiling a Mod

  1. #1
    Mysterial
    Guest

    Post Getting Started Compiling a Mod

    These are the basic steps you need to get your mod compiling and running in the game.

    Mod source should be put in My Documents\My Games\Unreal Tournament 3\UTGame\Src, in a subdirectory of your package name. You put the .uc files in a further subdirectory named Classes.

    Next, you need to tell the game that your package should be compiled. In UTEditor.ini under the section [ModPackages], add a line for your mod:
    Code:
    ModPackages=MyCoolMutator
    Run "ut3 make" to compile your mod. The output script goes into My Documents\My Games\Unreal Tournament 3\UTGame\Unpublished\CookedPC\Script. Note the "unpublished". By default the game does not load files in this tree. This is so that you can choose to "cook" the mod (mostly for faster loading - only really useful for mods with a lot of custom content) or you can simply copy it into the Published branch. Since cooking/copying all the time is tedious, while testing you can pass the game the "-useunpublished" command line parameter to tell it to use the files in the Unpublished branch.

    When you compile a mutator, gametype, or weapon, the compiler will automatically generate an .ini file for your mod package that tells the menus about it. You can opt out of this by setting the property bExportMenuData to false in your class's defaultproperties.

    Feel free to post if you have questions or need help - that's what this forum is for.

  2. #2
    SwaTz0rs
    Guest
    I added mypackage to the UTeditor.ini but all i get when i run 'ut3 make -full' is

    core - release
    engine - release
    gameframework - release
    ...
    ...
    ...
    UTGameContent - release

    //edit
    when i run 'ut make' i get this message


  3. #3
    Nuky
    Guest
    Thanks for the quick reply Mysterial

    But there is a mistake
    Rypel figured it out: it is ModPackageS, with an S.

  4. #4
    RypeL
    Guest
    Thx Mysterial. But theres one typo in your tut. It should be "ModPackageS=MyCoolMutator" with the additional S. Then it works

  5. #5
    Mysterial
    Guest
    Thanks, fixed the typo.

  6. #6
    rans.m
    Guest
    I get a standard windows crash (popup box come up with ut3.exe has encountered a problem etc) when I compile and it gets down to my package and writes "-------vyd-release-----------" like that. Any ideas? I'm pretty sure I followed the instructions

  7. #7
    Xero
    Guest
    Thanks Mysterial you guys rock.
    Now all I need is UT3...

  8. #8
    Limi
    Guest
    I'm trying to run the basic of basic helloworld mutators as a test to make sure everything is working right, and to also get a feel for the engine again. But I'm having some issues.

    I have successfully compiled the mutator, and i'm using the -unpublished and -log flags to get some output. I can see that it's trying to load my mutator, but its just saying...

    Code:
    Error: Error reading attributes for 'C:\Games\Unreal Tournament 3\Binaries\..\UTGame\Unpublished\CookedPC\Script\MutHelloWorld.u'
    No idea's on whats causing this. Although the mutator does appear in the in-game lists. So I try to start a local instant action with my HelloWorld mutator and...

    Code:
    ScriptLog: Mutators MutHelloWorld.HelloWorld
    Warning: Failed to load 'Class MutHelloWorld.HelloWorld': Failed to find object 'Class MutHelloWorld.HelloWorld'
    So I have no ideas at all, anyone else got any?

    Here's the code im using...

    Code:
    class HelloWorld extends UTMutator
    	config(Game);
    
    function PostBeginPlay()
    {
      Super.PostBeginPlay();
      LogInternal("Hello World");
    }
    
    defaultproperties
    {
      bExportMenuData=true
      GroupNames(0)="TEST"
    }
    I'v also tried instead of function "simulated event" as that appears to be used about the place but no dice.

  9. #9
    Mysterial
    Guest
    Quote Originally Posted by Limi View Post
    i'm using the -unpublished
    It's actually "-useunpublished"... I had another typo in my post... guess I didn't proofread it well enough

  10. #10
    _Lynx
    Guest
    Now I don't have to wait for UDN to open

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •