Page 4 of 30 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 291

Thread: Joysticks/Gamepads/Controller Configurations Here

  1. #31
    legacy-kazza
    Guest

    Post configure

    i got my game pad to work except for left and right i went in the ini files but nothing seems to work

  2. #32
    legacy-Duffmeister
    Guest
    equipment:
    microsoft gamepad gravis xterminator

    result wanted:
    use analog joystick to replace mouse look.

    procedure followed:
    make changes to unreal2003.ini as described in first thread.
    make changes in user.ini by adding axis y and axisx lines as described.

    problem:
    any changes I make to the user.ini are completely ignored by UT2003.
    I make simple changes like "joy8=fire" save user.ini and exit wordpad.
    I start UT2003 but joy 8 idoes not fire weapons.
    I used the control panel settings to make sure which button is actually number 8.
    any suggestions?

    edit:
    the analog joy stick does allow me to straff and move forward and backward, but UT2003 ignores any changes I make to the user.ini file

    edit:
    all fixed, my problem was instruction line 5:
    quote
    --------------------------------------------------------------------------------
    5. Add the following lines to the bottom of the file:

    JoyX=Axis aStrafe SpeedBase=32768.0 DeadZone=0.4
    JoyY=Axis aBaseY SpeedBase=32768.0 DeadZone=0.4 Invert=-1

    ---------------------------------------------------------------------
    I found the settings are elsewhere in the user.ini file. I adjusted those instead of adding the new lines to the end of the file. then it worked fine.

  3. #33
    legacy-Hellbender
    Guest

    Gravis?

    Hey guys

    OK Ive tried all the ini.file edit trix ..No help at all,
    I use a gravis black hawk(Digital)
    WinXP pro
    No matter what I enable or edit it just refuses to recognize my joystick.
    Ive been to every site and forums page out there
    Has anyone been able to get a gravis contoller to work?

  4. #34
    legacy-UTomicPUNK
    Guest
    This may sound a little basic, but all of the scenarios that can render your joystick unrecognizable need to be adressed.

    Did you calibrate your joystick in the "Gaming Options" utility? First and formost, Windows has to recognize your controller, otherwise no game will recognize it.

    Make certain that the controller is setup properly in Windows. With that being a given, then you can work on pinpointing whatever your problem is with the game recognizing it.

    Read this other "Joystick" thread which has additional info:

    http://www.ina-community.com/forums/...2&goto=newpost

    There is a lot of info posted between these two threads that should help.

    Good Luck


  5. #35
    legacy-Hellbender
    Guest
    UM...Yes lol
    Works with all other games except UT2003
    Im thinking its a (Gravis) issue.
    Thats y Im asking if anyone else with a gravis got thiers to work

  6. #36
    legacy-Duffmeister
    Guest
    My gravis xterminater works

    When you say it does not work, do you mean not at all or just not well enough to use?

    If it does not work at all check the following:
    1. your settings in UT2003 input screen, check to see if the use joystick is checkmarked. If it is not, it does no good to change it in the GUI, you have to go to the ut2003.ini file and find both joystick options and change them to true.

    If it works but not very well, then you need to check the user.ini file settings.

  7. #37
    legacy-UTomicPUNK
    Guest
    Hellbentforleather-

    LOL

    I figured that you were well aware of that.

    However, there are some here who are not, or may overlook it sometimes.

    The stick can be enabled in the UT2003.ini like so:

    [WinDrv.WindowsClient]
    WindowedViewportX=640
    WindowedViewportY=480
    FullscreenViewportX=1024
    FullscreenViewportY=768
    MenuViewportX=640
    MenuViewportY=480
    Brightness=0.870000
    Contrast=0.730000
    Gamma=1.070000
    UseJoystick=True
    CaptureMouse=True
    StartupFullscreen=True
    ScreenFlashes=False
    NoLighting=False
    MinDesiredFrameRate=33.000000
    Decals=True
    Coronas=False
    DecoLayers=False
    Projectors=False
    NoDynamicLights=False
    ReportDynamicUploads=False
    TextureDetailInterface=High
    TextureDetailTerrain=UltraHigh
    TextureDetailWeaponSkin=Higher
    TextureDetailPlayerSkin=Higher
    TextureDetailWorld=UltraHigh
    TextureDetailRenderMap=UltraHigh
    TextureDetailLightmap=UltraHigh
    TextureMaxLOD=0
    TextureMinLOD=0
    NoFractalAnim=True
    ScaleHUDX=0.000000

    (The red areas...DOHH!)

    [SDLDrv.SDLClient]
    WindowedViewportX=640
    WindowedViewportY=480
    FullscreenViewportX=800
    FullscreenViewportY=600
    MenuViewportX=640
    MenuViewportY=480
    Brightness=0.800000
    Contrast=0.700000
    Gamma=0.800000
    UseJoystick=True
    JoystickNumber=0
    IgnoreHat=False
    JoystickHatNumber=0
    CaptureMouse=True
    StartupFullscreen=True
    ScreenFlashes=True
    NoLighting=False
    MinDesiredFrameRate=0.000000
    Decals=True
    Coronas=True
    DecoLayers=True
    Projectors=True
    NoDynamicLights=False
    ReportDynamicUploads=False
    TextureDetailInterface=Normal
    TextureDetailTerrain=Normal
    TextureDetailWeaponSkin=Normal
    TextureDetailPlayerSkin=Normal
    TextureDetailWorld=Normal
    TextureDetailRenderMap=Normal
    TextureDetailLightmap=UltraHigh
    TextureMaxLOD=0
    TextureMinLOD=0
    NoFractalAnim=False

    Next, the User.ini should be set like this:

    Joy1=Fire
    Joy2=AltFire
    Joy3=getweapon TransLauncher
    Joy4=Jump
    Joy5=SwitchWeapon 8
    Joy6=SwitchWeapon 9
    Joy7=SwitchWeapon 6
    Joy8=SwitchWeapon 7
    Joy9=
    Joy10=
    Joy11=
    Joy12=
    Joy13=
    Joy14=
    Joy15=
    Joy16=
    JoyX=Axis aStrafe SpeedBase=32768.0 DeadZone=0.4
    JoyY=Axis aBaseY SpeedBase=32768.0 DeadZone=0.4 Invert=-1
    JoyZ=
    JoyR=
    JoyU=
    JoyV=
    JoySlider1=
    JoySlider2=


    The red area denotes the critical ini entries that enable proper movement with the controller.

    Also, once the controller is enabled and working properly, you CAN set functions for the controller's buttons in the GUI rather than exiting the game and editing the ini.

    If you have your INIz set like that, then the only other thing that I can suggest is there may be a conflict with the Gravis programming software.

    I have a Gravis Exterminator Dual Control, and I like it except for the lack of a 4th axis on the stick. I have had conflict issues with the Gravis software in the past. I use a Sidewinder Precision Pro Optical that works well.

    Happy troubleshooting......


  8. #38
    legacy-kazza
    Guest
    i have tryed all different ways in my ini files but nothing seems to work i have most dirrections except for left and it seems to move to the right on its own :cry:

  9. #39
    legacy-UTomicPUNK
    Guest
    :bulb:

    Can't comment on what I can't see...

    Post your sys settings!

    It's tough for anyone to give some pointers without seeing your ini settings and related info.

    If you post something, you are more likely to get responses toward getting your problem solved.

    C-ya

  10. #40
    legacy-kazza
    Guest
    its the d-pad im trying to get working,any ideas on what line i should alter in my ini files:bulb:

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •