PDA

View Full Version : Cooked Game Problem - Correct GameInfo has been loaded, but I cannot see my pawn



Uncomfortable
02-26-2012, 06:49 PM
I've been building a custom game in UDK, and I'm having some trouble cooking it. I've set up my INIs correctly as far as I can tell (switched all of the default game settings), and the map that loads once it has all been cooked is using my correct GameInfo class. The problem is, however, that I cannot see my pawn.

The pawn class uses a 3rd person camera, and I can see that this is working; if I run up too close to a wall, the camera automatically zooms in as it is supposed to. So that's functioning correctly. The problem is that the pawn itself is completely invisible.

If I load up the game using UDK.exe or load it up in the editor, it works fine.

What could be causing this? Could the cooker have an issue loading up my packages? The environment static meshes are all appearing, so while they're in a separate package, it leads me to think that this is not a package issue.

I know there was a setting in the pawn's skeletal mesh component, bOwnerNoSee, but that is set to false. I'm really drawing a blank here.

Edit: I had written out an explanation to the solution I found for this, but for some reason the forums never saw fit to approve my post? Anyways, the issue was that the package containing my character assets was not being included. I had to explicitly force them to be cooked in the DefaultEngine.ini file. I don't want to type out more than that, so if you would like more detail, refer to my reddit post on the matter: http://www.reddit.com/r/udk/comments/q7d7w/cooked_game_problem_correct_gameinfo_has_been/