PDA

View Full Version : HUD not showing up on device



FlameHaze
12-22-2010, 04:35 PM
Hello!! I'm a complete amateur developing with the UDK. I have read and completed several tutorials for creating HUDs. Each tutorial shows up appropriately in the mobile previewer, however, when I test it on my iPad itself, I only have the version number in the upper right corner.

Does anyone have and ideas, suggestions, or links that would be helpful?

Curious
12-22-2010, 07:38 PM
Hello!! I'm a complete amateur developing with the UDK. I have read and completed several tutorials for creating HUDs. Each tutorial shows up appropriately in the mobile previewer, however, when I test it on my iPad itself, I only have the version number in the upper right corner.

Does anyone have and ideas, suggestions, or links that would be helpful?

Make sure you carefully edit DefaultGame and DefaultEngine inis, specifically in DefaultEngine make sure that you first check you have added your stuff to be compiled by adding a package here:


[UnrealEd.EditorEngine]
+EditPackages=MyGame

and here:


[Engine.StartupPackages]
+Package=MyGame

Add them at the bottom...

Now in DefaultGame.ini make sure your gametype is setup properly (which includes your HUD/input control stuff)


[Engine.GameInfo]
DefaultGame=MyGame.MyGameInfo
DefaultServerGame=MyGame.MyGameInfo
DefaultGameType="MyGame.MyGameInfo"

and also make sure that you've added the specific input configs which are required for the input to function... Basically specific groups of controls you've defined in script and the ini.


[MyGame.MyGameInfo]
+RequiredMobileInputConfigs=(GroupName="UberGroup",RequireZoneNames=("UberStickMoveZone","UberStickLookZone","UberLookZone"))
+RequiredMobileInputconfigs=(GroupName="InitialFlybyGroup")

The specific group names for required mobile input configurations are yours to choose, these are the UDK's default.

Delete the Mobile*.inis

Hope it helps! Also, do a full recompile, full clean recook and place it on your iOS device. Should work now! And take it easy, Rome wasn't built in a day :D