PDA

View Full Version : Having weird problem with custom char. Need help



InhexSTER
02-19-2010, 01:14 PM
This screenshot is from the game. Character's arms and hand are in weird position (going through body and weapon is a bit down) :

http://f.imagehost.org/0073/ScreenShot00009.jpg

I adjusted UDK robot skeleton and skinned it to mesh
And here is screenshot of animation set (works just fine):

http://f.imagehost.org/0240/Capture.jpg

geodav
02-19-2010, 01:56 PM
I adjusted UDK robot skeleton and skinned it to mesh

beeen a rule of UT modding for years "don't" change to rig change your mesh
you can try using the UT3 female rig

for that problem i've found its all in your skinning, it does look ok in the editor/3d app but not in game, normally caused by your bones being switched, eg you managed to skin the left arm to the right bone, or the mirroring didn't work

InhexSTER
02-19-2010, 02:06 PM
By mirroring you mean mirror animations function? I never actually did it, because i used basic human male skeleton + human male animset. and as I looked for LIAM skeletal mesh it doesn't have mirroring

Could physics asset be causing this?

geodav
02-19-2010, 03:33 PM
doubtful as those anims don't use physics, like i said that sort of problem is normally caused by skinning, trust me i had a simular problem last week and i've been doing this sort of thing for years

FlynT
02-19-2010, 04:27 PM
I hope you don't release this model ;)

InhexSTER
02-19-2010, 04:51 PM
alright i will have to try to skin more simpler model and test it out.