PDA

View Full Version : Maya Skin File Creation Error



Empidi.87
01-25-2010, 06:43 AM
Title will give away my problem I suppose... But I'm working on a simple weapon in Maya and when I go to export I get "Skin File Creation Error". These are the steps I took to attach the Skel to the Mesh.

Selected root bone
Selected mesh
Went to skin -> Bind Skin -> Smooth Bind -> Options
in options I set Bind To: Selected Joints

Then I tried to export. Did I miss something?

Denny
01-25-2010, 08:32 AM
What is the whole error message?

Empidi.87
01-25-2010, 09:55 AM
Skin File Creation Error then Skin Save Error

Thats it

EDIT: Uploaded a vid of my process. http://www.youtube.com/watch?v=r5HK0bW0OzQ

Denny
01-25-2010, 11:43 AM
You have a dirty construction history on your mesh, delete history and try again. :)

Empidi.87
01-25-2010, 11:47 AM
Edit -> Delete By Type -> History right?

Did that and it still gives me the errors.

Denny
01-25-2010, 12:12 PM
Have you tried to just Bind Skin without setting specific joints and then skinweight afterwards?

Empidi.87
01-25-2010, 12:52 PM
Well actually I didn't realize that your export folder must exist before you export...

Denny
01-25-2010, 03:38 PM
LOL, **** happens! Good luck with your weapon. :D

Empidi.87
01-25-2010, 07:13 PM
Yeah, stupid little mistakes are always fun... But now I'm having another problem.

I added some moving parts to my mesh and all the anims and what not work perfectly in Maya (I'm using AXtended by the way, its awesome) but once I get the mesh and anims in to the editor I only see the basic movements. The slider on the top of the gun doesn't move, the clip doesnt fall out, etc. but the anims are all there because there is SOME movement. Do I have to combine all polys into one mesh before I bind it to the skeleton or... I don't know. Any thoughts?

Thank you very much by the way for your time Denny. I really appreciate it.

Kelt'ar
01-25-2010, 11:20 PM
Did U uncheck BRotation only: under the Animation tab?

Denny
01-26-2010, 03:29 AM
What Kelt'ar said, you need to uncheck that option as animations in Unreal only allows rotational motion by default as an optimization.