PDA

View Full Version : Normalmap seams in Zmapper



SidV
12-15-2009, 12:20 PM
Hi Guys,

I trying to find a solution for a Zmapper/UDK Pipeline.

The Situation: I did Character in 3dsmax, detail it in ZBrush and exporting normalmaps out of Zmapper. The normal map works fine within Zbrush as u can see below.

http://img710.imageshack.us/img710/5816/zmapper.jpg

But when i try to import the char and the normal map in UDK, i get this.


http://img684.imageshack.us/img684/2116/udks.jpg

As you can see i get seems at each UV Element. I spend several day now to figure out how to fix this, trying different settings in Zmapper. No success. I read several topics about this subject over at ZBruschcentral. None of the solutions worked in my case. Below you can see the UVLayout and the generated normal map out of Zmapper.

http://img163.imageshack.us/img163/9558/normalmap.jpg

I m pretty sure that this is a problem that a lot of people will have sooner or later. This really drives me nuts. I know there must be a solution for this. Mabe a different mapping method. Or maybe its just some setting in Zmapper that i dont tryed yet. Anyway, i'm out of ideas here,

PLS HELP!

fritzmonkey
12-15-2009, 12:49 PM
What software are you exporting the character's mesh from?

SidV
12-15-2009, 01:01 PM
3ds max 2010 and exported as obj with the zbrush default settings.

KalleW
12-15-2009, 01:10 PM
I have a very quick test for you. If this doesn't work then there are other things to try but just do this first.

Change the background color from white to rgb 128,128,255.

SidV
12-15-2009, 01:31 PM
Hey Kalle,

I know what u mean but this doesnt help. zmapper has "seaming overpaint" on by default. otherwise i would probably see white lines at the seems.

The problem is caused by how the UV's lay on the UV Grid and the way how the normal maps are rendered within ZBrush. So, red represent the x direction, green the y direction. If you take a look on the normal map u can see that, no matter how the UV's are layed, it has to run into problems.

What i dont understand is when ZBrush uses the same UV Layout and it looked good why is it that Max and UDK have this seem problem.

I also tryed different material ID's and put every UV Segment on a different UV Region so i can flip the red or green channel around within max, but that working neither.

If i could just find a way in Zmapper to confom the different color information for the normal map.

DELTATHUND3R
12-15-2009, 02:39 PM
did you click fix seams in zbrush?

SidV
12-15-2009, 02:52 PM
I dont know what u mean. Within Zmapper there is no "Fix Seems" button.

DELTATHUND3R
12-15-2009, 03:00 PM
Not in zmapper but in tool bar in Texture palette.Once u create your Uv click fix seams.Are u using GUV or AUV?
Also make sure you set zmapper too the right config for what your exporting it too.
If in max set it too max best quality or if maya set it too Maya tangent space node best quality.I will pull out my trusty zbrush books for ya and have aextra read up on seams :).

SidV
12-15-2009, 03:20 PM
No, that doesnt seem to help either. I'm using UV Tiles made in Max btw.
Did your book says anything about the settings in Expert Pass 1 or 2? Hard to get any info on that topic. I m sure the solution is somewhere in those Expert pass settings.

DELTATHUND3R
12-15-2009, 04:04 PM
will read up on this for you today.Im stuck looking after little one atm..
maybe try this in zbrush when exporting your obj make sure in prefrences Importexport iflip and eflip options are off.
Also under Tool menu click Export menu and make sure mrg is on and scale set to 1.
The book Im using too help is Scott Spencers character creation in zbrush..Its a worthy book matey if your getting into zbrush.Also Eric Keller has a awsome book called introducing zbrush..

johanz
12-15-2009, 04:47 PM
What about baking maps in max rather than zbrush?

SidV
12-15-2009, 06:24 PM
well, the flipped normal seems appears in max also, so that wouldnt really help i guess.

i discovered some flipped UV Elements and corrected them. that helped a little. but still, depending from wich angle your light falls you see the seems more or less. for example when the light falls direct from the point of view, the seems are less noticable. if it comes from another angle they appear more.

danimal'
12-15-2009, 06:39 PM
Have you tried just generating unique uv's (AUVs) within Zbrush for your high res mesh, exporting that high mesh with AUVs and then just letting xNormal have at it with your lower res mesh/ lower res mesh's uvs? It's one of the reasons xNormal is brilliant, let it sort it all out ;)

Follow one of Epic's own here:
http://picasaweb.google.com/TheEnolaJay/ZBrush3PolyPaintingTutorialI#5325724297275475186

danimal

SidV
12-15-2009, 07:37 PM
the tutorial u posted sound interesting. i heared a lot about xnormal, i think i should give it a try.

KazeoHin
12-15-2009, 07:46 PM
any UV seams will translate into hard edge normals.

wish that could change.

fritzmonkey
12-15-2009, 07:57 PM
It can change. It all depends on what you are exporting from, what you are exporting in to, and if they agree on a few things.

http://wiki.polycount.net/Normal_Map#head-50711a391d6648e90d1ed894e527f03d56bb7c3e

danimal'
12-15-2009, 08:31 PM
Not sure it'll solve your problems but if it looks decent in Zbrush, xNormal generally does great. Not to mention that in most peoples' opinion, xNormal flat out makes better normal maps. Free is nice too ;) Hope it helps, it's a great workflow for some assets (the tut I linked).

danimal

DELTATHUND3R
12-15-2009, 08:38 PM
nice tutorial....

SidV
12-15-2009, 09:24 PM
@danimal
i did my first shot in xnormal following the tut u posted. the result was the same hard egded seems. i dont know, maybe theres something wrong with my UV Layout. just cant figure out what :(

@fritzmonkey
thx for the link, i get a deeper look tomorrow.

SidV
12-16-2009, 10:33 AM
ok, following fritzmonkeys link i get some really useful info on tangent normals and some interesting approaches how to fix it.

one of them i tried was painting the seems with tangent default color (128,128,255). that works in some ways but depending on the light angle, you see the seems more or less. this isnt really a good solution

another thing i tried was to straight the uv seems to a 90 degree angle to avoid any diagonal seems that doesnt match with the opposite. epic uses the same technique and straight the uv's when ever possible as u can see if u take a look on their textures. but even that doesnt seem to work in my case cause i have one continuous mesh.

the internet forums are full of topics on that subject. they fighting this problem for years now and you can find topics on that matter on a daily basis over at zbrushcental. it seems there isnt really a perfect solution to this. normalmaps exists for almost a decade now and the industry are not able to agree on some kind of standard. really sad. so this is not just a zmapper problem, i read mudbox got the same issues.

i guess i have to live with that wich is really frustrating. :(

danimal'
12-17-2009, 12:08 AM
Um, well tbh UV seams have always existed and always will. The trick is to hide your seams, for instance you shouldn't be running the seam along the shoulder/neck. Most people split under the arms for example and with clothing there's always a place you can effectively hide it. Depending on how the model is viewed, you just have to put it in the least obvious place that a person is likely to see. It's not really a flaw or a bug, it's a reality of translating a 3d object into 2d. :/

danimal

Deranged
12-20-2009, 06:21 AM
why are you even using zmapper isn't 3.5 release 3 out already haha

SidV
02-04-2010, 12:32 PM
Ok, mystery solved

No more seems in normalmaps! thx for the help anyway. :D

Before:
http://img51.imageshack.us/img51/4605/seem.jpg

After:
http://img51.imageshack.us/img51/9898/seemless.jpg

darthviper107
02-04-2010, 03:59 PM
How did you fix the issue? I've got the same problem with some static meshes I'm working with, they look fine in 3ds Max but they've got those horrible seams in UDK

SidV
02-04-2010, 04:33 PM
by fading in along the seems with a rich bluetone rgb[0.0.255]. simple as that. :p


http://img168.imageshack.us/img168/2738/normald.jpg

Octo
02-04-2010, 04:57 PM
Hey
It looks like you've changed the UV's a bit judging by the last screenshot, but if you haven't, you should.
You are (were) wasting a huge amount of uv space. And that's not even counting mirroring, which you should generally do on symmetric parts such as arms, legs, hands and feet.