PDA

View Full Version : building light in terrain problem



scan36
12-02-2009, 01:22 AM
can anybody tell me why when i press build all in the udk terrain editor i keep getting the lightning build fail, see the log for more information, not allowing me to build lighthing in the terrain mode thanks anyone

Denny
12-02-2009, 03:08 AM
If you're using Lightmass, check the Swarm client and its log. It's most likely that you ran out of memory, it happened for me and only way to solve it was to lower the lighting build quality.

It's most likely that you're supposed to have a cluster of computers making the quality build.

scan36
12-02-2009, 07:28 AM
ok i reduce thye lighthing quality to preview but i still get the error this is what i get on swarm log

(7:21:11 AM: [Interface:OpenChannel] Error: System.IO.FileNotFoundException: Could not find file 'C:\SwarmCache\9AD45E32DF274C5496821EDD0112A82B.62 E40CCD44633A3ECF87F984722EB1E9.mtrl'.
File name: 'C:\SwarmCache\9AD45E32DF274C5496821EDD0112A82B.62 E40CCD44633A3ECF87F984722EB1E9.mtrl'
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at System.IO.File.ReadAllBytes(String path)
at NSwarm.FSwarmInterfaceManagedImpl.OpenChannel(Char * ChannelName, TChannelFlags ChannelFlags)

dont truly know what all that means but is there other type of lighting i could use that takes less memory thanks

Rives
12-02-2009, 07:30 AM
Apparently, it's a file problem:


Could not find file 'C:\SwarmCache\9AD45E32DF274C5496821EDD0112A82B.62 E40CCD44633A3ECF87F984722EB1E9.mtrl'.

scan36
12-02-2009, 08:13 AM
maybe i should try doing the terrain as a static mesh instead the unreal terrain editor en exported into unreal

Rives
12-02-2009, 08:34 AM
I would recommend enabling stand alone mode in the Swarm Agent if you don't have more than one machine for Lightmass processing.

scan36
12-02-2009, 09:11 AM
where do you find that setting in the swarm agent thanks

Rives
12-02-2009, 10:36 AM
In the Swarm Agent window, under the Settings tab, down in the Distributions Settings you have the "EnableStandaloneMode" option. Set it to true.

scan36
12-02-2009, 10:57 AM
just did the EnableStanAlone to true and no luck stiil get could not rebuild light error any other suggestions

?

Rives
12-02-2009, 11:05 AM
Might be a .net Framework problem. Try (re)installing 3.5 SP1.

scan36
12-02-2009, 11:10 AM
whats the 3.5 sp1 i am also using the lates version of udk also had the same problem with the older version

Rives
12-02-2009, 11:11 AM
It's the .net Framework. I don't think it's an UDK issue, but rather a configuration one.

scan36
12-02-2009, 11:20 AM
where can i dowload that .net3.5 sp 1 thanks

Rives
12-02-2009, 11:21 AM
Here (http://www.microsoft.com/downLoads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en). Also, Google is a great friend. :P

scan36
12-02-2009, 11:47 AM
i am so sorry i google it up before ur reply and installed stiil gives me the same error i will try to restart the computer see in that works thanks

Rives
12-02-2009, 11:52 AM
This issue is still unresolved on an older thread. As a temporary fix, you may disable Lightmass. I can't think of anything else at the moment, sorry.

scan36
12-02-2009, 06:39 PM
i am sorry for my ignorance but where can i find the setting for diabaling lightmass i have try the light properties but can not see it thanks