PDA

View Full Version : Can't Run Editor on Vista-64



MattCan36
11-09-2009, 04:14 AM
Log: === Critical error: ===
Fatal error!

System.Windows.Markup.XamlParseException error in PresentationFramework:

The property 'ContentStringFormat' does not exist in XML namespace 'http://schemas.microsoft.com/winfx/2006/xaml/presentation'. Line '40' Position '288'.

at System.Windows.Markup.XamlParser.ThrowException(St ring message, Int32 lineNumber, Int32 linePosition)
at System.Windows.Markup.XamlParser.ThrowException(SR ID id, String value1, String value2, Int32 lineNumber, Int32 linePosition)
at System.Windows.Markup.XamlParser.WriteUnknownAttri bute(XamlUnknownAttributeNode xamlUnknownAttributeNode)
at System.Windows.Markup.TemplateXamlParser.WriteUnkn ownAttribute(XamlUnknownAttributeNode xamlUnknownAttributeNode)
at System.Windows.Markup.XamlParser.ProcessXamlNode(X amlNode xamlNode, Boolean& cleanup, Boolean& done)
at System.Windows.Markup.TemplateXamlParser.ProcessXa mlNode(XamlNode xamlNode, Boolean& cleanup, Boolean& done)
at System.Windows.Markup.XamlParser.ReadXaml(Boolean singleRecordMode)
at System.Windows.Markup.XamlParser._Parse()
at System.Windows.Markup.TemplateXamlTreeBuilder.Pars eFragment()
at System.Windows.Markup.XamlTemplateSerializer.Conve rtXamlToObject(XamlReaderHelper tokenReader, ReadWriteStreamManager streamManager, ParserContext context, XamlNode xamlNode, BamlRecordReader reader)
at System.Windows.Markup.StyleXamlParser.WriteElement Start(XamlElementStartNode xamlElementStartNode)
at System.Windows.Markup.XamlParser.ProcessXamlNode(X amlNode xamlNode, Boolean& cleanup, Boolean& done)
at System.Windows.Markup.StyleXamlParser.ProcessXamlN ode(XamlNode xamlNode, Boolean& cleanup, Boolean& done)
at System.Windows.Markup.XamlParser.ReadXaml(Boolean singleRecordMode)
at System.Windows.Markup.XamlParser._Parse()
at System.Windows.Markup.StyleXamlTreeBuilder.ParseFr agment()
at System.Windows.Markup.XamlStyleSerializer.ConvertX amlToObject(XamlReaderHelper tokenReader, ReadWriteStreamManager streamManager, ParserContext context, XamlNode xamlNode, BamlRecordReader reader)
at System.Windows.Markup.TreeBuilderXamlTranslator.Wr iteElementStart(XamlElementStartNode xamlElementStartNode)
at System.Windows.Markup.XamlParser.ProcessXamlNode(X amlNode xamlNode, Boolean& cleanup, Boolean& done)
at System.Windows.Markup.XamlParser.ReadXaml(Boolean singleRecordMode)
at System.Windows.Markup.TreeBuilderXamlTranslator._P arse()
at System.Windows.Markup.XamlTreeBuilder.ParseFragmen t()
at System.Windows.Markup.TreeBuilder.Parse()
at System.Windows.Markup.XamlReader.XmlTreeBuildDefau lt(ParserContext pc, Stream stream, XamlParseMode parseMode, Boolean etwTracingEnabled)
at System.Windows.Markup.XamlReader.Load(Stream stream, ParserContext parserContext)
at CLRTools.CreateWPFWindowFromXaml(HWND__* ParentWindow, String XamlFileName, String WindowTitle, Int32 X, Int32 Y, Int32 Width, Int32 Height, Int32 WindowStyle, Int32 ExtendedWindowStyle, Int32 WindowClassStyle, Boolean bUsesPerPixelOpacity, Boolean bSizeToContent)
at MWPFWindowWrapper.InitWindow(HWND__* InParentWindowHandle, String InWindowTitle, String InWPFXamlFileName, Int32 InPositionX, Int32 InPositionY, Boolean bCenterWindow, Int32 InFakeTitleBarHeight)
at MLightmapResRatioWindow.InitLightmapResRatioWindow (HWND__* InParentWindowHandle)
at FLightmapResRatioWindow.CreateLightmapResRatioWind ow(HWND__* InParentWindowHandle)
at GuardedMain(Char* , HINSTANCE__* , HINSTANCE__* , Int32 )
at ManagedGuardedMain(Char* CmdLine, HINSTANCE__* hInInstance, HINSTANCE__* hPrevInstance, Int32 nCmdShow)Address = 0x7668e05c (filename not found) [in C:\Windows\syswow64\KERNEL32.dll]
Address = 0x79f9691a (filename not found) [in C:\Windows\Microsoft.NET\Framework\v2.0.50727\msco rwks.dll]
Address = 0x7a098f8f (filename not found) [in C:\Windows\Microsoft.NET\Framework\v2.0.50727\msco rwks.dll]
Address = 0x3859da0 (filename not found)
Address = 0x147c3c0 (filename not found) [in C:\UDK\UDK-2009-11\Binaries\Win32\UDK.exe]
Address = 0x15ec007 (filename not found) [in C:\UDK\UDK-2009-11\Binaries\Win32\UDK.exe]
Address = 0x79e8273b (filename not found) [in C:\Windows\Microsoft.NET\Framework\v2.0.50727\msco rwks.dll]
Address = 0x79e8273b (filename not found) [in C:\Windows\Microsoft.NET\Framework\v2.0.50727\msco rwks.dll]
Address = 0xa20138 (filename not found) [in C:\UDK\UDK-2009-11\Binaries\Win32\UDK.exe]
Address = 0xa20138 (filename not found) [in C:\UDK\UDK-2009-11\Binaries\Win32\UDK.exe]

Exit: Executing UObject::StaticShutdownAfterError
Exit: Executing UWindowsClient::ShutdownAfterError
Exit: Executing UWindowsClient::ShutdownAfterError
Exit: UXAudio2Device::ShutdownAfterError
Log: Shutting down FaceFX...
Log: FaceFX shutdown.
Exit: Exiting.
Log: Log file closed, 11/09/09 04:03:30


That's my log file, I've re-installed .NET a bunch of times, installed new video card drivers and nothing seems to work.

I'm on Vista-64 with a Quad-Core, GeForce 8800 GTX Supercharged and 8gb of ram.

Can someone please offer a solution?

DarkVeil
11-09-2009, 09:29 AM
Based on the error message, it looks like some .NET Framework components are missing or not installed properly.

Have you tried downloading the following .NET 3.5 SP1 installer and running that?

http://www.microsoft.com/downloads/details.aspx?FamilyID=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en

Make sure to reboot afterward. Failing this, you can try repairing (http://support.microsoft.com/kb/306160)your .NET Framework installation in place.

MattCan36
11-09-2009, 02:09 PM
I've tried repairing and rebooting after the install to no avail.

MattCan36
11-09-2009, 02:10 PM
I'll try that tutorial as well and let you know what happens this has been incredibly frustrating.

MattCan36
11-10-2009, 02:29 AM
tried the tutorial and clearing out all of .NET and reinstalling... still no luck no idea WTH is going on.