PDA

View Full Version : Unable to host with patch 1.1



jswashburn
12-11-2007, 10:37 PM
After I installed the 1.1 patch (public final release), I'm no longer able to host a server. I get the message...

ERROR: Your network configuration is not compatible with hosting matches. Please check your router’s manual for instructions on setting up ‘Port Forwarding’ or a ‘DMZ server’

My PC has a static IP. All UT3 ports are forwarded to it correctly and I have uPnP enabled in my router. I'm not running any anti-virus software (just AVG) or anything that might act as a 3rd party software firewall. As such, I've turned of the Windows firewall for troubleshooting purposes. I haven't put my PC behind the DMZ yet as that would defeat the purpose of using my router as a SPI firewall.

I'm using a D-Link DGL-4300 gamefuel router with firmware rev 1.8. Doing a google search has reported at least two other users having trouble after the patch with the same router. Is it just a quencidence, or does anyone else have the same issue here?

Dubious
12-12-2007, 12:35 AM
post deleted

agentq_71
12-12-2007, 01:21 AM
I am having this exact same issue.

Dubious, I noticed that you're using the dedicated server. I get this error message when I try to host through the UT3 GUI.

[ST2]Unborn
12-12-2007, 04:27 AM
Yeah this is a bug i guess. I got it to, the only way to go through is setting DMZ but it is just a (dangerous) workaround.

Epic did a very bad job on network code i think.

(¯°·«èXó»·°¯)
12-12-2007, 06:52 AM
Have same router, DGL-4300 and we too are unable to host a server via in-game menu. :/

MasterB
12-12-2007, 07:22 AM
I have had the same problem/error message with all beta patches and the final patch as well.
If I launch a LAN match, I get the error message but if I click "OK", it allows me to proceed and create the LAN match. Others can join.
For some reason the option of selecting Internet or LAN is not selectable. It's stuck on LAN and I can't change it.
I shouldn't have to go into my router settings and change something that worked fine without the patch installed. There is too much risk of me messing something up.
I have posted this problem several times in these foroms. EPIC must be aware of the problem.
:(:(

NakedApe
12-12-2007, 07:30 AM
This is most likely due to the master server checking if your source port is randomized when connecting. That is one of two checks (the other one being that the gameport is reachable from the master) that triggers this message.
It is a counterproductive check in my opinion since it screws most owners of SOHO class routers (which do not have an option to turn randomization on/off) and also it has absolutely no bearing on the ability of the server to function.

This is exactly the same problem that UT2k* had with NAT and this was reported to Epic over 4 years ago. Let's see if they address it this time around...

Jesko
12-12-2007, 07:55 AM
same for me:
can not host UT3 games, too ("your network configuration is not compatible with hosting matches").
But I can
* host warcraft 3 games without any problems (portforward 6612)
* host UT3 games when I activate DMZ in my router
* host a UT3 server with a start.bat

I have tryed following portforwards (controlled used ports with TCP-View):
2299 listening port
3478
6500
13000
27900

and also tryed different combinations with UDP/TCP or both and with some of the list above. No success. So I assume, that my router blocks something other routers don't block. But I have no idea, what it could be. It has to be something very special in ut3. Because I have no problems to host other games (warcraft 3; CS; etc.)

My system:
UT3 1.1
router linksys wrt54gl with Firmware: DD-WRT v23
win xp pro, no local firewall activated

So no idea what is wrong?
Only workaround for friends game:
what you have to do:
1. forward port 7777 in your router to your LAN-IP (something like 192.168.1.xxx)
2. open a LAN-Game

what your friends have to do:
1. open console in ut3 by pressing TAB or F10
2. than they have to type open and your (the HOST) WAN-IP (http://www.whatismyip.de/) and add :7777 (e.g. open 85.178.xxx.xxx:7777)

Greetings,
Jesko.

agentq_71
12-12-2007, 09:59 AM
This is most likely due to the master server checking if your source port is randomized when connecting.

What does that even mean? In almost all network applications, the source port is chosen by the operating system from a certain port range when the connection is initiated. On top of that, when using NAT with a single external IP address (which almost all home users will have), the source port on the router will most likely not match the source port on the PC.

It would be pure insanity for any network application to insist on a static source port.



This is exactly the same problem that UT2k* had with NAT and this was reported to Epic over 4 years ago. Let's see if they address it this time around...

This is not a problem that UT has ever had before. I've run servers since UT and never had this issue. I have a friend who has both UT2k4 and UT3 installed _right now_ and can host a 2k4 server just fine, but not a UT3 server.

From what I can see, this really seems to be a problem specific to launching a server from the in game UI. Otherwise, we'd be seeing a lot more server admins complaining about it since some of the people in here are having problems with very common routers.

ScuzzBuster
12-12-2007, 10:36 AM
I get that ERROR: Your network configuration is not compatible with hosting matches. Please check your router’s manual for instructions on setting up ‘Port Forwarding’ or a ‘DMZ server’ if when I try to go into MP from the retail version. With no changes to my network config or router though I'm still able succesfully host internet games with the dedicated version from the same machine.

Dubious
12-12-2007, 11:29 AM
I am having this exact same issue.

Dubious, I noticed that you're using the dedicated server. I get this error message when I try to host through the UT3 GUI.
I also have no problems starting a game using retail GUI on this same computer. I just checked it to be sure.

I dont know what you people using DLink DGL-4300 routers are doing, but I just showed you exactly how mine is setup and it works without any problem. Some of you say "I have the same router and also have this problem" but you make no mention if you set your router up to match what I have, and didnt post any screen shots of your config either. There is no way to even troubleshoot it if you just say "it doesnt work." :confused:

Dubious
12-12-2007, 11:36 AM
I shouldn't have to go into my router settings and change something that worked fine without the patch installed. There is too much risk of me messing something up.
Well, yes, you may have to change settings in some cases, because there were changes made to the way UT3 fundamentally handles NAT transversal. It is naive to think that you shouldn't have to change as well. In some cases, changes may have to be made in order to support this functionality post-patch.

If you are concerned with messing something up then you likely do not know enough about networking to understand why this isn't working for you. I don't mean to sound rude when I say that, I'm just trying to put things into perspective.

Dubious
12-12-2007, 11:48 AM
Ok, those of you running D-Link DGL-4300 routers

I think I found the magic bullet for you.
1. Login to your router's web interface
2. Go to Advaced --> Firewall
3. Look at the settings for "NAT Endpoint Filtering"
- "UDP Endpoint Filtering" needs to be set to "Endpoint Independent"

If you have this set to anything other than "Endpoint Independent" then the UT3 GUI will give the error message and not allow you to host an Internet server.

I do not know if this setting also exists on other D-Link routers. I do not know the equivalent setting on Linksys or other brand routers. But, here is the D-Link description of this setting:

NAT Endpoint Filtering

The NAT Endpoint Filtering options control how the router's NAT manages incoming connection requests to ports that are already being used.

Endpoint Independent
Once a LAN-side application has created a connection through a specific port, the NAT will forward any incoming connection requests with the same port to the LAN-side application regardless of their origin. This is the least restrictive option, giving the best connectivity and allowing some applications (P2P applications in particular) to behave almost as if they are directly connected to the Internet.

Str1der
12-12-2007, 11:50 AM
What does that even mean? In almost all network applications, the source port is chosen by the operating system from a certain port range when the connection is initiated. On top of that, when using NAT with a single external IP address (which almost all home users will have), the source port on the router will most likely not match the source port on the PC.

It would be pure insanity for any network application to insist on a static source port.


Some NAT routers will change the external port even when they don't need to. ie if port 7777 is available on the public ip the router should attempt to use that first, though some will change it anyway. Your problem may be the "unsolicited connection" check.

One of the devs posted this:

There are 2 checks that determine whether or not your router is "strict".
The first is it checks to see if the outgoing port is randomized. The game
communicates on 7777, but some routers may map that to a completely
different port. This would need to be disabled in order to host a server.

The other check is whether or not an unsolicited connection request will be
accepted by your router. Most will accept responses, but if there wasn't an
outgoing request first, some servers will just blanket reject the incoming
request. Again, this would need to be disabled in order to host a server.

Whether or not your server has 1 or both of these issues, I don't know, but
either would trigger the strict nat warning and disable internet hosting.

Hope that helps!

Jeff

Though I'm not sure why it works with the dedicated server for some but not a listen server. Could be a bug. For those who had it work with with the dedicated server but not a listen server: where you able to actually have people connect and play ok also?

LordStrider
12-12-2007, 12:07 PM
.........For those who had it work with with the dedicated server but not a listen server: where you able to actually have people connect and play ok also?

Yes, I can connect to my dedicated box using serverbehindNAT (Linksys Router). I've tested connections both internally on my 192 subnet and externally from other computers. No DMZ or anything odd, just straight what one would expect to do to make it work. After the STUN option was added my server just started working.

NakedApe
12-12-2007, 01:56 PM
This is not a problem that UT has ever had before.

Oh really? (http://ataricommunity.com/forums/showthread.php?t=234947)

agentq_71
12-12-2007, 03:00 PM
Oh really? (http://ataricommunity.com/forums/showthread.php?t=234947)

I guess I should rephrase - it's not a problem _I've_ ever experienced with UT before. Thanks for the link though, it's a much better explanation than "This is most likely due to the master server checking if your source port is randomized when connecting".

It's also a pretty crappy implementation :P.

MasterB
12-12-2007, 08:32 PM
Well, yes, you may have to change settings in some cases, because there were changes made to the way UT3 fundamentally handles NAT transversal. It is naive to think that you shouldn't have to change as well. In some cases, changes may have to be made in order to support this functionality post-patch.

If you are concerned with messing something up then you likely do not know enough about networking to understand why this isn't working for you. I don't mean to sound rude when I say that, I'm just trying to put things into perspective.

Ok Mr condescending, What IP address do I set my DMZ server to?
Also just FYI, I have 20 or so games that I play on-line that do not require router setting changes to play then, they play out of the box. That includes UT2004.

Dubious
12-12-2007, 08:51 PM
Ok Mr condescending, What IP address do I set my DMZ server to?
I have no way of knowing that, as I don't know what subnetting schema you used on your LAN nor anything about how your routing policy is setup.

Also just FYI, I have 20 or so games that I play on-line that do not require router setting changes to play then, they play out of the box. That includes UT2004.
My point is that you cannot simply say "Well I'm not going to make changes so it better just work." If you want it to function you may have to make changes. Its as simple as that.

agentq_71
12-12-2007, 09:44 PM
Ok, those of you running D-Link DGL-4300 routers

I think I found the magic bullet for you.
1. Login to your router's web interface
2. Go to Advaced --> Firewall
3. Look at the settings for "NAT Endpoint Filtering"
- "UDP Endpoint Filtering" needs to be set to "Endpoint Independent"

If you have this set to anything other than "Endpoint Independent" then the UT3 GUI will give the error message and not allow you to host an Internet server.

I do not know if this setting also exists on other D-Link routers. I do not know the equivalent setting on Linksys or other brand routers. But, here is the D-Link description of this setting:

I do not have any such option in my router, so I guess I'm SOL. This really is a craptastic networking implementation.

What really burns me is that it seems to be a problem specific to communicating with the master server. Which means that you should still be able to set up a server that people can connect to by directly entering your IP, but this new check doesn't even let you do that.

Creole Ned
12-12-2007, 10:04 PM
Ok, those of you running D-Link DGL-4300 routers

I think I found the magic bullet for you.
1. Login to your router's web interface
2. Go to Advaced --> Firewall
3. Look at the settings for "NAT Endpoint Filtering"
- "UDP Endpoint Filtering" needs to be set to "Endpoint Independent"

If you have this set to anything other than "Endpoint Independent" then the UT3 GUI will give the error message and not allow you to host an Internet server.

I do not know if this setting also exists on other D-Link routers. I do not know the equivalent setting on Linksys or other brand routers.

I am one of those nutty people who bought an MS router (the MN 100) during the brief time they made them. There is no such setting in my router config. I was able to host games with the UT3demo but as of patch 1.1, the network error cited in the OP is preventing my server from hosting.

I'm not afraid to change my router settings but I have nothing I *can* change.

Dubious
12-12-2007, 10:26 PM
Guys,

My apologies but this thread was started by someone who was having a problem hosting behind a D-Link DGL-4300. Another person in this thread also has this router. I happen to have the same router and was (hopefully) able to identify a setting to fix the problem. I do not have access to your routers or settings to say if there is an equivalent setting change that will work for you.

At this point I'm waiting for one of the two people to say whether or not the fix worked for them. I have private msgs into both users as well. Hopefully they will respond and we can mark one model of router off of the list. :)

MasterB
12-13-2007, 07:50 AM
And my point is that you cannot ask the average user to make this type of setting change to their routers just to play a single game. My router came with my Verizon FIOS. It is used for both TV and Internet. They set it up. I had to go through He** just to get information on how to access it with the correct log-in and password. This forum is full of posts relating to the confusion caused by the port forwarding/DMZ issue. Every other game I have played on-line has worked out of the box. UT3 is the only exception. I don't question your ability to deal with this. It's the average user (or even higher) that I am concerned about and that includes me.

Dubious
12-13-2007, 03:16 PM
One of the two people running the DGL-4300 router got back to me and said that the fix in this post (http://gearsforums.epicgames.com/showpost.php?p=25164157&postcount=13) worked for them and they can now host matches.

The setting is only available in firmware v1.17 and higher.

jswashburn
12-13-2007, 07:20 PM
For the record, I agree with MasterB. Some games will require a few work-arounds here and there when it comes to using a router. But UT3 takes the cake. I've never been more frustrated with a game (let alone any application) than this one regarding NAT/firewall issues! And this is comming from someone who does IT Admin work for a living. That said however, I couldn't have gotten half as far without Dubious's extensive UT3 knowledge. For that, I'm very grateful. :)

Back on topic; I just set TCP/UDP to "Endpoint Independent". While that cleared up the error, I've ran into a another issue. For some bloody reason, I can't get the game to publish to the MBL (Master Browser List). In fact, I left my server running for over six hours in case there was some delay on their end.

My router logs reported that incomming traffic on ports 6501, 6502, 6503, and 6504 were blocked. I forwarded those ports too just in case, but no go. Should I forward port TCP 27900 to my internal IP too? I seem to remember seeing it in my "netstat -a" list via command prompt. I've heard this port is the MasterServerPort.

Any suggestions?

Dubious
12-13-2007, 09:08 PM
For some bloody reason, I can't get the game to publish to the MBL (Master Browser List). In fact, I left my server running for over six hours in case there was some delay on their end.

My router logs reported that incomming traffic on ports 6501, 6502, 6503, and 6504 were blocked. I forwarded those ports too just in case, but no go. Should I forward port TCP 27900 to my internal IP too? I seem to remember seeing it in my "netstat -a" list via command prompt. I've heard this port is the MasterServerPort.

Any suggestions?
If you have the first patch installed, the only ports you should need to forward are UDP 6500, 7777, and 13000.

With that said, the most common root cause of not being able to see your server in the server browser is a failing Gamespy login/password. Even if you think you are fine, go ahead and login to the game as a player, using your server username/password. Make sure that it works. Remember that your server must have its own unique login.

The second most common root cause is that your server is running a mutator, and you forget to set your server browser search parameters to 'Any' for "pure" servers.

The third most common root cause is that you have a software firewall active on your PC and did not set an exception / open necessary ports for UT3.

mrthundercleese
12-13-2007, 10:37 PM
My 2c.

I have a DGL-4300 and I had to do two things. 1) Check the box as suggested by Dubious and 2) change my software firewall to 'medium' protection settings (zonealarm). Tadah, it works. Thanks Dubious.

jswashburn
12-14-2007, 01:06 AM
I seriously doubt it's my router as it's configured exactly how Dubious has his setup. Still a no-go for me. :(

I've already looked through my string, but perhaps I'm overlooking something?


ut3.exe Server vCTF-Necropolis?MaxPlayers=16?MinNetPlayers=0?NumPublic Connections=16?NumPrivateConnections=0?NumOpenPubl icConnections=16?NumOpenPrivateConnections=0?bShou ldAdvertise=True?bIsLanMatch=False?bUsesStats=True ?bAllowJoinInProgress=True?bAllowInvites=True?bUse sPresence=True?bAllowJoinViaPresence=True?bUsesArb itration=False?bIsDedicated=True?bIsListPlay=False ?OwningPlayerName=?PingInMs=0?AverageSkillRating=1 000.000000?GameMode=3?Difficulty=2?PureServer=1?Lo ckedServer=0?Campaign=0?ForceRespawn=0?CustomMapNa me=vCTF-Necropolis?CustomGameMode=UTGameContent.UTVehicleC TFGame_Content?GoalScore=5?TimeLimit=45?ServerDesc ription=072000111000117000115000116000111000110000 032000084000088000?NumPlay=1?game=UTGameContent.UT VehicleCTFGame_Content?AdminPassword=example -log=DedicatedServer.log -Login=example -Password=example -nohomedir -unattended

Dubious
12-14-2007, 10:08 AM
I've already looked through my string, but perhaps I'm overlooking something?
It may be your string. It has a lot of unnecessary stuff in it that may be causing problems. You have the patch installed on the server, right? Try this one, which should give you the exact same settings:


ut3.exe Server vCTF-Necropolis?MaxPlayers=16?MinNetPlayers=0?GameMode= 3?ForceRespawn=0?GoalScore=5?TimeLimit=45?ServerDe scription=0720001110001170001150001160001110001100 00032000084000088000?NumPlay=1?game=UTGameContent. UTVehicleCTFGame_Content?AdminPassword=example -log=DedicatedServer.log -Login=example -Password=example -nohomedir -unattended

XSStanky
12-14-2007, 06:24 PM
[QUOTE=agentq_71;25163846]
It would be pure insanity for any network application to insist on a static source port.

Yea, those wacky FTP programs and their port 21 and the craziest of them all Interzillafari and port 80. :D:p:D

agentq_71
12-15-2007, 09:21 AM
It would be pure insanity for any network application to insist on a static source port.

Yea, those wacky FTP programs and their port 21 and the craziest of them all Interzillafari and port 80. :D:p:D

Those are destination ports, not source ports. Whenever you establish a network connection, that connection consists of [your IP]:[port chosen by operating system or application] -> [server IP]:[port server is listening on].

The [port server is listening on] part is 21 for FTP, 80 for HTTP, etc.

Things get more complicated when you're behind a NAT because you wind up with two connections:

[local machine IP]:[port chosen by operating system or application] -> [router IP]:[port server is listening on]
and
[IP of router]:[port chosen by router] -> [server IP]:[port server is listening on]

In plain English, my understanding of the problem with hosting UT servers is that the network code expects [port chosen by router] to behave a certain way. Depending on the router, the user may or may not have control over this and the router may or may not work the way that UT expects it to.

This means that you may or may not be able to host a UT server depending on the router you have, which in my opinion means it's a horrible network code implementation.

Syxx
12-15-2007, 03:30 PM
Has anyone had any luck hosting matches on Linksys routers? I've tried just about everything I can think of, the only thing thats worked is enabling DMZ :/

WRT54GS
http://img137.imageshack.us/img137/5551/50573191lh0.th.png (http://img137.imageshack.us/my.php?image=50573191lh0.png)
http://img167.imageshack.us/img167/1658/16624396pk3.th.png (http://img167.imageshack.us/my.php?image=16624396pk3.png)
http://img167.imageshack.us/img167/6163/45533425gg0.th.png (http://img167.imageshack.us/my.php?image=45533425gg0.png)

These are basically the only options available to configure..

MasterB
12-15-2007, 03:42 PM
read this. http://utforums.epicgames.com/showthread.php?t=592943
look for similar settings in your router firewall settings. Input the IP address of the server and enable DMZ server. I think it will do the same.
I need to warn you I an no network expert. Write down your old settings.

Corey
12-15-2007, 05:27 PM
Has anyone had any luck hosting matches on Linksys routers? I've tried just about everything I can think of, the only thing thats worked is enabling DMZ :/

WRT54GS
http://img137.imageshack.us/img137/5551/50573191lh0.th.png (http://img137.imageshack.us/my.php?image=50573191lh0.png)
http://img167.imageshack.us/img167/1658/16624396pk3.th.png (http://img167.imageshack.us/my.php?image=16624396pk3.png)
http://img167.imageshack.us/img167/6163/45533425gg0.th.png (http://img167.imageshack.us/my.php?image=45533425gg0.png)

These are basically the only options available to configure..
Same here

http://www.pnw4runners.com/gaming/linksys.jpg

As posted elsewhere I can only host if I enable that DMZ thing which I do not like.
It leaves you pretty much wide open I hear.

General.Jung
12-15-2007, 07:56 PM
Hello Forum,

a DMZ will solve the problem, but this really no choice also with a client software firewall.

Big_Poppy
12-15-2007, 09:30 PM
I have this problem as well. I run a SOHO Juniper SSG 5 GT firewall. I have tried everything, named source ports, all ports, no protection, switched to DMZ, you name it. By trade I'm a CISO, so I have some experience here. I run a TF2 server and over my years have hosted just about every game out there.

I'm starting to think we have a 1.1 bug and would like to see EPIC step up and comment. I just sunk a considerable amount of money for the software and hardware upgrades to host/play it.

Let's get some love!!

Corey
12-15-2007, 10:17 PM
Tell me about it.
I spent a little over $200.
I bought three of the special edition ones for my son, a friend, and me.

I would like to see Epic fix this, and other bugs such as mutators not sticking when you come back to host later.

GunghoIguana
12-15-2007, 10:45 PM
same for me:
can not host UT3 games, too ("your network configuration is not compatible with hosting matches").
But I can
* host warcraft 3 games without any problems (portforward 6612)
* host UT3 games when I activate DMZ in my router
* host a UT3 server with a start.bat

I have tryed following portforwards (controlled used ports with TCP-View):
2299 listening port
3478
6500
13000
27900

and also tryed different combinations with UDP/TCP or both and with some of the list above. No success. So I assume, that my router blocks something other routers don't block. But I have no idea, what it could be. It has to be something very special in ut3. Because I have no problems to host other games (warcraft 3; CS; etc.)

My system:
UT3 1.1
router linksys wrt54gl with Firmware: DD-WRT v23
win xp pro, no local firewall activated

So no idea what is wrong?
Only workaround for friends game:
what you have to do:
1. forward port 7777 in your router to your LAN-IP (something like 192.168.1.xxx)
2. open a LAN-Game

what your friends have to do:
1. open console in ut3 by pressing TAB or F10
2. than they have to type open and your (the HOST) WAN-IP (http://www.whatismyip.de/) and add :7777 (e.g. open 85.178.xxx.xxx:7777)

Greetings,
Jesko.

This workaround works for me.

GunghoIguana
12-15-2007, 10:48 PM
Jesko's workaround works for me (see page 1 post), and I'm using a Linksys router. I have port 7777 forwarded on both TCP and UDP, if that matters.

Big_Poppy
12-16-2007, 02:53 AM
We tried that last night to no avail. I notice that port 6500 is not open on my host server. Isn't that the advertise port? Where did it go? Only 13000 (Stat server) and 7777 (Game port) are open.

LordStrider
12-16-2007, 08:37 AM
Has anyone had any luck hosting matches on Linksys routers? I've tried just about everything I can think of, the only thing thats worked is enabling DMZ :/

WRT54GS
http://img137.imageshack.us/img137/5551/50573191lh0.th.png (http://img137.imageshack.us/my.php?image=50573191lh0.png)
http://img167.imageshack.us/img167/1658/16624396pk3.th.png (http://img167.imageshack.us/my.php?image=16624396pk3.png)
http://img167.imageshack.us/img167/6163/45533425gg0.th.png (http://img167.imageshack.us/my.php?image=45533425gg0.png)

These are basically the only options available to configure..

Mine is a 54G (not gs) and I only forward port 7777-7778, 27900,13000 and 6500. I don't use port triggering or DMZ.

Corey
12-16-2007, 09:39 AM
Mine is a 54G (not gs) and I only forward port 7777-7778, 27900,13000 and 6500. I don't use port triggering or DMZ.
I wonder why mine will not work then.
I opened up 13000 too, but it is not seen in the picture I posted earlier.
Mine are all set to UDP too, not TCP.

ghost_zero
12-16-2007, 11:07 AM
OK.
I figured out how to get around this problem on my system.
UT3 seems to use a or more "random" - at least the vary - ports (looked that up with TCPView) between 2500 and 3000 (maybe the range is a bit smaller or even a bit bigger - but from what I saw that's more or less what it should be.
I "just" needed to add that range (type UDP) to the port 7777 UDP to get this working.
However: UT3 needs to be STARTED with those ports already opened, otherwise you will get those message as long as you don't quit an restart UT3 (not even Logout and then Login again seemed to do the trick).

EDIT:
The range seem to go definitally higher than 3000 because I just had ports over 3200 used.
I wonder if those are just ports that are currently free by the OS or something like this. However, this is definitally a strange way to check if you use NAT or not, I mean using more or less random ports..?

Corey
12-16-2007, 11:14 AM
So you are saying we need to add 2500 to 3000 in our port forwarding setup area where the other ports are opened up?

ghost_zero
12-16-2007, 11:18 AM
Probably more. I just had one over 3000...

EDIT:
Here is a picture of TCPView:
http://img98.imageshack.us/img98/981/tcpviewku3.th.jpg (http://img98.imageshack.us/my.php?image=tcpviewku3.jpg)

I marked the intersting ports red.
I also tested if using the TCP ports below or the UDP ports above makes any differences in getting past the DMZ/Port-Forwarding message but it doesn't seem so.
Only those two ports seem to be interesting.
However they seem to be more or less random.

EDIT2:
You probably have to adjust that range after the fist UT3 start because everytime I startup UT3 (with closing it before) the used ports seem to get higher.
And after I restarted my PC those two ports were beetween 1000 and 1200, so....
My guess is that Epic let more or less the OS decide which port to use (probably the next free port or something like this). However this is kinda stupid for listening ports.
I wonder if they can be specified somehwere (seem only to be those two I marked in the screenshot).

Jesko
12-16-2007, 05:04 PM
here you can read something more of this random-port-phenomenon with linksys routers, but I don't understand it: :o
http://www.dd-wrt.com/phpBB2/viewtopic.php?p=132153#132153

ghost_zero
12-16-2007, 05:22 PM
Well... It seems more to be like the client is listening on a random port... After all: TCP-View reports this as ports the PC is waiting for AND NOT the router.
So this has not really something to do with the router itself.
Why it is working for some though is kinda strange for me though...
If you ask me this is just stupid. You can't do such things with random ports.
I hope they change this in v1.2 and hope that one will be out soon.
Especially since all other ports are mostly static (or at least can be configured)...

General.Jung
12-16-2007, 05:22 PM
Hello Forum,

I have also the problem with hosting a game, without DMZ, but I won´t use a DMZ. When any Developer needs my Router Model, please write a PM and I will give you some information about my network, but I won´t make it public here.

Syxx
12-16-2007, 05:53 PM
So if Im understanding this right, all this basically translates into UT3 wants to use a random port between 1000 and 4000, and since we have no way of knowing which it will choose we should just open them all....?

I really hope theres a patch coming to fix this mess.

BIGFOOT_PI
12-17-2007, 05:52 PM
I have the same problem. I have a Linksys WRT54G, Firmware Version : v4.20.7
This really sucks!
Only DMZ makes it work. Screw that!

MasterB
12-17-2007, 06:32 PM
I would like to know if ANYONE has been able to launch a LAN server without getting the DMZ error message when they have the patch installed? My guess is that it doesn't matter which router you have or which ports you are forwarding. You simply cannot launch a listen server with any of the patches installed.
Can anyone prove me wrong?

Dubious
12-17-2007, 08:22 PM
You simply cannot launch a listen server with any of the patches installed.
Can anyone prove me wrong?
I don't know how I can prove it to you, but I can start a listen server from in the game without apparent problem. I simply don't check the "Dedicated server" box and it starts without problem. Obviously this is with patched client v101 installation.

MasterB
12-18-2007, 06:07 PM
I don't know how I can prove it to you, but I can start a listen server from in the game without apparent problem. I simply don't check the "Dedicated server" box and it starts without problem. Obviously this is with patched client v101 installation.

You can setup a LAN server without the error message??

Dubious
12-18-2007, 06:15 PM
You can setup a LAN server without the error message??
Well ... yeah. I just did what I said that I did two posts above. Its just like I'm going to start a dedicated server except that I do NOT check the "dedicated server" box. The game starts with me in it, and its able to accept external players. Its a listen server.

Am I missing something?

MasterB
12-18-2007, 07:00 PM
Did you select LAN server and not Internet server?

agentq_71
12-18-2007, 07:01 PM
You can setup a LAN server without the error message??
A LAN server works even when you get the "Your network configuration is not compatible with hosting matches" error message. That message just refers to not being able to host a game on the internet.

MasterB
12-18-2007, 07:07 PM
A LAN server works even when you get the "Your network configuration is not compatible with hosting matches" error message. That message just refers to not being able to host a game on the internet.

I was aware of this, that's why I asked about the error message.
Is your LAN setting grayed out and unable to change to Internet server?

agentq_71
12-18-2007, 08:58 PM
I was aware of this, that's why I asked about the error message.
Is your LAN setting grayed out and unable to change to Internet server?

Yes. Even with the proper ports forwarded, I cannot host an internet server because my router does not have the option of specifying how to handle outgoing port assignments.

MasterB
12-19-2007, 07:17 AM
Yes. Even with the proper ports forwarded, I cannot host an internet server because my router does not have the option of specifying how to handle outgoing port assignments.

That's what I thought. Everyone seems to be able to launch the LAN server even if they get the error message but cannot switch to Internet Server. Port forwarding doesn't seem to work for anyone. DMZ works but leaves your computer open to attack.
I think we are stuck until a patch fixes this.
What's frustrating is that this was in all beta patches and not fixed. It seems so fundamental to me. FRUCTRATING!!!!

Takoma
12-19-2007, 09:48 AM
I don't think I've ever had this much trouble trying to play a game with my mate.

First of all, we tried Hamachi, 'cos that's just how we roll. (Hamachi is an app that creates a VPN, and allows most games to operate over it as if it was a LAN. We use it because we get lower pings, and can be assured of private games without having to wade through internet servers or remember passwords.) No joy there, simply couldn't reach each other.

Okay, playing over a third party app doesn't work, I can handle that. What I found ridiculous, and I hope to God there's a good reason, is that when trying to join his LAN game, the Game Mode dropbox was set to Deathmatch, and greyed out. Do you really mean to tell me I can only join Deathmatch games over LAN? You gotta be kidding me.

So, righteously rebuked, we each try setting up a passworded Internet server, while the other tries to join. Behold, the Port Forwarding/DMZ message!

Now, I run a Netcomm 1300+4, it was cheap, and it connects to yonder interweb. However, it only allows me to forward 20 ports, total, including inputting ranges. So naturally I'm choosy about which apps I reserve ports for, and which I simply choose not to use. I love UT3, so another unnamed app went, and in came UT3's settings.

I've read every post in this thread carefully, and I can't make sense of it. I know what a DMZ is, and you can bet your behind I'll not be resorting to that. After two hours and a headache, he's gone to bed, and I've come here to vent.

This simply will not do. I don't know enough to make sense of this thread, but I know enough to make me wonder how your average Joe is going to get on trying to play a private UT3 game with his mates. Not working over Hamachi is a nonissue, it wasn't designed to do that, so I can excuse that failure, even when most other games succeed. But to ask that your customers possess a Bachelor of Computer Science to play Duel with a mate is insane. If you're going to make a multiplayer-focused game, you better make sure people can host and join games, or you're going to run into trouble.

That there has been no response from Epic on this issue is galling to say the least. Hamachi aside, I have a real and frustrating problem with playing online, not to mention the illogical greyed-out Game Mode box.

This will not do at all.

headfog
12-19-2007, 09:58 AM
After forwarding the appropriate ports, the NAT ENDPOINT FILTERING change made in this post:
http://forums.epicgames.com/showpost.php?p=25163033&postcount=2

... is what resolved the issue for me. We just need to see what type of check it is trying to perform in order to see if you can host on the Internet. I noticed in the router log (informational setting) something is trying to communicate on port 3479. Port forwarding doesn't resolve this.

Takoma
12-19-2007, 10:08 AM
After forwarding the appropriate ports, the NAT ENDPOINT FILTERING change made in this post:
http://forums.epicgames.com/showpost.php?p=25163033&postcount=2

... is what resolved the issue for me. We just need to see what type of check it is trying to perform in order to see if you can host on the Internet. I noticed in the router log (informational setting) something is trying to communicate on port 3479. Port forwarding doesn't resolve this.

Good grief, now we're having to do a detailed network analysis to try and determine how to host a match?

I certainly hope this is a bug, one which is keeping Epic's staff too busy to respond. An official solution would be fantastic, but failing that a simple "We're aware that some of our customers are experiencing difficulties" would go a long way.

agentq_71
12-19-2007, 11:07 AM
Good grief, now we're having to do a detailed network analysis to try and determine how to host a match?

I certainly hope this is a bug, one which is keeping Epic's staff too busy to respond. An official solution would be fantastic, but failing that a simple "We're aware that some of our customers are experiencing difficulties" would go a long way.

From what I've read on the issue, I don't think it's a bug - I think it's just an extremely poor implementation choice. Any sane server implementation should only require port forwarding to function and not some obscure setting that routers may or may not have (my router does not have any such setting).

vläd
12-20-2007, 01:46 AM
Here's (http://mususumbra.blogspot.com/2007/12/hosting-ut3-games-truly-daft-solution.html) some more information on why some routers may be working and some do not with the 1.1 patch.

BIGFOOT_PI
12-20-2007, 11:46 PM
To EPIC: me and my brother don't play this game anymore. You got our money so I'm sure you don't care as you are too busy appeasing ps3 users, but this game is broke. If you aren't going to fix it any time soon at least SAY SOMETHING! DAMN!

PALADiN
12-21-2007, 06:54 PM
Add me to the list of people who can't host games on the Internet.

My modem (which also acts as a router) is a Siemens SpeedStream 4200 (firmware A8P). It has no setting for DMZ as far as i can tell, nor any "NAT endpoiint filtering" option. Tried forwardng ports mentioned on the forums with no success.

I also run ZoneAlarm Pro and I've set the Internet access and server permissions for ut3.exe to "allow". No effect.

Kindar
12-22-2007, 12:09 AM
Add me too, I just want to host a campain... and I could pre-1.1, but now it gives me that message.

i'm running vista, with a linksys (DD-WRT v23 firmware) and a Sympatico Speedstream 6200 router/modem (acts as my modem) the speedstream is set to DMZ to the Linksys Router, and i'v tried DMZ'ing my computer from the linksys but it had no effect. There is no option to change that filtering option. Right now I simply can not host a game online... at all.

noise
12-22-2007, 11:23 AM
After trawling the internet I found a solution for me to host a non-dedicated game.

If, like me, you can't get rid of the annoying message there is a work around.

Set port forwarding on your router. don't know the exact ones needed but trawling through various posts i have forwarded these:
6500 UDP
7777-7778 UDP
13000 UDP
7787-7788 UDP
42292 UDP/TCP
27900 TCP
28902 TCP.

Download STUN from here (http://sourceforge.net/project/showfiles.php?group_id=47735)(stun-win32 client and server) set the server to run in a command prompt using server -h 192.168.1.2 -a 127.0.0.1 -v (192.168.1.2 needs to be your internal ip address and -v is just for verbose).

Check that the server is working by running client localhost. That should say Open.

Edit My Documents\My Games\Unreal Tournament 3\UTGame\Config\UTEngine.ini and search for stunserver.org and change that to your ip address (192.168.1.2).

et voila! can host a non-dedicated game and that silly message it gone. it's a crappy workaround and means you have to run a cmd prompt but it works till it's fixed.

I have now setup a batch file to run the STUN server before UT3 starts. I copied the UT3 shortcut and the stun server exe to the UT3 directory, then changed the UT3 shortcut in the start menu and desktop to run ut3.bat which i've put in the ut3 folder.
ut3.bat contains:
"C:\Games\Unreal Tournament 3\Binaries\Unreal tournament 3.lnk"
"C:\Games\Unreal Tournament 3\Binaries\stun-server-0-96.exe" -h 192.168.1.2 -a 127.0.0.1 -v


I found the STUN workaround solution here (http://mususumbra.blogspot.com/2007/12/hosting-ut3-games-truly-daft-solution.html)

Corey
12-22-2007, 11:31 AM
Gosh that is a lotta stuff to do, I am unwilling to do that.
It is cool you got it going though.

I just do not like to install apps to do something the game should already be doing since every other game I own lets me host a listen server.

This bug better be fixed in the next patch.

noise
12-22-2007, 02:26 PM
i like fiddling so didn't bother me :)
would be nice if they fixed it though.

iycgtptyarvg
12-22-2007, 10:25 PM
I can confirm this works! I use:
Stun_server.exe -h 192.168.1.10 -a 127.0.0.1 -v

@NOISE
Thanks man, you're a life saver!!!

@Epic
Please fix this in the 2nd patch before everyone abandons UT3 on-line!!!

Kindar
12-22-2007, 11:04 PM
I like fiddling as well, and I had to mess with the batch a little, but thats because I'm using vista, and it seems to treat things a little differently, if I have like yours:

"C:\Games\Unreal Tournament 3\Binaries\Unreal tournament 3.lnk"
"C:\Games\Unreal Tournament 3\Binaries\stun-server-0-96.exe" -h 192.168.1.2 -a 127.0.0.1 -v

it runs one, then waits till it ends, then runs the other... so I did

@echo off
cd /d "D:\Program Files (x86)\Unreal Tournament 3\Binaries\"
rem stun server
Start stun-server-0-96.exe -h 192.168.1.116 -a 127.0.0.1 -v
rem Unreal Tournament 3
start UT3.exe
exit

little batch code... lol I'm learning things as I go here! and I changed the ini setting, and voila it works again, not to much fiddling just a little text file, changing an ini setting, and downloading a file... shouldn't NEED to do it, but if it works, i'm keeping it for now.

also I only have these ports forwarded

6500 UDP
7777-7778 UDP
13000 UDP

add the STUN link from the above post to complete my post HERE (http://sourceforge.net/project/showfiles.php?group_id=47735)

Seven_Force
12-23-2007, 01:11 AM
Add me to the list as well guys. I'm using a Dlink router and could host fine before the official patch. After applying the patch, I can no longer host in UT3, but every other game on my comp and every other internet function in UT works fine.

These bugs are truly crippling the game and killing the community. I have some good news though: I PM'ed Flak (admin here) and he replied right away and said he's forwarding the issue to War Tourist. Apparently, War Tourist is on vacation until the 27th so all we can do is keep the issue out in the open.

Keep bumping this thread and pray this issue gets fixed in the next patch. Obviously the patch broke something if we could all host fine before.

iycgtptyarvg
12-23-2007, 08:29 AM
1.
I'm using a LinkSys WRT54GL router with Tomato firmware.

2.
I only have the following ports open:
UDP 6500, 7777, 13000
-> Is there any use in adding port 7778?

3.
My script is a batch file which I created a shotcut to (placed on the desktop):

Start Stun-server-0-96 -h 192.168.1.10 -a 127.0.0.1 -v
Start UT3

mcm311
12-23-2007, 01:44 PM
For anyone running DD-WRT firmware on their Linksys router.

This procedure worked for me:

"After consulting the www.linksysinfo.org forums I have been provided with an answer.

To forward a WAN IP Address (192.245.12.228) to a LAN IP address (192.168.0.5) requires amendments of both the FORWARD chain and the PREROUTING chain as follows:

iptables -I FORWARD -p all -s 192.245.12.228 -d 192.168.0.5 -j ACCEPT
iptables -t nat -I PREROUTING -p all -s 192.245.12.228 -j DNAT --to 192.168.0.5

If these commands are entered (each on a separate line) into the Administration\Commands window of the web interface and then 'Save Firewall'is clicked the commands are remembered after a router reboot.

If you duplicate the commands with the WAN IP address of 192.245.12.248 then you should be able to host UT3 games providing you also forward the usual port 7777 to your hosting PC, and you also have installed the 1.1 Beta Patch. "

So for my router, I added the following lines to the administration\console and saved to startup: (my IP is 192.168.1.25)

iptables -I FORWARD -p all -s 192.245.12.248 -d 192.168.1.25 -j ACCEPT
iptables -t nat -I PREROUTING -p all -s 192.245.12.248 -j DNAT --to 192.168.1.25
iptables -I FORWARD -p all -s 192.245.12.228 -d 192.168.1.25 -j ACCEPT
iptables -t nat -I PREROUTING -p all -s 192.245.12.228 -j DNAT --to 192.168.1.25

BIGFOOT_PI
12-23-2007, 01:54 PM
I wont pretend to understand everything you wrote there, but you are forwarding ALL ports? which is essentially DMZ?

noise
12-23-2007, 04:24 PM
there are many posts saying that the port after the one your using needs to be open too, not sure if that's true on UT3 or not, but certainly was in 2003/4.

Methodman
12-23-2007, 04:38 PM
Hmmm I haven't had much luck yet, but I'll try! Hopefully I can get it to work.

noise
12-23-2007, 04:47 PM
if you need any help just ask :)

Big_Poppy
12-24-2007, 09:43 AM
So, I've done everything, ran a stun server, moved my server to the DMZ and allowed any-any-any, no software firewall, dedicated server, still doesn't advertise and not sure it can be reached outside of my local network.

EPIC, please let us know you are addressing this, 12 of us both this game and incurred the additional cost of hardware to meet it. I would like to know that something is being done to address this.

BIGFOOT_PI
12-24-2007, 12:17 PM
the stun server thing actually worked! finally my brother could join my listen server!
ps- at first I thought it didnt work, but I found my router changed my IP (damn DHCP)
so I just went into my linksys and changed the UT ports to the correct computer IP and restarted the batch file- voila! He joined! and I splattered him to hell!
pps- this is SO REDICULOUS having to download and install and hack with 3rd parts executables to do online play- FFS EPIC- DAMN!

vinnycthatwhoibe
01-05-2008, 07:45 PM
http://www.lanpartyguide.com/images/ut3error1.jpg

Ok well it seems the only way to really get this to work for everyone is the stun server fix. If you happen to have a D-Link DGL-4300, the UDP End Point Filtering setting does work (its on page 1), but I know not everyone has this router.

I have created a visual guide that can help you do the stunserver fix.
http://www.lanpartyguide.com/ut3.html

Oh look, I can un-check LAN now!

http://www.lanpartyguide.com/images/ut3nolan.jpg

ANick
01-05-2008, 09:55 PM
Why dont you just add a kicker to the end of your desktop shortcut UT3.exe target?

Open the desktop shortcut to properties and add to the target line -multihome=yourIPaddress.

Example:

Target: "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" -multihome=66.88.22.240

That should bypass the error popup window. Make sure you got a <space> after UT3.exe" then add -multihome=xx.xx.xx.xxx ;)