PDA

View Full Version : highly annoyed...



darkviper039
11-21-2007, 03:05 AM
Bought the game today, I am overall impressed with it BUT...one thing that is starting to tick me off, EVERY LAST TIME i load the game it asks for my CD-KEY again....HOW DO I STOP IT FROM DOING THIS :mad:

darkviper039
11-21-2007, 03:07 AM
lol, mine doesnt, make sure your pc's date is set correctly.

yea it is set correctly

this is ungodly annoying

Hickeroar
11-21-2007, 03:19 AM
Check your my documents/my games folder.

Is there an Unreal Tournament 3 folder in there? If not, that's your issue. Someone here may be able to help you get that put in there properly. My installer created it for me.

darkviper039
11-21-2007, 03:22 AM
Check your my documents/my games folder.

Is there an Unreal Tournament 3 folder in there? If not, that's your issue. Someone here may be able to help you get that put in there properly. My installer created it for me.

you know...thats probably the problem due to the fact i had my "my documents" folder targeted to a 2nd hard drive...i bet reinstalling the game fixes the problem or is there another way to just create the necessary folder?

Hickeroar
11-21-2007, 03:40 AM
Just create a directory structure like C:\Documents and Settings\[your account name]\My Games

Then try starting the game again. If that doesnt work, try a reinstall. My UT3 settings folder was created upon installation.

Green_Day_584
11-21-2007, 03:51 AM
if not, maybe you could try adding it directly into the right line in the .ini. that has worked for a few of my games, although iv never had to try it in UT...

darkviper039
11-21-2007, 04:08 AM
thanks for the suggestions guys

my fix was:

unmapping my "my documents" folder back to default instead of F:/ drive

reinstalling the game

no longer asks for cd-key upon reloading of the game

:D:D:D:D:D

darkviper is happy once again lol

see you guys in game :cool:

Entil'Zha
11-21-2007, 04:46 AM
So in other words, if ppl don't have MyDocuments at its default location, they're screwed. Bug imo.

Taleweaver
11-21-2007, 05:10 AM
Damn...I too have my documents on another drive. I'll probably run into that problem as well in a couple of days. :\

Never had any problems with the .ini & co settings in F:\mydocs\My games\... in the demo, though. Did you have any problems then, darkviper?

Daimao
11-21-2007, 07:00 AM
i hope that this will be fixed in the first patch, I too have "My Documents" on another partition and I refuse to change it just so I could play one video game :mad:

Loeder
11-21-2007, 07:02 AM
So in other words, if ppl don't have MyDocuments at its default location, they're screwed. Bug imo.

No, I have mine on a different drive and with the demo it installs perfectly.

Madmanxan
11-21-2007, 07:24 AM
jeez this would be annoying...glad u got it fixed man, hope i dont get this problem :(

Hypotenuse
11-21-2007, 08:04 AM
thanks for the suggestions guys

my fix was:

unmapping my "my documents" folder back to default instead of F:/ drive

reinstalling the game

no longer asks for cd-key upon reloading of the game

:D:D:D:D:D

darkviper is happy once again lol

see you guys in game :cool:


So in other words, if ppl don't have MyDocuments at its default location, they're screwed. Bug imo.

I have my MyDocuments in some arbitrary directory on a different drive and it worked for me in the demo (of course i had to manually install the demo because the installer had some bugs). This fix may have worked but there will be a proper work around. It's not alright in the least to ask people to change their directory structure just for your 7/10 game.

m3b
11-21-2007, 08:07 AM
right click on all the inis and make sure its not set to read only

warwhore
11-21-2007, 08:16 AM
I cant stand games that go outside of the install directory to store profiles and savegames and configs and such. I believe that even the demos are now stored in the My Documents folder, which is lame. This kinda thing isn't good for people who have their C: drive set up for strickly their OS, with just a 5 to 10 gig partition llike me :(

nfleming
11-21-2007, 11:08 AM
Yep, most of us separate the OS from the games. This is, apparently, a MS Games logo requirement or some such crap. Just one more thing to annoy the hell out of us.

WarTourist
11-21-2007, 11:16 AM
Hi guys. We're looking at this here, but you might try adding -nohomedir to the UT3 shortcut ("D:\games\unreal tournament 3\Binaries\UT3.exe" -nohomedir).

This will force all created files to be created local to where you installed the game rather than the \my documents folder.

clark kent
11-21-2007, 12:21 PM
OK this is screwed up hard! Come on EPIC, I mean really! They have screwed the pooch BIG TIME with this silly issue!

I cannot get the game to keep any settings at all no matter where I install it! CD Key, binds, characters, nada! This is the biggest screw up I have ever seen in 9 years of playing UT. If I cannot get this running a.s.a.p. then I WANT MY MONEY BACK RIGHT NOW!

As far as I am concerned UT2k4 was the best EPIC has done to date. GEAR's is just ok for me and I hate console games and this game suxors right now for me and I am warning my entire clan NOT to buy the game. Mark Rein you screwed up hard!!!

Can someone e-mail me and tell me how to fix this $60 POS game I just bought????? PLEASE!!!!!!!!!!!

emc_clark@yahoo.com

clark kent
11-21-2007, 12:32 PM
-nohomedir ? That's a joke, it won't let me add that to my short cut and the directory/drive/folder I install into should be irrelevent! I am really pissed right now because I got better things to do then fix your bugs right out of the gate. I waited 8 months for this? Someone should be fired for this one. Looks like EPIC is a Console Game company now and has lost their touch for PC gaming. Consoles are easier environments so havew fun EPIC...

I want my money back!!! Here is where I installed it, it's where the game wanted to install it. "C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe"

Daimao
11-21-2007, 12:35 PM
I cant stand games that go outside of the install directory to store profiles and savegames and configs and such. I believe that even the demos are now stored in the My Documents folder, which is lame. This kinda thing isn't good for people who have their C: drive set up for strickly their OS, with just a 5 to 10 gig partition llike me :(

That's called multi-user support. I know it can be annoying at first, but that's only because Windows users aren't used to it.
This way you can share your computer with someone else and everyone will have separate, personal .ini files.


Hi guys. We're looking at this here, but you might try adding -nohomedir to the UT3 shortcut ("D:\games\unreal tournament 3\Binaries\UT3.exe" -nohomedir).

This will force all created files to be created local to where you installed the game rather than the \my documents folder.

Thanks, it's always good to see replies from Epic employees :)

clark kent
11-21-2007, 01:25 PM
Adding "-nohomedir" to the VERY end of my desktop icon seems to have fixed my CD-Key and Settings not being saved issue. So here is what I did:

"C:\Program Files\Unreal Tournament 3\Binaries\UT3.exe" -nohomedir

This worked for me so far! What a mess this is! I have spent four hours on this nonsense, good going EPIC but thanks for the fix... So far anyway...

HudsonC_TAW
11-21-2007, 02:18 PM
Done with Epic

clark kent
11-21-2007, 07:13 PM
OK it's still not saving all of my settings but the CD Key issue is fixed. IMO they did a hose job with the Demo and it's showing up here. I had the same issues with the Demo so I waited and they didn't fix any of those issues.

How do I get it to keep all of my settings?

ProfessorDazzle
11-21-2007, 08:56 PM
thanks for the suggestions guys

my fix was:

unmapping my "my documents" folder back to default instead of F:/ drive

reinstalling the game

no longer asks for cd-key upon reloading of the game

:D:D:D:D:D

darkviper is happy once again lol

see you guys in game :cool:

I think I actually did see you, haha.

beckizzle
11-21-2007, 09:31 PM
http://forums.epicgames.com/showthread.php?t=585923

http://forums.epicgames.com/showthread.php?t=585657

Look there.

robbiekhan
11-23-2007, 05:35 PM
I'm just about to test the -nohomedir switch now as I had the same issue, I managed to get the VIDEO settings to stick by creating the game folders ( M:\My Games\Unreal Tournament 3\UTGame\Config ) as I too have My Docs mapped to a 2nd HDD in Vista and now the game saves Video settings perfectly BUT keybinds and mouse settings do not stay nor do character settings as I have to setup my character every time I choose to play online.

I had to create the same folder structure for GEARS OF WAR as well so this is defo a Unreal Engine 3 powered game issue as I have COD4 and Crysis which had no issues like this at all.

robbiekhan
11-23-2007, 05:47 PM
Holy ****

-nohomedir fixed ALL the issues I had with the game not saving settings :D

CONFIRMED ISSUE FIXED!

Gibbon
11-24-2007, 06:56 AM
I cannot add -nohomedir to the shortcut in vista, just tells me the target is then incorrect??

Gibbon

robbiekhan
11-24-2007, 11:47 AM
I cannot add -nohomedir to the shortcut in vista, just tells me the target is then incorrect??

Gibbon

You need to put it after the " not before, like this:

http://robbiekhan.co.uk/root/temp/ut3cust.png

stephen_wq
11-26-2007, 05:23 PM
Hi guys. We're looking at this here, but you might try adding -nohomedir to the UT3 shortcut ("D:\games\unreal tournament 3\Binaries\UT3.exe" -nohomedir).

This will force all created files to be created local to where you installed the game rather than the \my documents folder.

Is this -nohomedir just a debugging thing, or will this allow me to completely remove the my documents part and just use the game folder like UT04 and UT99?

robbiekhan
11-26-2007, 05:37 PM
Is this -nohomedir just a debugging thing, or will this allow me to completely remove the my documents part and just use the game folder like UT04 and UT99?

You can completely remove the UT3 from My Documents.

magicgoof
01-26-2008, 10:53 PM
Hi guys. We're looking at this here, but you might try adding -nohomedir to the UT3 shortcut ("D:\games\unreal tournament 3\Binaries\UT3.exe" -nohomedir).

This will force all created files to be created local to where you installed the game rather than the \my documents folder.

That fix worked for me! Prefectly! I even managed to make it work with Steam (just added that little -nohomedir thing to that shortcut)! I'm a very happy man.

Screw
02-16-2008, 11:12 PM
You can completely remove the UT3 from My Documents.

so now that I have added -nohomedir to my ut3 shortcut, where does my user data now get saved to ?

IceFrogg
02-17-2008, 02:33 AM
So in other words, if ppl don't have MyDocuments at its default location, they're screwed. Bug imo.

Ok.. Yeah i run UT3 from the c / drive and its fine. fact : UR MEANT TO RUN GAMES OFF THE HDD's not from MY Documents.

Screw
02-20-2008, 11:34 PM
Ok.. Yeah i run UT3 from the c / drive and its fine. fact : UR MEANT TO RUN GAMES OFF THE HDD's not from MY Documents.

The game is ran off our C: directory, however, if you have your My Documents directory on another hard drive, that is where we run into problems. I guess the game itself fails to see the My Documents because it is no longer stored on the C: drive.

I'm assuming with the -nohomedir fix, the user data then begins to store in its original place of installation and not My Documents like everyone else. My question is, where exactly does this data get stored now ? Specifically.

Screw
02-23-2008, 10:51 AM
Bump...I hope someone can help me.