PDA

View Full Version : UT3 supports X-Fi technology?



RaptorZX3
11-17-2007, 01:49 AM
i wonder if Unreal Tournament 3 support the Creative X-Fi technology found on the XtremeMusic and XtremeGamer sound cards series

Mortis
03-21-2008, 02:25 PM
I have a Fatal1ty X-FI SC... and I can't get game to run. <shrug>
================================================== ====
Specs:
[CPU]: AMD Phenom 9600 Agena 2.3GHz Socket AM2+ 95W Quad-Core Black Edition
[CPU-Cooler] : ZEROtherm BTF90
[GPU] : ASUS EN8800GTX/HTDP/768M GeForce 8800GTX 768MB
[MoBo]: ASUS M3A32-MVP Deluxe/WiFi AM2+/AM2 AMD 790FX ATX AMD Motherboard
[Mem] : CORSAIR XMS2 4096MB PC6400 DDR2 800MHz Memory (4 x 1024MB)
[PSU] : Antec TruePower Quattro TPQ-1000 ATX12V / EPS12V 1000W Power Supply
[HDD] : WD Raptor X WD1500AHFD 150GB 10,000 RPM SATA-150
[OS] : Microsoft Windows Vista 32-Bit Ultimate for System Builders
[Case]: Antec Nine Hundred Black Steel ATX Mid Tower
[SC] : Creative Sound Blaster X-Fi XtremeGamer Fatal1ty Pro

Masklin
03-22-2008, 06:38 AM
I have X-Fi and I'm running OpenAL without problems.

WolfSeven
03-22-2008, 09:51 AM
I got an X-Fi XtremeGamer Fatal1ty Pro
and my ut3 crashes randomly during gameplay when OpenAL is enabled

Metal_Militia
03-22-2008, 10:11 AM
I have an XtremeGamer, and the game runs fine with OpenAL. . . I wonder if the Fatal1ty series is incompatible with UT3.

D-Hunter
03-22-2008, 12:23 PM
I get crashes, and I don't have a sound card. It crashes even with the 'nosound' switch.

Harmatia
03-22-2008, 12:44 PM
Any of the big, useless, unecessarily expensive cards get crashes.

Works heavenly with my xtremegamer.

It doesn't really have any kind of audio settings. I tweaked the maxchannels to 128, though. Sounds nicer =)

EZappa
03-22-2008, 04:32 PM
We already discussed this many times....there is a problem with the X-Ram...the "normal" xtremegamer and the Xtreme Music don't have X-Ram so they don't have any problem...

boo_radley
03-23-2008, 01:12 AM
I have the random crashes with the regular x-fi extreme music with the UT3 has encountered a problem and needs to close message,open al or not.
asus m2n-sli deluxe
amd 3.0 ghz X2
2gb corsair 800 mhz
creative extrememusic
2-320 gb seagates in raid 0
egva 8800gtx
This occurs at startup at times or 5-20 minutes into the game. No other game problems with over 20 installed.

Metal_Militia
03-23-2008, 06:27 AM
Are you sure it's the SC, boo radley?

IceFrogg
03-23-2008, 06:34 AM
i think they do, as far as i can tell UT3 is sponsored by x-fi.

"Sounds best on X-FI"

WolfSeven
03-23-2008, 10:04 AM
@boo_radley:
If your ut3 crashes with openAL disabled, the sound card isn't your problem

haslo
03-23-2008, 10:51 AM
My X-Fi (with XRAM, the fatal1ty one) works perfectly with UT3, and makes it sound a huge lot nicer than the onboard soundcard did - so much that I finally switched off music, because the audio clues work heavenly and it's in fact almost an unfair advantage to hear people that good before you see them.

Vista however has problems with X-Fi, and UT3 and Vista and X-Fi consequently have, too. Switch to XP and you'll be fine :)