PDA

View Full Version : Tips for Improved Video Performance



legacy-Echofission.com
03-18-2004, 11:14 AM
Hey folks,

I just thought I would put in this forum some tips that have worked for me in order to make the game smoother. My systen is a P4, 2 GhZ, 512MB RAM, and a Geforce FX5900.

First, make sure (obvious) you have the latest Nvidia (or other graphics) drivers. They just put the new ones up on 3/15

Second, make sure your audio drivers are up to date too. An old audio driver can actually hang your system as well.

Third, defrag your hard disk after the install. Many have reported a significant improvement in game play after they do this.

I won't go into how you can change your video settings, b/c that is pretty obvious that can enhance smoothness by lowering detail levels, and by most counts, these issues happen regardless of what detail settings you have.

Open your x:\UT2004\system\UT2004.ini file and do these edits

In every instance there is a x/y screen coordinate (screen resolution) set your screen resolution. Example:

MenuViewportX=1280
MenuViewportY=1024
WindowedViewportX=1280
WindowedViewportY=1024
FullscreenViewportX=1280
FullscreenViewportY=1024

etc...

In every instance you see "vsync," set it to yes.

UseVSync=True

In every instance you see anisotropic filtering, set that to "0."

LevelOfAnisotropy=0

Also, for Nvidia users, turn this off on your card in your settings (should be located in system tray).

Set your minimum desired frame rate to 50 (again, every place you see it)

MinDesiredFrameRate=50.000000

Set your desired frame rate to whatever your monitor is at (my flatscreen is 72)

DesiredRefreshRate=72

Set these to true everywhere you see them...

UseTrilinear=True
UseTripleBuffering=True

Also, in the settings, disable the "preload skins" option.

One more (added 3/19/04)

For Nvidia users, turn Anisotropic OFF in the performance preferences, and set Anti Aliasing to "Application Controlled." This is another biggie that will take that "feels like I am drunk" vibe off the motion, and make your movements much crisper. You will barely notice the difference in the details, but will notice a huge difference in performance.

I performed the above and it worked for me...it may not work for you, so save the UT2004.ini to UT2004_OLD.ini so you can go back if needed.

legacy-ButterB
03-18-2004, 11:50 AM
overall good tips...Ive done that on mine as well. But the anisotropy and triple buffering I didnt do. Ill check those when I get home. The key ones I think are min desired FPS, but I think that has been removed in the D3D settings. :weird: Thought they were there before, but I didn't see them now. But your desired refresh should definately be what your monitor is. That will make it seem smoother.

legacy-Echofission.com
03-18-2004, 12:22 PM
Yeah, with the "default" detail settings, things are pretty smooth now.

legacy-J_Flash
03-18-2004, 04:43 PM
How does the minimum desired framerate work? What does it affect and cause?

legacy-Johnny Wadd
03-18-2004, 05:35 PM
Thanks Echo you da man :up: :up: :up:
Running my p4 1.6 this morning I was clocking in a 35-40 fps for assault and ONS :eek:
I used your framerate, reset my refreshrate, vsynch, etc. and now I'm looking at an fps 45-60, which is what I had roughly for the demo.
Thx dude, I owe you one :up:

Only thing that caused me some trouble was deselecting auto internet speed adjustment. It caused me to have longer loading times on the splash screen.

legacy-Ganj
03-19-2004, 01:31 AM
Thanks for the tips, the one about the anisotropic setting helped me alot. Good stuff for Nvidia and ATI users alike.

I get the same results with that dynamic netspeed setting, where turning it off results in longer load time for the initial splash screen right after clicking the icon to play.

Thanks again.

----------------------------------------------------
Pentium 4 CPU 3.01GHz Hyperthreading Enabled
Abit VI7 - VIA PT800/VT8237
512MB DDR400/PC3200 Crucial RAM @ 2.5-3-3-7
120GB Western Digital SATA HDD
40GB Western Digital IDE HDD
Hercules 3D Prophet 9800 Pro 128DDR (4.3 Catalysts)
Coolermaster Aero 4 CPU fan @ 2800rpm
Aspire X-Dreamer II Case
Enlight 360W PSU
Viewsonic G90fb 19" CRT
Klipsch Promedia GMX A-2.1 Speakers
Logitech MX Duo Wireless Mouse/Keyboard
Avg CPU temp range - 70F/21C idle - 100F/38C peak
Windows XP Pro-(tweaked to use less ram)
----------------------------------------------------

legacy-Sirelothar
03-19-2004, 03:20 AM
Awesome tips man, helped me get rid of some mysterious slowdowns I was having, sorry for bumping, but it's worthy :p

legacy-DARK GENiX
03-19-2004, 06:56 AM
i have to try this as soon as possible...but i'm not having much trouble as of now. the game is running pretty good, but i need to test it more i only played a few maps before going to sleep. good job man.

legacy-|XyPe|
03-19-2004, 09:52 AM
Great tips!

How ever do you come with those things?

I never understand s*h*i*t from those ini files...

Before my game was crummy as hell... and now... plays as smooth as I wanted... Thanks mate! Hope to frag you some online sometime...

GreetZ, XyPe

legacy-Jognt
03-19-2004, 10:29 AM
by enablind TriLinear filtering and upping the basic resolution, dont you make the game run worse?

Id say the only thing making it run better is the mindesiredframerate option, which lowers settings like world detail etc to hang around the desired framerate...

Id like to know if all these people would have a good game without the mindesiredframerate option.

legacy-Echofission.com
03-19-2004, 12:25 PM
Originally posted by |XyPe|
Great tips!

How ever do you come with those things?

I never understand s*h*i*t from those ini files...

Before my game was crummy as hell... and now... plays as smooth as I wanted... Thanks mate! Hope to frag you some online sometime...

GreetZ, XyPe

Thanks!

Another one I forgot to mention is for Nvidia users, turn Anisotropic OFF in the performance preferences, and set anti aliasing to "Application Controlled." This is another biggie that will take that "feels like I am drunk" vibe off the motion, and make your movements much crisper.

legacy-Echofission.com
03-19-2004, 12:29 PM
Originally posted by Jognt
by enablind TriLinear filtering and upping the basic resolution, dont you make the game run worse?

Id say the only thing making it run better is the mindesiredframerate option, which lowers settings like world detail etc to hang around the desired framerate...

Id like to know if all these people would have a good game without the mindesiredframerate option.

You don't have to up the resolution, those are just the ones I am using. I actually found though that with a lower res, you notice the slower framerate more. If you disable trilinear in your graphics options, I think that will make the game run even smoother, but I reached a point where it was working fine for me, so I didn't kill that option.

I don't fault Epic for not having the game run smoothly on every platform, but it would have been nice if they included vsync (and other standard video options) in the settings interface...I remember that the demo had at least vsync options as a choice.

legacy-Echofission.com
03-19-2004, 01:39 PM
bump

legacy-J_Flash
03-19-2004, 05:32 PM
OMFG! This was working perfectly and then suddenly it just STOPS working! I only changed the minimum desired framerates at first, and that worked like a dream. Now, it has no effect; works just the same crappy way. Please, is there any way to reset my .INI, fix it, or make the minimum fps work again? It was working SOOOOOO well, I'm so upset!

Also, is there anything like this in other games?

legacy-J_Flash
03-19-2004, 08:38 PM
bump

legacy-3n!gmatix
03-19-2004, 10:21 PM
Hi ! I tried what you said ! Everything ! and didnt noticed any changes =(
then I came back with my old UT2004.ini file .. and tried to change minfpsdesireded to 50 ...
and woot ! the game seems to get better FPS ! I also put anti??? to off and the other one to ???? (lol I dont remember the option)
anyway .. ! Thanks

EDIT: I tried it again and ... BAD BAD BAD .. i wonder why but bad things were happening ! my fps was stuck at 30 .. capping there ..

legacy-Echofission.com
03-20-2004, 12:20 AM
Originally posted by J_Flash
OMFG! This was working perfectly and then suddenly it just STOPS working! I only changed the minimum desired framerates at first, and that worked like a dream. Now, it has no effect; works just the same crappy way. Please, is there any way to reset my .INI, fix it, or make the minimum fps work again? It was working SOOOOOO well, I'm so upset!

Also, is there anything like this in other games?

Just put back what was there before. Also, make sure you change ALL instances of these things. There are (I think) for example, three instances of anistotropic=1, as well as the other parameters.

I know you didn't follow ALL the insctructions I listed as I said that you should rename the original UT2004.ini to UT2004_OLD.ini so you can revert back if needed ;)

legacy-digital orgasm
03-20-2004, 06:46 AM
These tips helped improve my performance also.

legacy-uglyduck_uk
03-20-2004, 06:50 AM
Just a comment.

If you have a top end Card then you will find that it actually runs better at higher resolutions.

legacy-goKi
03-20-2004, 08:32 AM
I tried this, and it worked extremely well. totally cleared up my lagging when i spawn for the first time. Thanks!

legacy-J_Flash
03-20-2004, 08:39 AM
How top is top end? Like... 9600 pro overclocked? lol, i have high hopes :D

legacy-Echofission.com
03-20-2004, 08:42 AM
My Geforce FX5900 works better at high res too.

legacy-uglyduck_uk
03-20-2004, 08:47 AM
Originally posted by Echofission.com
My Geforce FX5900 works better at high res too.

Of course it will - it was intended to :) It will actually struggle at 800x600 and below.

legacy-J_Flash
03-20-2004, 08:57 AM
Do you run your card with any AA or AF? What res and levels? Detail levels? Is my milk still good?

legacy-Echofission.com
03-20-2004, 09:36 AM
Originally posted by J_Flash
Do you run your card with any AA or AF? What res and levels? Detail levels? Is my milk still good?

Read the tips again. No AA, and AL set to application controlled.

legacy-willy27
03-20-2004, 11:25 PM
Also Try out the Omega ATI Radeon Driver from http://www.omegacorner.com/ Those drivers are designed for Gaming, I've tested on my AMD Anthlon 64 fx-51 1gb ddr ram ATI Radeon 9600 Pro and I've been getting max fps with max settings. Hope this helps. :)

legacy-[SC]Turbage`L|S
03-20-2004, 11:33 PM
LOL.

How much did that box cost you?

*is in envy*

legacy-Triad X
03-21-2004, 01:30 AM
:bulb:

legacy-marl0n
03-21-2004, 04:29 AM
wee for the help :D

legacy-Sirelothar
03-21-2004, 07:38 AM
Forgot to mention, also these are some ini settings I use, I personally choose to play this game in 16bit color mode instead of 32bit, I guess im a performance huffy.. But anyways, if you choose to use 16bit and see if you get a performance increase, set the ingame bit setting to 16 then goto your UT2004.ini in your system folder and change all instances of

Use16bit
Use16bitTextures

To true *theres 3 instances of these 2 lines of text in the ini* and see if you gain any FPS this way, please post and respond if this eigther helped or decreased your performance. Thanks

legacy-MasterBlaster73
03-21-2004, 08:33 AM
This is a great program that was just released for UT2004 that makes these setting agjustments much easier.
I just installed it and it worked great.

UT2004 ini Editor
http://www.soulix.com/fila/UT2004_ini_Editor.zip
;) ;) ;)

legacy-jwilliams
03-21-2004, 10:07 AM
There is also a default.ini file with many of the same settings. Someone here spoke of the frame rate helping for a little while then reverting back. Maybe if they change the frame rate here too, this would help? I have had 'ok' performance but I just applied the settings in this post and in the default.ini file and will try playing now (here is hoping I did not screw everything up!)


Originally posted by Echofission.com
Hey folks,

I just thought I would put in this forum some tips that have worked for me in order to make the game smoother. My systen is a P4, 2 GhZ, 512MB RAM, and a Geforce FX5900.

First, make sure (obvious) you have the latest Nvidia (or other graphics) drivers. They just put the new ones up on 3/15

Second, make sure your audio drivers are up to date too. An old audio driver can actually hang your system as well.

Third, defrag your hard disk after the install. Many have reported a significant improvement in game play after they do this.

I won't go into how you can change your video settings, b/c that is pretty obvious that can enhance smoothness by lowering detail levels, and by most counts, these issues happen regardless of what detail settings you have.

Open your x:\UT2004\system\UT2004.ini file and do these edits

In every instance there is a x/y screen coordinate (screen resolution) set your screen resolution. Example:

MenuViewportX=1280
MenuViewportY=1024
WindowedViewportX=1280
WindowedViewportY=1024
FullscreenViewportX=1280
FullscreenViewportY=1024

etc...

In every instance you see "vsync," set it to yes.

UseVSync=True

In every instance you see anisotropic filtering, set that to "0."

LevelOfAnisotropy=0

Also, for Nvidia users, turn this off on your card in your settings (should be located in system tray).

Set your minimum desired frame rate to 50 (again, every place you see it)

MinDesiredFrameRate=50.000000

Set your desired frame rate to whatever your monitor is at (my flatscreen is 72)

DesiredRefreshRate=72

Set these to true everywhere you see them...

UseTrilinear=True
UseTripleBuffering=True

Also, in the settings, disable the "preload skins" option.

One more (added 3/19/04)

For Nvidia users, turn Anisotropic OFF in the performance preferences, and set Anti Aliasing to "Application Controlled." This is another biggie that will take that "feels like I am drunk" vibe off the motion, and make your movements much crisper. You will barely notice the difference in the details, but will notice a huge difference in performance.

I performed the above and it worked for me...it may not work for you, so save the UT2004.ini to UT2004_OLD.ini so you can go back if needed.

legacy-stencilboy0987
03-21-2004, 08:14 PM
sorry dude but this made my game run horrible


:(

im just going to leave it the way it was

legacy-R0B0T
03-28-2004, 12:35 AM
me and some friends were talking and we were thinking that it has something to do with the gaming engine and newer cards that make it run better at higher res, i dont know if thats true for the bit color(16,32) but when i tried going from 32 to 16 it didnt get worse or better seems like it runs great at 32 bit, and doesnt get better at 16

legacy-coldplasma
03-28-2004, 04:57 AM
ive got a few pointers here.

MinDesiredFramerate disables special effects (like the spiral around the shock beam) when your framerate goes below what you put here.

Increasing your resolution DOES NOT increase performance, it significantly drains it as it gives your video card more pixels to draw.

VSync set to "True" caps your framerate at your refresh rate so your dont get video tearing, hence, lagging your framerate. Setting it to "False" allows it to surpass your refresh rate.

What you have said in this post ONLY and i repeat ONLY increasing video quality, but at a performance cost.